Winmail Server 系統介紹

系統介紹

Winmail Server 是安全易用全功能的郵件伺服器軟體， 不僅支持SMTP/POP3/IMAP/Webmail/LDAP(公用位址簿)/多域/發信認證/反垃圾郵件/郵件過濾/系統通信組/公共郵件夾等標準郵件功能， 還有提供分散式部署/協力廠商認證/系統遷移/PushMail/RBL/SPF/SpamAssassin/DKIM/郵件簽核/郵件殺毒/郵件監控/微信綁定/釘釘綁定/支援IIS,Apache/網路硬碟及共用/郵件密級/郵件撤回/短信提醒/唯讀郵箱/定時郵件/郵件備份/SSL安全傳輸協定/郵件閘道/動態功能變數名稱支援/遠端系統管理/Web 管理/獨立域管理員/線上註冊/二次開發介面等特色功能。 它既可以作為互聯網郵件伺服器、局域網郵件伺服器，也可以作為ADSL等動態接入方式的郵件伺服器和郵件閘道。

運行環境

• 硬體設定 至少 Intel P4以上CPU, 硬碟100G, 記憶體1024M。
• 軟體要求 中英文 Windows XP/2003/2008/Windows 7/Windows 8/2012/Windows 10/2016 等 Win32/64 作業系統平臺。
• 網路要求 安裝並正確配置TCP/IP的網卡，架設互聯網郵件伺服器需要公網Ip和正式註冊的功能變數名稱。

主要特點

• 支援通用郵件用戶端軟體 Outlook、Windows Live Mail、Foxmail、 等收發郵件。
• 提供多語言多風格全功能 Webmail，可以在網頁上線上註冊新郵箱、收發郵件、修改密碼、線上預覽 Office 附件、自動轉發、自動回復、設置短信等操作。
• 支援郵件殺毒功能，支援四種模式，支援幾乎所有的殺毒引擎，有效的攔截、清除帶毒郵件。白金版支援內嵌查毒引擎，支援自動更新。Winmail 和殺毒引擎
• 支援 Internet 光?專線、主機託管、雲主機、VPS收發郵件，以及ADSL等動態接入方式的連接 Internet 收發郵件。
• 支持 ESMTP 驗證(SMTP 發信認證)，更安全。
• 支援 IMAP，可以在伺服器上操作郵件, 支援中文郵件夾和子資料夾。
• 支持公用位址簿，Outlook、Foxmail、、Webmail 等可查看, 方便企業共用使用者資訊。
• 支持公共郵件夾功能, 可以設置讀寫許可權，方便企業共用公用資訊。Webmail 可以讀寫郵件，也可以在 Outlook, Foxmail 裡查看。
• 白金版支援分散式部署功能，支援單功能變數名稱多主機，滿足多分支機搆系統架設需求。
• 白金版支持協力廠商 LDAP 認證、Radius 認證。
• 白金版支援用戶密級和郵件密級。郵箱用戶不可以發送和閱讀高於自己密級的郵件。
• 對 SMTP, POP3, IMAP, LDAP, HTTP 可以支援 SSL 加密傳輸, 防止網路偵聽, 通信更安全。
• 提供多種 Webmail 頁面風格，支援移動設備：普通手機、智慧手機、平板, 提供 iPad 專用 Webmail。
• 白金版提供 Push Mail 模組，可以用常用的智慧手機和移動設備同步郵件、連絡人、行事曆，支援 iPhone、iPad、Android等。
• Webmail 全面支持 UTF-8。
• 提供網路磁片功能，可以設置有密碼保護的共用，可通過 Webmail 或通用的 FTP 用戶端軟體來訪問。
• 提供網路行事曆和網路記事本服務，標準化行事曆，相容 Outlook、Foxmail，支援共用。
• 支持創建、導入、匯出 CA SSL 證書。
• 支援密碼安全性原則，支援密碼強度設定，支援定期改密碼。
• 提供郵箱密碼被猜解行為檢測功能，支援異地登錄提醒功能。
• 提供郵箱被盜用轉發垃圾郵件行為檢測功能。
• 支持郵件撤回功能, 支持 Webmail 和 Outlook，其他用戶端發送的郵件滿足條件的也可以在 Webmail 上進行撤回。
• 提供自動遷移協力廠商郵件系統資料的郵箱搬家功能，自動遷移原系統帳戶、密碼和郵件.
• 支持新郵件手機短信提醒，微信提醒和釘釘提醒，有新郵件到達時，可在手機上及時獲得通知。
• 支持郵件簽核，可以在郵件發出前進行簽核，支持條件簽核，支持收件簽核。
• 完全支持多域(虛擬域)。可以在單機中安裝多個郵件域。
• 可與 Windows AD 帳號進行整合，方便管理。白金版支援自動同步 AD 中帳戶。
• 白金版支援 Outlook 2013 Pushmail連接方式，支援郵件、日曆、連絡人、任務同步。本功能也支援常用的智慧手機和移動設備。
• 提供帳號導入,匯出功能, 方便升級伺服器。
• 將 Webmail 設置為 IIS 和 Apache 的虛擬目錄或虛擬網站。Webmail 與其他 Web 伺服器整合
• 提供快速設置嚮導, 只需輸入幾個簡單參數, 讓您一分鐘內設置好郵件系統。
• 提供 SMTP/POP3/IMAP4 客戶 IP 訪問頻率限制的功能.
• 提供 SMTP/POP3/IMAP4 同一 IP 同時連接次數限制的功能.
• 多IP伺服器，可以設置外發郵件連出ip，可選擇網卡上綁定的ip，支援單網卡多ip和多網卡多ip.
• 支援管理員新建、刪除、禁用用戶郵箱和設置用戶郵箱大小。
• 可控制單用戶發外部郵件，收外部郵件，修改密碼等多項功能許可權，可設置帳號有效時間。
• 可以設置唯讀郵箱，用戶無法刪除郵件，包括用戶端和 Webmail。
• Webmail 支援發送定時郵件。
• Webmail 可發送加密碼郵件，同時也相容 Foxmail 和騰訊郵箱系統相關功能。
• Webmail 裡可以查看本郵箱的訪問記錄、發信記錄、刪信記錄、隔離郵件。
• 白金版支援發信流量控制，系統、域、郵箱可以設置每小時和每日發信量。
• 白金版支援查看使用者郵箱訪問記錄、發郵件記錄、收郵件記錄。
• 允許創建多個管理員, 支援單獨的域管理員功能。
• 管理員可以遠端系統管理伺服器，連線協定採用了 SSL 加密。
• 支援 Web 管理, 管理員可以進行在網頁上線上管理系統的郵箱和功能變數名稱。
• 用戶既可以接收公司內部的郵件，也可以接收通過Internet發來的郵件。
• 用戶可以發送郵件到公司內部的用戶，也可以發送郵件到Internet上其他用戶。
• 支援多層級系統通信組，發往系統通信組郵寄地址的郵件會自動分發給每個組成員, 支持 Everyone 組。
• 支援兩種方式的郵件閘道：POP3下載和ETRN下載，可以實現多人共用一個郵件帳號而互不干擾。
• 支援垃圾郵寄地址、IP、功能變數名稱過濾、SPF檢查、RBL(Real-time Blackhole Lists)檢查、DBL檢查、白名單，識別虛假信頭。
• 支援灰名單(Greylisting)和連接延遲回應反垃圾功能。
• 支援 DKIM 過濾和簽名，設置 DKIM 也可以提高外發郵件的到達率。
• 支援系統級和郵箱級自訂過濾規則。
• 反垃圾郵件支援隔離區功能，用戶和管理員可以取回和設置白名單，使用者每天會收到系統發的隔離通知郵件。
• 過濾整合 SpamAssassin, 實現智慧化自學習過濾。
• 郵箱用戶可以設置個人級寄件者黑白名單，個人位址簿中的連絡人自動加入白名單。
• 支援過濾指定的附件檔案名、類型和附件個數過濾功能。
• 支援郵件歸檔功能, 可以將所有收發的郵件備份到指定郵箱或目錄，使用者和管理員可以在 Web 上查詢、下載和恢復系統歸檔郵件，可以設置歸檔資料保留時間，支援單副本存儲。
• 支援系統級備份和恢復功能, 可以設置自動備份，可以設置備份資料檔案保留時間。
• 支持將 MS-TNEF (winmail.dat) 類型附件自動剝離功能。
• 支持計畫任務, 可設置執行時間段。
• 支援郵箱雙向監控功能，被監控郵箱和監控人郵箱可以任意組合，支援條件監控，讓管理無漏洞。
• 顯示當前的當前活動連接，系統狀態統計。
• 顯示各系統服務流量統計圖。
• 多種郵箱使用情況報表，讓管理員及時瞭解系統運行狀況。
• 多執行緒設計，滿足大量用戶的同時訪問。
• 系統故障和恢復，不丟信，不併發衝突，不鎖死。
• 系統退信可以設置語言，支援簡體、繁體、英文，簡體中文退信裡提供原因解釋和處理建議。
• 記錄系統運行情況和各伺服器的訪問日誌。
• 管理工具提供多語言版本，目前版本支援英文、簡體中文和繁體中文。
• 操作方便、通俗易懂。
• 支援固定IP和動態IP接入 Internet 方式。
• 方便地安裝和反安裝 Install/Uninstall。
• 提供COM 介面元件, 可以程式設計操作用戶帳號,功能變數名稱,管理員, 提供 asp, php, asp.net, c++, java 實例。
• 提供 OpenAPI 二次開發介面，HTTP 協定請求使用 GET/POST 方式，返回資料採用 JSON 格式, 方便與其他企業應用全面整合。


功能模組

它主要具有以下功能模組群組成﹕

• SMTP 服務
SMTP服務可以支援多網域名稱､域別名､ESMTP 發信驗證等功能﹐可以將外發郵件通過MX記錄直接遞送給目的網域名稱﹐也可以將其遞送某臺外發郵件伺服器（如﹕ISP的SMTP伺服器）﹐ 並支援 SSL 安全傳輸通訊協定加密通信。

• POP3 服務
用戶可以通過一般的郵件用戶端軟體 Outlook､Foxmail､Windows Live Mail 等來收取伺服器上的郵件﹐並支援 SSL 安全傳輸通訊協定加密通信。

• IMAP 服務
用戶可以通過一般的郵件用戶端軟體 Outlook､Foxmail､Windows Live Mail 等來直接操作伺服器上的郵件, 支援中文郵件夾和子檔案夾﹐並支援 SSL 安全傳輸通訊協定加密通信。

• Webmail 服務
提供多種語言﹐多種介面風格的全功能 Webmail, 可以在網頁上在線註冊新郵箱, 收發郵件, 修改密碼, 在線預視 Office 附件､自動轉發､自動回復､設定短信等操作。 並支援 SSL 加密通信。 目前支援簡體中文/繁體中文/英文/法語/德語/日語/韓語/西班牙語/等多種語言。Webmail 可以與其他 Web 伺服器整合
提供多種 Webmail 頁面型式﹐支援移動設備﹕普通手機､智能手機､平板, 提供移動設備專用 Webmail。
可發送加密碼郵件﹐同時也相容 Foxmail 和騰訊郵箱系統相關功能。可以查看本郵箱的存取記錄､發信記錄､刪信記錄､隔離郵件。 系統後臺經過組態後﹐Webmail 可以在線預視 Office 附件。

• 公用位址簿 (LDAP 服務)
用戶可以通過 Webmail､Office Outlook(使用插件)､Foxmail(使用插件)直接參看公用位址簿中的用戶資訊﹐ Outlook 也直接存取公用位址簿。

• 公共郵件夾
支援公共郵件夾功能, 可以設定讀寫解除權限。有權限的用戶可以在 Webmail 上進行郵件讀寫﹐也可以通過 Outlook､Foxmail 等支援 IMAP 通訊協定的用戶端軟體查看公共郵件夾中的郵件。

• 密碼安全策略
支援密碼安全策略﹐可以設定密碼強度﹐支援定期改密碼﹐可以設定下次登入必須修改密碼。 提供郵箱密碼被猜解行為偵測功能﹐提供郵箱被盜用轉發垃圾郵件行為偵測功能﹐支援異地登入提醒功能。

• 郵件撤回功能
支援郵件撤回功能, 支援 Webmail 和 Outlook﹐其他用戶端發送的郵件滿足條件的也可以在 Webmail 上進行撤回。

• 網路磁碟
提供網路磁碟功能﹐並且可以設定有密碼保護的共享。可以通過 Webmail 或 一般的的 FTP 用戶端軟體來上傳與下載網路磁碟中的檔案。可以將網路磁碟上的檔案以附件方式或者鏈接方式發郵件。

• 網路行事歷與記事本
提供網路行事歷功能和記事本﹐用戶可以設定事件與任務來提醒完成某項任務。標準化行事歷﹐相容 Outlook､Foxmail﹐支援共享。

• 中繼轉發
通過別人的郵件伺服器(中繼伺服器)將你的郵件系統的郵件遞送到目標位址。 Winmail 支援多中繼﹐即使您伺服器的IP在對方的垃圾郵件黑名單中﹐郵件照發不誤。

• 郵件簽核與監控
管理員可以限制一些用戶發信是否要經過指定管理員簽核。簽核管理員可以允許和拒絕需要簽核的用戶發送郵件。可以設定要簽核郵件的條件﹐滿足條件的郵件才簽核。
支援收件簽核。管理員對一些用戶接收和發送的郵件進行監控﹐自動拷貝一份給管理員﹐可以設定要監控郵件的條件﹐滿足條件的郵件才監控。

• 郵件殺毒
支援郵件殺毒功能﹐支援四種模式﹐支援幾乎所有的殺毒引擎﹐有效的攔截､清除帶毒郵件。白金版支援內嵌查毒引擎﹐支援自動更新。
Winmail 和殺毒引擎

• 郵件密級
[白金版]支援用戶密級與郵件密級控制﹐密級從低到高分為“無”､“限制”､“秘密”和“機密”﹐對應的郵件也分“無”､“限制”､“秘密”和“機密”三個密級﹐郵箱用戶不可以發送和閱讀高於自己密級的郵件。

• Push Mail
[白金版]可以用常用的智能手機和移動設備同步郵件､聯繫人和日歷﹐支援 iPhone､iPad､Android等﹐也支援 Outlook 2013 同步。

• 新郵件提醒
支援短信提醒﹐有新郵件到達時﹐可在手機上獲得通知。採用網路短信平臺通道和 GSM 短信貓兩種工作方式。
支援系統級新郵件訊息推送﹐可指定 URL﹐數據格式支援 JSON､XML､Form。
支援與微信認證服務號或企業微信整合﹐可以實現新郵件微信通知（企業微信）﹐微信中登入 Webmail 收發郵件﹐微信裏可以定制郵件相關選單項。 Winmail 與微信綁定
支援與釘釘整合﹐可以實現新郵件釘釘通知﹐釘釘中登入 Webmail 收發郵件﹐釘釘裏可以增加郵件微應用。 Winmail 與釘釘綁定

• 快速設定向導和系統遷移
本系統的提供快速設定向導工具, 只需輸入幾個簡單參數, 讓您一分鐘內設定好郵件系統。 具體請見 裝設與初始化設定。
提供自動遷移第三方郵件系統數據的郵箱搬家功能﹐自動遷移原系統賬戶､密碼﹐後臺使用POP3､IMAP下載原系統郵件﹐ 也支援不同網域名稱之間的遷移﹐以滿足更新網域名稱的要求。

• 多域
完全支援多域(虛擬域)﹐可以在單機中裝設多個郵件域。

• Windows AD 認證和第三方認證
系統中的郵箱用戶可以與 Windows AD 系統用戶進行整合﹐收發的郵件的認證採用 AD 進行認證﹐提系統的安全性﹐降低系統維護的複雜性。 白金版支援自動同步 AD 中賬戶﹐還支援第三方 LDAP､Radius 認證。

• 用戶管理
管理員可以新建､解除､禁用用戶郵箱和設定用戶郵箱大小､最多的郵件數､最大的允許發郵件位元組數﹐以及用戶資訊是否公開等。可控制單用戶發外部郵件﹐收外部郵件﹐修改密碼等多項功能權限﹐可設定有效時間。可按部門管理用戶。可以設定唯讀郵箱﹐用戶無法解除郵件﹐包括用戶端和 Webmail。 用戶可以導入和導出。

• 系統通信群組（郵件群組､用戶群組）
管理員可以根據情況設定一些系統通信群組（郵件群組､用戶群組）﹐系統會將發往系統通信群組的郵件自動分發給每個群組成員, 支援 Everyone 群組, 支援外部郵箱位址。支援多層級系統通信群組﹐實現樹形企業通訊錄。系統通訊群組可以導入和導出。白金版﹕ 系統通信群組可以排序﹐系統通信群組成員可以排序。

• 郵件通訊閘
本系統還可以作為區域網路的郵件通訊閘﹐自動收取遠端伺服器上指定帳號的郵件﹐然後按照預設定的規則進行郵件分發給本地用戶的功能。系統主要以兩種方式來收取遠端郵件﹕POP3收取和ETRN下載。 可以實現多人共享一個郵件帳號而互不干擾。

• 遠端管理
本系統的管理工具可以遠端管理郵件伺服器﹐讓管理員可以管理遠在托管中心的郵件伺服器﹐並支援同時管理多臺伺服器﹐通訊協定採用SSL加密。 允許建立多個管理員, 支援單獨的域管理員功能。支援 Web 管理, 管理員可以進行在網頁上在線管理系統的郵箱和網域名稱。

• 垃圾過濾
本郵件系統還提供了 IP 位址﹐網域名稱﹐郵件來源﹐郵件頭內容﹐郵件信體等方式的過濾﹐有效的的防止垃圾郵件和非法資訊﹔支援SPF､RBL(Real Black List) 檢查､DBL(Domain Black List)檢查﹔支援白名單和識別虛假信頭﹔支援過濾指定的附件檔案名稱﹐型式和附件個數過濾功能。
提供自定義的系統級和郵箱級過濾規則。整合 SpamAssassin, 實現智能化自學習過濾。
郵箱用戶可以設定個人級發件人黑白名單﹐個人位址簿中的聯繫人自動加入白名單。
支援灰名單(Greylisting)和連接延遲響應反垃圾功能。
支援 DKIM 過濾和簽名﹐設定 DKIM 也可以提高外發郵件的到達率。
垃圾郵件處理方式支援放入隔離區﹐用戶和管理員可以取回郵件和設定白名單﹐用戶可以收到系統發的隔離通知郵件﹐在郵件可以點擊鏈接取回。
支援郵件內嵌圖片裏文字識別過濾﹐有效過濾圖片垃圾郵件。支援在線更新垃圾郵件規則庫。

• 分散式部署
白金版支援分散式部署郵件系統﹐支援單網域名稱多主機﹐滿足多分支機構系統架設需求﹐支援不同地點不同網路下系統整體化部署﹐支援同環境下不同主機分但式部署。支援群組織內賬號､用戶群組資訊同步﹐支援賬號批量遷移。可實現負載均衡架構。

• 計劃任務
管理員可以設定一些在某個特定時間或按某一個周期執行的任務（如﹐發送郵件到遠端服器﹐收取遠端伺服器的郵件）﹐還可以設定定期清理用戶指定郵件夾下的郵件﹐處理長期不使用的郵箱。

• 存取控制
提供 SMTP/POP3/IMAP4 服務 IP 存取頻率限制的功能﹐提供 SMTP/POP3/IMAP4 同一 IP 同時連接次數限制的功能﹐ 可以針對特定用戶設定特定服務存取控制。

• 系統日誌和流量統計圖
提供詳細的系統執行日誌﹐分 system(系統)､smtp､pop3､imap､queue(佇列)､webmail､ftp(網路磁碟)､msms(短信/微信)､admin(管理) ﹐以便管理員能隨時的了解系統執行情況或分析錯誤資訊。
系統日誌可以設定記錄語言﹐支援簡體､繁體､英文。
顯示各系統服務流量統計圖﹐數據保留30天。
多種郵箱用戶使用情況報表﹐讓管理員及時了解系統執行狀況。

• 流量統計和控制
[白金版]可以記錄用戶郵箱存取記錄､收信記錄和發信記錄﹐支援發信流量控制﹐可以設定系統､域､郵箱可以設定每小時和每日發信量。

• 系統備份和恢復
支援系統級備份和恢復功能, 可選擇備份系統設定數據和用戶郵件數據, 可以自動進行﹐可以設定備份保留時間。

• 系統郵件歸檔
支援收發郵件即時歸檔功能﹐用戶和管理員可以在 Web 上查詢和恢復系統歸檔郵件。可以設定歸檔郵件數據保留時間。

• 二次開發接口
提供 COM 接口群組件, 可以程式設計操作用戶賬號,網域名稱,管理員, 提供 asp, php, asp.net, c++, java 實例。提供遠端 http url 開發接口和 Webmail 部分頁面嵌入開發敘述。
提供 OpenAPI 二次開發接口﹐HTTP 通訊協定請求使用 GET/POST 方式﹐返回數據採用 JSON 格式, 方便與其他企業應用全面整合。


裝設與初始化設定

安裝與初始化設置

準備

如果您還沒有 Winmail Server 安裝包，可以到 http://www.winmail.cn/download.php 去下載最新的安裝程式；
如果您想要伺服器可以給 Internet 上的其他信箱發信（如: test@163.com），您必須保證要安裝的伺服器可以聯接 Internet，並設置了可用的 DNS；
如果您想要接收來自 Internet 的郵件，必須要擁有 Internet 上的合法功能變數名稱（如：ourcompany.com），並將此功能變數名稱MX解析到您的郵件伺服器IP地址。如果你沒有固定的IP位址，可以參考應用實例。

安裝

在安裝本系統之前，首先必須選定作業系統平臺，可以考慮安裝在 Windows 2016 等作業系統。然後運行安裝包按照螢幕提示進行安裝。

在安裝過程中，安裝程式會讓您進行一些必要的選擇，如安裝元件、安裝目錄、運行方式以及設置管理員的登陸密碼。

安裝組件

安裝元件有伺服器核心(Server) 和 管理工具(Admin)兩部份。管理工具支援遠端系統管理，為了方便郵件系統管理員的日常管理，管理工具可以單獨安裝到另外一台電腦上。

選擇運行方式、設定檔處理、預設語種

伺服器核心(Server)運行方式主要有兩種：作為系統服務運行和單獨程式運行；兩種運行方式的主要區別在於：系統服務運行方式，只需要電腦啟動後，無需要登錄到系統，程式就能夠自動的運行；單獨程式運行方式必須在使用者登錄系統後才能運行。 建議伺服器核心程式採用以系統服務方式運行。

設置管理員的登陸密碼

安裝過程中，如果是檢測到是第一次安裝，或您選擇覆蓋已有的設定檔時，安裝程式會提示的輸入郵件系統管理員的登陸密碼(必須輸入)。默認的管理員名是 admin 。

在安裝完成後，可以啟動郵件伺服器程式。這時應該會在系統託盤區的圖示上顯示一個伺服器的圖示。 表示成功運行。 表示運行失敗。

運行失敗的可能有以下幾種情況：
1. 管理埠6000被佔用，解決辦法請見：安裝後,為什麼總是不能啟動SMTP/POP3/ADMIN/HTTP/IMAP/LDAP服務？
2. 以前裝過同一版本的軟體，並且已經超過試用期。
3. 授權不正確。如用戶數超過授權許可。

初始化設置

在成功運行後，管理員必須對系統進行一些初始化設置，系統才能正常運行。伺服器在啟動時如果發現還沒有設置功能變數名稱會自動運行快速設置嚮導，用戶可以用它來簡單快速的設置郵件伺服器。當然用戶也可以不用快速設置嚮導，用傳統的管理端設置方法。

快速設置嚮導設置

使用者輸入一個要新建的郵箱位址及密碼，點擊“設置”按鈕，設置嚮導會自動查找資料庫是否存在要建的郵箱，如果發現不存在嚮導會向資料庫中增加新功能變數名稱和新的郵箱，同時嚮導也會測試 SMTP/POP3/ADMIN/HTTP 伺服器是否啟動成功以及是否要停止 IIS 中的 SMTP 服務。設置結束後，在設置結果欄中會報告設置資訊及伺服器測試資訊，設置結果的最下面是也會給出有關郵件用戶端軟體的設置資訊。

管理端設置

1.登陸管理端程式

運行 Winmail Server 伺服器程式或按兩下系統託盤區的 [image] 圖示，使用用戶名(admin)和在安裝時設定的密碼登陸，有關管理工具的使用請見：管理工具

2.檢查系統運行狀態

使用"系統設置"/"系統服務"查看系統的 SMTP，POP3，ADMIN 服務是否正常運行， 可能會發現 SMTP 或 POP3 沒有啟動成功，使用"系統日誌"/"SYSTEM"查看系統的日誌資訊，一般顯示Port被佔用無法啟動，請關閉佔用程式或者更換埠再重新開機相關的服務，例如在Win Windows 缺省安裝時會 安裝IIS的SMTP服務，從而導致郵件系統SMTP起不來。如果您找不到佔用程式，可以用 fport 軟體查看那個程式佔用了埠，可到 http://www.winmail.cn/download_other.php 下載。

3.設置郵件域

為郵件系統設置一個域，如 ourcompany.com。請使用"功能變數名稱設置"/"功能變數名稱管理"，具體請見 域操作。

4.增加郵箱

使用"用戶和組"/"用戶管理"加入幾個郵箱，有關操作請見 用戶管理。

收發信測試

可以使用常用的郵件用戶端軟體，如 Outlook，Foxmail 來測試，“發送郵件伺服器(smtp)”和“內送郵件伺服器(pop3)”項中設置為郵件伺服器的IP位址或主機名稱，pop3 用戶名和口令要輸入用戶管理管理中設定的。

也可以用 Webmail 進行測試, 登陸位址是 http://yourserverip:6080/
也可以用 Webadmin 進行郵件系統管理, 登陸位址是 http://yourserverip:6080/admin/
注意：系統強制啟用SMTP發信認證，使用者在用戶端軟體中增加帳號時也必須設置SMTP發信認證。

對上述安裝設置步驟如果還有問題，請見更詳細的文檔“Winmail Winmail 架設指南”


管理工具

郵件系統的管理可以通過專門提供的管理工具程式和 Web 管理兩種方式。管理工具功能全面可以管理全部系統設置，支援遠端系統管理。 Web 管理可以管理郵箱和功能變數名稱基本設置。

啟動

使用者在安裝郵件系統，如果在“選擇元件”時，選擇了“管理工具”，安裝結束後就可以從“開始”->“程式”->“Magic Winmail”->“Magic Winmail管理工具”啟動管理工具。當然如果在安裝時，選擇了創建快捷方式，也可從桌面圖示，快捷工具條上啟動管理工具。用戶也可以單獨下載管理工具的安裝包進行安裝。您可以到 http://www.winmail.cn/download.php 去下載最新的管理工具安裝程式。

使用

使用者啟用管理工具就可以看到如下的畫面。

如果這時候沒有出現登錄視窗，請點擊功能表上“連接”->“連接伺服器...”。

如果您想管理本地的郵件伺服器，請在“被管理伺服器”中選擇“本地主機”；如果您想管理遠端的郵件伺服器，請在“被管理伺服器”中選擇“遠端主機”，並輸入主機名稱或 IP 位址和連接埠。輸入管理員的用戶名和密碼。同時您也可能選擇“啟動時顯示此對話方塊”，以便每次啟動時能自動顯示登錄視窗。使用者登錄後，會見到如下的畫面：

這時候您可以在左邊選擇要管理的專案，在右邊的畫面中選擇參數設置等。

在使用管理工具時，最好使用管理工具與郵件伺服器軟體是同一版本號的。一般管理工具的伺服器版本不能低於郵件伺服器軟體的版本號。

如在登錄時“伺服器無回應”的提示框，則表示郵件伺服器沒有啟動或管理服務程式沒有啟動。
如在登錄時“Your IP address has been denied!”的提示框，則表示您的機器不允許被連接。
如在登錄時“Login failure! The username or password is error.”的提示框，則表示用戶名和密碼不正確。
如在登錄時“The server has too many concurrents, please try again later!”的提示框，則表示伺服器同時線上的併發連接數太多，稍後再試。
在進行管理時，如果長時間等候狀態，沒有操作動作，系統將會提示“Your session is time out, please login again!”，這時請重新登錄。

Web 管理

為方便管理員進行郵箱用戶的日常維護，郵件系統還提供了“Web 管理”。

登陸地址是 http://yourserverip:6080/admin/

輸入管理員的用戶名和密碼， 支援域管理員。

用戶登錄後，管理員可以對有許可權功能變數名稱及功能變數名稱下的用戶，組和別名進行管理。


系統資訊

系統資訊中主要列出了一些伺服器系統資訊(如﹕作業系統版號﹐記憶體情況﹐磁碟情況等)和有關本系統的情況(如﹕是否已授權﹐最多可用郵箱數﹐還能使用的天數等)。

系統超級管理員可以在系統資訊中﹐查看作業系統的資訊及本系統的資訊﹔一般域管理員在登入後﹐只查看到有關本系統的資訊。具體資訊如下圖所示﹕


系統設定

系統服務
SMTP設定
郵件通訊閘
計劃任務
進階設定
公共郵件夾
防病毒設定
新郵件提醒
系統備份


系統服務

系統服務中主要列出了系統中所有提供的服務的執行狀態﹐綁定位址以及連接埠﹐超級管理員可以選擇某個服務進行設定或啟停。

服務功能

ADMIN 服務 | 本郵件系統所用的管理服務﹐管理工具可以通過此服務對郵件系統伺服器進行的管理﹐此服務不能停止。如果此服務啟動失敗﹐則郵件系統不能正常執行。ADMIN 是 SSL 安全傳輸通訊協定加密的。
SMTP 服務 | (Simple Mail Transfer Protocol﹐簡單郵件傳輸通訊協定) SMTP 服務用於發送郵件和接收其它郵件伺服器發過來的郵件。
SMTP MSA 服務 | 功能與 SMTP 服務類似﹐主要用於用戶端與伺服器之間發信﹐必須要進行發信認證。
Secure SMTP 服務 | 通過 SSL 安全傳輸通訊協定加密的 SMTP 服務﹐防止網路監聽。
POP3 服務 | (Post Office Protocol﹐郵局通訊協定) 用戶通過用戶端軟體將存放在其郵箱中的郵件接收到本地。
Secure POP3 服務 | 通過 SSL 安全傳輸通訊協定加密的 POP3 服務﹐防止網路監聽。
IMAP 服務 | (Internet Message Access Protocol﹐Internet 郵件存取通訊協定) 用戶通過 Internet 直接在伺服器上存取郵箱中的郵件。
Secure IMAP 服務 | 通過 SSL 安全傳輸通訊協定加密的 IMAP 服務﹐防止網路監聽。
HTTP 服務 | (Hypertext Transfer Protocol﹐超檔案傳輸通訊協定) Webmail 程式操作所用的通訊協定。
Secure HTTP 服務 | 通過 SSL 安全傳輸通訊協定加密的 HTTP 服務﹐防止網路監聽。
FTP 服務 | (File Transfer Protocol 檔案轉送[輸]通訊協定) 網路磁碟所用的通訊協定。
Secure FTP 服務 | 通過 SSL 安全傳輸通訊協定加密的 FTP 服務﹐防止網路監聽。
LDAP 服務 | (Lightwighted Directory Access Protocol 輕目錄存取通訊協定) 分散式目錄型資料庫伺服器﹐主要存放公用位址簿﹐方便用戶查詢公共聯繫人。
MSMS 服務 | 新郵件訊息通知發送服務。

功能選項

1.啟動

從服務清單中選擇某一已經停止服務﹐進行啟動。如果服務一直啟動不成功﹐應該到“系統日誌”/“SYSTEM”中去查看啟動失敗的原因。
一般失敗原因都是所用連接埠被佔用。具請解決辦法請見﹕裝設後,為什麼總是不能啟動SMTP/POP3/ADMIN/HTTP/IMAP/LDAP服務﹖

2.停止

從服務清單中選擇某一正在執行的服務﹐進行停止。
注意﹕ADMIN 服務是為郵件系統的管理提供服務﹐不允許停止。

3.設定

對已選的服務進行參數設定﹐如修改綁定 IP 位址﹐監聽連接埠﹐存取控制設定等。

基本參數

IP 和連接埠 | 增加服務要綁定的 IP 位址和偵聽的連接埠﹐可以增加多個IP位址和連接埠。
並發連接數 | 同時允許的最多並發連接數量﹐超過會拒絕連接。
超時時間 | 網路連接﹐數據傳輸的最長等待時間﹐單位﹕秒。
本系統啟動時自動執行 | 系統啟動時啟用該服務﹐如果不希望開啟某個服務﹐請不要勾選此選擇項。
設定立即重啟該服務 | 選擇此項後﹐點擊“確定”﹐即會重啟該服務。

點擊“增加”﹐從網卡上選擇 IP 位址﹐設定服務要偵聽的連接埠

存取控制

不限制存取服務的 IP 位址 | 任意的 IP 位址都能存取該服務。
禁止以下 IP 位址存取服務 | 列示方塊中的 IP 位址不允許存取該服務。限制某一段的 IP 位址﹐如 192.168.0. 這個網段的所有 IP﹐可以輸入 192.168.0.即可。
只允許以下 IP 位址存取服務 | 只有列示方塊中的 IP 位址才有權存取該服務。允許某一段的 IP 位址﹐如 192.168.0. 這個網段的所有 IP﹐可以輸入 192.168.0.即可。

頻率控制

每個 IP 的最大連接並發數 | 每個 IP 的同時連接伺服器的最大連接數。
每分鐘每個 IP 最大連接數 | 每分鐘﹐每個 IP 允許連接的最大數。
不受限制的 IP 清單 | 在列示方塊中的 IP 位址不受上述的兩種情況限制。

注意事項

1. SMTP 服務一般不能修改連接埠﹐要用 25﹐如果 SMTP 服務修改了連接埠﹐其他郵件系統無法給你發信。
2. 目前 HTTP 服務不是採用的標準連接埠 80﹐而是用的 6080 連接埠﹐所以用戶在使用Webmail時,必須注意指定連接埠。如在本機存取時﹐IE的位址欄必須輸入 http://yourserverip:6080/ 當然如果您的伺服器上沒有其他 HTTP 服務使用 80 連接埠, 您可以將 Winmail 的 HTTP 服務的連接埠改為 80, 這樣就可以直接使用 http://yourserverip/
3. 如果伺服器一塊網卡有兩個位址（內部位址或為外部位址）﹐如果要讓兩個位址都能存取﹐請設定SMTP/POP3/IMAP屬性的“綁定位址”不應該設為固定位址（內部位址或為外部位址）﹐應該設為0.0.0.0（伺服器上的所有IP位址）。


SMTP 設定

主要是對 SMTP 服務和郵件遞送的各參數進行設定。

基本參數

系統管理員郵箱 | 接收系統錯誤信件或發送系統錯誤郵件的郵箱。請填寫有效的本系統內郵箱位址﹐請不要清空。經常查看此郵箱可以及時了解系統的執行狀態。
HELO/EHLO 主機名 | SMTP 命令互動過程中﹐HELO/EHLO 用的主機名。空白表示使用主網域名稱。這裏一般填寫能解析到郵件系統外網 IP 的主機名﹐如﹕mail.demo.com
每封郵件的最多收件人數 | 每封郵件最多允許的收件人數。
每封郵件的最大位元組數 | 每封郵件允許的最大位元組數。指信頭（發件人﹐收件人﹐郵件主題﹐發信時間等內容）﹐編碼後的郵件內容﹐編碼的後的所有附件的位元組總和。
接收外域郵件最大位元組數 | 接收來自外域郵箱的郵件時﹐允許的最大位元組數。
發往外域郵件最大位元組數 | 向外域郵箱發送郵件時﹐允許的最大位元組數。
接收郵件的最多跳數 | SMTP 服務允許郵件最多經過的 SMTP 伺服器個數。郵件每經過一個郵件伺服器一般都會在郵件頭上增加一個 Received 欄位﹐這裏主要計算 Received 個數
單次連接最多的重置次數 | SMTP 服務一次連接時﹐所允許的最多的重置次數（REST 命令次數）。
佇列中失敗郵件的重試間隔時間 | 郵件遞送失敗後﹐在佇列中等待多長時間進行重新發送。建議值﹕20 分鐘
佇列中郵件的最長停留時間 | 郵件遞送失敗後﹐在佇列中最長停留多長時間。建議值﹕2 小時
佇列中未簽核郵件的最長等待時間 | 需要等待簽核的郵件﹐在佇列中等待管理員簽核﹐最長等待時間。
連接遠端主機的超時間 | 外發郵件時﹐連接遠端主機的超時時間。
外發郵件時連出 IP 位址 | 外發郵件時﹐綁定此 IP 發送郵件.如果伺服器有多個 IP﹐可以設定其中一個 IP 作為外發 IP﹐不是本機的 IP 填寫無效。
啟用發信認證 | 只有經過身份認證的用戶才能使用 SMTP 服務轉發郵件。可以有效的防止非信任主機借用伺服器發垃圾郵件。這個選項預設選中﹐無法修改的。
認證發信時發件人必須是本系統的域下用戶 | 認證發郵件時﹐發件人位址必須是本系統中的郵箱位址。
發件人和認證用戶必須一致 | 發件人和認證用戶必須是同一郵箱帳號。可以有效防止系統內沒有權限外發的用戶借用有權限外發的帳號來發郵件。
以本系統中網域名稱發郵件時必須認證 | 以包含本系統中網域名稱的郵件位址來發郵件時必須認證。可以防止發垃圾郵件者偽造發件人來發垃圾郵件。
將 MS-TNEF 郵件轉換成MIME格式郵件 | MS-TNEF 是 Microsoft Outlook 的特殊格式郵件（只有一個名為 winmail.dat 的附件）﹐大多數非 Outlook 的郵件用戶端軟體都不能正常的解析。 啟用此功能後﹐能自動的將 MS-TNEF 的郵件轉換為一般的的 MIME 格式的郵件。
支援 STARTLS 命令(SSL/TLS 傳輸) | 接受外部郵件時, 可以支援安全連接（SSL）。一般遠端伺服器會自選擇連接方式。
支援 VRFY/EXPN 命令 | 支援 SMTP 的 VRFY/EXPN 命令。有的郵件系統(例如﹕verizon.net )需要該指令做驗證。
禁止明文認證 | 啟用此項後﹐SMTP 服務禁止用 PLAIN 和 LOGIN 的認證方式﹔Secure SMTP 和 SMTP MSA 服務﹐不受影響。
禁止 25 連接埠認證 | 啟用此項後﹐偵聽 25 連接埠的 SMTP 服務不允許提供認證功能﹐可以有效的防止的外網連接猜測密碼。
郵件頭增加“Sender”欄位 | 啟用此項後﹐當 SMTP 命令的 MAIL FROM 位址和郵件頭的發件人位址不一致時﹐會增加 Sender 欄位。

外發遞送

通常情況﹐寬帶接入到 INTERNET 的用戶可以無需設定這個功能。外發中繼遞送一般是在本身連接到 Internet 的速度比較慢﹐而連接到某一臺 SMTP 伺服器速度相對比較快。如普通撥號上網的用戶﹐可以將中繼伺服器的位址設為當地的電信的 SMTP 主機。這樣會加快遞送速度﹐減少遞送過程中的出錯。

遞送規則 | 1. 當選擇“通過查詢 MX(郵件交換)記錄直接遞送”﹐發到外域的郵件會查詢這些網域名稱的 MX(郵件交換)記錄﹐取得收件人伺服器進行連接遞送。如果選擇“記錄遞送失敗後﹐用中繼伺服器遞送”﹐則在直接遞送給收件人伺服器失敗後﹐接連中繼伺服器進行遞送﹔如果不選擇﹐則等待下次遞送。 2. 當選擇“啟用中繼伺服器遞送”﹐則所有發送到外域的郵件都直接到遞送到中繼伺服器。如果中繼伺服器需要發信認證﹐還必選中“中繼伺服器需要認證”選項﹐同時也要正確設定認證的用戶名與密碼。
中繼伺服器 | 1. 當設定多個中繼伺服器時﹐系統會從上至下連接中繼伺服器遞送郵件﹐直至遞送成功。 2. 如果中繼伺服器需要發信認證﹐必選中“中繼伺服器需要認證”選項﹐同時也要正確設定認證的用戶名與密碼。 3. 有的中繼伺服器會在發信的互動過程中檢查認證用戶與 Mail From 中的位址是否一致﹐如果不一致將不允許發送﹐這時候要設定“發件人位址”﹐如﹕用 163.com,sohu.com 作為中繼伺服器。 4. “啟用 SSL”選擇後﹐可以支援只提供 SSL 連接的伺服器做中繼伺服器(連接埠預設是 465)。如使用 gmail.com 作為中繼伺服器
遠端伺服器支援 STARTTLS 時﹐啟用 SSL/TLS 連接 | 發信時, 如果遠端伺服器支援 STARTTLS 命令時﹐Winmail 會自動啟用 SSL 加密連接通訊發送郵件﹐可以防止網路竊聽﹔如果遠端伺服器不支援﹐則會繼續使用普通連接發送郵件。

中繼伺服器設定﹐點擊“增加”﹐在彈出對話方塊中輸入中繼伺服器組態。也可以在中繼伺服器清單中﹐選擇伺服器記錄﹐進行修改和解除。

允許轉發域

當開啟了“SMTP發信認證”時﹐發給這些域的郵件﹐可以不需要進行發信認證。切記不能將免費郵箱的網域名稱加入﹐如 hotmail.com, aol.com, yahoo.com, qq.com 等等。

信任主機

當開啟“SMTP 發信認證”時﹐此清單中主機位址發過來的郵件可以不需要進行發信認證直接轉發出去。例如企業的OA﹐CRM系統需要發信﹐可以將這些系統的 IP 加入清單。謹慎增加﹐防止有人亂發郵件。

外域直接遞送

針對某一網域名稱﹐可以設定直接遞送某個指定的主機。同一網域名稱可以增加多個直接遞送的主機﹐並且可以根據網路情況調整遞送順序。
需要使用這種功能的場景﹐在一個專網內有幾個臺不同的郵件系統﹐各郵件系統使用不同的網域名稱﹐而又沒有設定 DNS 的情況。
如果直接遞送主機需要發信認證﹐可以選擇“伺服器需要認證”選項﹐同時正確設定認證的用戶名與密碼。
有的遞送主機會在發信的互動過程中檢查認證用戶與 Mail From 中的位址是否一致﹐如果不一致將不允許發送﹐這時候要設定“發件人位址”﹐如﹕直接遞送到 163.com

點擊“增加”﹐在彈出對話方塊中輸入網域名稱和主機位址。也可以在主機清單中﹐選擇主機記錄﹐進行修改和解除。

網域名稱直接遞送失敗後﹐使用系統外發遞送規則﹕啟用此項後﹐當直接發送網域名稱指定的目標主機失敗後﹐會使用系統外發遞送規則查詢網域名稱的交換主機繼續進行發送。如果沒有啟用﹐則始終使用網域名稱直接遞送﹐發送給目標主機﹐直至成功或超時回退。
有關外發遞送規則設定請見﹕“外發遞送”。

郵件頭取代

設定郵頭中要取代的內容。例如﹕內部郵箱 @look.com, @alook.com, @look.net 發出去的郵件中的位址要被取代成 @winmailserver.com﹐則只需要增加一條類似於清單中的第一條記錄。同時至少選擇一種取代方式。

點擊“增加”﹐在彈出對話方塊中郵件頭取代內容。也可以在清單中﹐選擇記錄﹐進行修改和解除。

郵件密級

用戶端需要發送密級郵件時﹐可以通過暗送到不同密級指定的郵件位址﹐來實現對應郵件的密級。

注意事項

1. HELO/EHLO 主機名一般是填寫您的主機名﹐能夠正確解析出郵件系統所在主機的 IP 位址。
2. 如果您的郵件系統是在 Internet 上使用﹐請一定要開啟“SMTP發信認證”。不然您的郵件系統很快就會成為垃圾郵件轉發伺服器。如果您郵件系統郵件已經被人轉發垃圾郵件﹐請將“啟用發信認證”﹐“發件人和認證用戶必須一致”﹐“SMTP 通訊中﹐檢查郵件位址的有效性”﹐“通過 DNS 檢查發送者的郵件位址”和“給本系統內用戶發郵件時﹐檢查郵箱是否存在”這幾個選項全選項﹐以阻止不合法郵件發送﹐同時也要分析“系統日誌”/“SMTP”中的相關日誌﹐來過濾可疑的發送主機 IP 位址﹐增加到“系統服務”中“SMTP”服務的“存取控制”清單中。
3. 發信時不需要認證的情況﹕ 1) 發郵件主機的位址在“信任主機”清單中﹔2) 收件人位址的網域名稱是本系統中的網域名稱﹐域別名或在“直接遞送域”清單中。
4. Winmail 中 SMTP 服務啟動了﹐但無法發送郵送呢﹖
5. 本地能正常收發﹐能發給外域﹐但外域發過來不能收到﹐問題出現在哪裏﹖
6. 我的郵件系統能收不能發﹐請問可能是什麼原因呢﹖


郵件通訊閘

POP3下載
ETRN設定


POP3下載

系統的 POP3 帳號記錄﹐可以從其他郵件系統中通過 POP3 通訊協定將指定帳號的郵件收取下來﹐然後可以按照各帳號設定的規則進行分發﹐從而實現郵件通訊閘功能。

功能選項

1.新增

增加新的系統的 POP3 帳號記錄

伺服器位址 | 接收郵件的伺服器位址。
伺服器連接埠 | 接收郵件的連接埠。
生效 | 選中表示此條記錄生效。
帳號名 | 用戶郵箱帳號名。
密碼 | 用戶郵箱密碼。
使用安全鏈接（SSL） | 啟用加密鏈接轉輸數據﹐需要服務支援此功能。
下載郵件大小限制 | 允許下載的最大郵件尺寸。
下載郵件數限制 | 允許一次下載的最多郵件數。
在伺服器上保留備份 | 選中則在郵件伺服器上保留郵件﹐否則解除郵件。
直接遞送至郵箱 | 將下載的郵件轉發到其他的郵箱。
按信頭分檢 | 將下載的郵件按郵件頭的有關欄位分發到不同的內部郵箱。
用郵箱位址中的用戶名取代郵箱名 信頭中的郵箱位址的用戶名取代郵箱名﹐從而產生新的郵箱位址。
例如﹕郵箱位址 "steven" <default@winmail.cn> 經過變化產生新的郵箱名為﹕steven@winmail.cn﹐ 以此新郵箱名作為收件人的郵箱位址。可以實現多人共享一個郵件帳號而互不干擾。

進階設定

通過分析信頭中的指定欄位﹐取得其有效的郵箱位址進行遞送。
用戶可以針對實際情況選擇要分析的信頭欄位﹐也可以自定義要分析的欄位（多個欄位間用分號[;]隔開）。

2.編輯

修改選取系統的 POP3 帳號記錄。

3.解除

解除已選的系統的 POP3 帳號。支援單條和多條記錄的解除。

4.刷新

從後臺資料庫重新讀取數據﹐刷新介面。

注意事項

生效條件:在"計劃任務"中﹐必須有一條“接收系統 POP3 郵件”的事件。


ETRN設定

ETRN 帳號記錄﹐通過 SMTP通訊協定 中的 ETRN 命令將指定郵件系統佇列中發給所設定的網域名稱的郵件收取到本系統的郵件佇列中﹐然後郵件佇列程式將這些郵件分發各個接收人﹐從來實現郵件通訊閘功能。ETRN 是 SMTP 伺服器的一個擴展功能。用這種功能來實現郵件通訊閘﹐需要指定的郵件系統的 SMTP 服務支援 ETRN 功能。

功能選項

1.新增

增加新的 ETRN 帳號記錄。

網域名稱 | ETRN帳號的網域名稱。
描述 | 由用戶自由填寫。
生效 | 選中表示此條記錄起作用。
需要認證 | 選中表示需要。
用戶名 | 認證用戶名。
密碼 | 認證密碼。

2.編輯

修改已選的 ETRN 記錄。

3.解除

解除 ETRN 記錄。支援單條和多條記錄的解除。

4.刷新

從後臺資料庫重新讀取數據﹐刷新介面。

注意事項

生效條件:在"計劃任務"中﹐必須有一條“接收外部 ETRN 郵件”的事件。


計劃任務

用於設定某一時段或每隔一個周期去完成某些指定的任務。如﹕發送郵件到外域﹐收取系統或用戶的POP3､清除用戶郵件等。

功能選項

1.新增

任務標簽 | 用戶自己定義的任務標簽。
生效 | 選中表示此計劃任務生效。
定時執行 | 選中表示本任務只在指定時間執行。
回圈執行 | 選中表示本任務每隔一個回圈周期會自動執行一次。回圈執行時可以設定執行時間段。
發送佇列中的郵件 | 將佇列中的所有等待外發的郵件全部發送出去。
接收系統 POP3 郵件 | 接收所有生效的系統 POP3 賬號的郵件。在“郵件通訊閘”/“POP3 下載”中設定賬號。
接收外部 ETRN 郵件 | 接收所有生效的 ETRN 賬號的郵件。在“郵件通訊閘”/“ETRN 下載”中設定賬號。
接收用戶 POP3 郵件 | 接收所有用戶的設定的 POP3 賬號的郵件。系統中的郵箱用戶可以通過 Webmail 下的“外部 POP3 郵箱”來設定。
清理用戶的郵件 | 設定清理用戶多少天前的指定檔案夾的。
處理未使用的用戶 | 設定解除或禁止多少天沒有使用的郵箱用戶帳號。
如果未在線則自動撥號 | 當執行“發送佇列中的郵件”､“接收系統 POP3 郵件”､“接收外部ETRN郵件”和“接收用戶 POP3 郵件”事件時﹐如果沒有連接在 Internet 上﹐則可以選擇是否要自動撥號連接到 Internet。
任務完成後自動掛線 | 如果撥號連接到 Internet﹐在任務完成後是否要斷線。
動作指定物件 | 設定計劃任務動作（接收用戶 POP3 郵件﹐清理用戶的郵件﹐處理未使用的用戶）生效的物件。

當回圈執行時﹐選擇執行的時間段。

設定計劃任務動作（接收用戶 POP3 郵件﹐清理用戶的郵件﹐處理未使用的用戶）生效的用戶物件。

2.編輯

修改已選的計劃任務。

3.解除

解除已選的計劃任務。支援單條和多條記錄的解除。

4.刷新

從後臺資料庫重新讀取數據﹐刷新介面。


進階設定

系統參數
Webmail 設定
郵件模板
系統廣播
郵箱監控
郵件簽核
Internet 設定
SSL/TLS 證書
IP 歸屬地


系統參數

主要是對整個系統的一些參數進行設定﹐如﹕郵件存儲目錄﹐系統郵件模板﹐DNS設定﹐Webmail設定等。

基本參數

本地主機名/IP 位址 | 設定本機的主機名或 IP 位址。主要是用於白金版分散式佈署時﹐主機識別。
服務歡迎資訊 | 指定各服務（SMTP/POP3/IMAP/FTP）中的歡迎資訊。有時候修改此標識可以有效的防止系統攻擊。空白則顯示“Winmail Server” 再加上系統時間。
系統郵件模板語言 | 設定郵件模板的語言。
IP 位址認證失敗次數 | 同一個 IP 位址平均每分鐘內認證失敗的最大次數﹐可以有效防止某個 IP 來猜測密碼
用戶認證失敗次數 | 同一個郵箱用戶平均每分鐘內認證失敗的最大次數﹐可以有效防止猜測某個郵箱用戶的密碼
SMTP 認證次數 | 同一 IP 位址或郵箱用戶平均每分鐘內認證發信的最大次數﹐可以有效防止某個IP 位址不斷連接認證發信或郵箱用戶被猜到密碼被轉發垃圾郵件。
SMTP 外發收件人數 | 同一 IP 位址或郵箱用戶平均每分鐘內發到外域的最大收件人。可以有效防止某個IP 位址不斷連接認證外發郵件或郵箱用戶被猜到密碼被轉發垃圾郵件。
日誌語言 | 設定記錄日誌的語言。
日誌等級 | 設定日誌的記錄級別﹐可以控制日誌資訊量。
日誌檔案天數 | 保留的多少天的日誌檔案。
日誌檔案大小控制 | 可設定當日誌檔案達到多大後建立新的日誌。

存儲目錄

郵件存儲目錄 | 設定用戶郵件將被存放的目錄。 單副本儲存郵件﹕一封郵件同時發給多個收件人時﹐只儲存一份郵件﹐提高遞送效率﹐節約磁碟空間。
郵件佇列目錄 | 設定郵件佇列存放在目錄。
郵件備份目錄 | 設定郵件備份存放在目錄。有關郵件備份的設定﹐請見“系統備份”。
網路磁碟存儲目錄 | 設定網路磁碟存儲目錄。
日誌檔案存放目錄 | 設定日誌檔案存放的目錄。* 此項設定完成後﹐需要重啟系統才能生效
其他郵件存儲目錄 | 當郵件存儲目錄的可用空間不夠時﹐可以增加其他磁碟目錄來存放郵件
磁碟空間軟限制 | 如果磁碟的可用空間低於軟限制﹐將出現警告訊息﹐提醒管理員釋放更多的磁碟空間。
磁碟空間硬限制 | 如果磁碟的可用空間低於硬限制﹐郵件系統將被停止。
注意﹕ 1. 郵件存儲目錄､郵件佇列目錄､郵件備份目錄､網路磁碟和日誌存放目錄不能設定成相同的目錄。 2. 當修改目錄時﹐為保證數據不丟失必須把舊目錄結構拷貝到新目錄下去。 3. 修改日誌檔案存放目錄﹐必須重啟郵件系統才能生效。

IPv6 設定

啟用 IPv6 | 當伺服器網卡支援 TCP/IPv6 通訊協定時﹐Winmail 可以選擇啟用 IPv6
優先使用 IPv6 | 當郵件外發時﹐先通過 DNS 查詢收件方網域名稱是否有 IPv6 位址﹐優先使用 IPv6 通訊協定連接發信。

DNS 設定

DNS 設定 | 可以選擇使用作業系統網卡設定的DNS伺服器或者設定指定的 DNS 伺服器。
查詢失敗﹐從下列伺服器查詢 | 當 DNS 查詢 MX 記錄失敗﹐從更多的 DNS 伺服器查詢。
DNS 緩存總數 | 臨時記錄最近查詢的網域名稱的 MX 記錄和 A 記錄﹐減少 DNS 查詢﹐提高發信效率。可以清空和顯示目前緩存。
注意﹕ 1. 如果您不能確定 IP 接入商的DNS位址﹐可以使用以下公共 DNS。 114DNS: 114.114.114.114 , 114.114.115.115 阿裏DNS: 223.5.5.5 , 223.6.6.6 DNSPod: 119.29.29.29 Google DNS: 8.8.8.8 , 8.8.4.4 Open DNS: 208.67.222.222 , 208.67.220.220 2. 如果對網域名稱和DNS有疑問﹐請見﹕郵件/網域名稱/DNS相關知識。

系統報表

系統報告接收郵箱 當產生系統報表時﹐將會發送到此郵箱。

系統簽名

簽名內容 用戶發送郵件時﹐郵件附帶的簽名內容。
當要增加 HTML 簽名內容時﹐直接輸入 HTML 代碼﹐選中“HTML 格式”。

FTP 組態

FTP 是提供網路磁碟服務。也可以用 FTP 用戶端工具連接。

FTP 數據傳輸 | FTP的連接模式有兩種﹐PORT(主動模式)和PASV(被動模式)﹐當FTP 連接時﹐使用“PASV 模式”進行數據傳輸時﹐返回給用戶端的 IP 位址和連接連接埠。一般 IP 位址設定成外網的 IP 位址和對外開放的連接埠。
Secure FTP 數據傳輸 | 當Secure FTP 連接時﹐使用“PASV 模式”傳輸數據﹐返回給用戶端的 IP 位址和連接連接埠。

HTTP 組態

HTTP 是提供 Webmail 服務。

以 FastCGI 執行 | FastCGI 執行方式相對於傳統的 ISAP 執行方式具體效率高﹐響應快。
啟用 PHP 緩存 | PHP 緩存可以產生中間代碼﹐優化 PHP 腳本﹐提高 PHP 執行速度。
強制 https:// 存取 | 將通過 http:// 的存取重定向到 https://
最大上傳檔案 | 設定 Webmail 最大允許上傳的檔案大小。
Web管理存取目錄名 | 為了安全可以修改預設的Web管理端的存取目錄名
存取主機名 | 僅允許的主機名存取Webmail﹐阻止 IP 或其它惡意解析的主機名存取

LDAP 組態

Winmail 內置的 LDAP 主要存放公用位址簿聯繫人資訊﹐方便用戶查詢公用聯繫人。

LDAP 寫操作密碼 | 設定向 LDAP 中寫入資訊時的操作密碼
允許匿名存取 | 設定是否允許匿名讀取 LDAP 中的用戶資訊。 這樣通過用戶端軟體來找到公用位址簿時﹐就可以不需要設定查詢的用戶名和密碼。具體請見“公用位址簿用戶端”

ADMIN 組態

管理端組態

交談超時時間 | 管理端交談失效時間
登入需要二次驗證 | 輸入用戶名和密碼登入成功後﹐要輸入令牌 APP 上的動態密碼進行驗證
防止猜密碼 | 設定登入錯誤統計時間﹐允許的失敗次數﹐來源 IP 禁用時間

資料庫設定

系統組態和認證資訊預設使用 SQLite(內嵌式輕型資料庫)
企業版､白金版支援﹕MySQL(內置)､ MySQL/MariaDB(外部)､ PostgreSQL(外部)﹐幾種方式可以切換遷移。

SQLite 切換到 MySQL (內置) 操作步驟﹕

1. 點擊"MySQL (內置)" - "測試連接"﹐系統會後臺啟動內置的 MySQL 服務﹐再連接﹐正常顯示"連接資料庫成功﹗"提示框﹐有時可能啟用比較慢﹐導致提示無法連接﹐沒有關係﹐再點擊一次。
2. 選中"MySQL (內置)"﹐提示"使用新資料庫﹐如需要遷移目前數據﹐則應用前先執行導入數據操作"提示框﹐點擊"是(Y)"﹐再點擊"導入數據"﹐提示"導入數據將會重建資料庫。是否要執行?"﹐點擊"是(Y)"
3. 系統後臺自動從 SQLite 導入數據到 MySQL (內置), 完成後提示"數據導入成功﹗"
4. 點擊本頁最下面的"應用"儲存本次修改﹐提示"修改資料庫設定﹐必須重啟郵件系統。"﹐手工關閉 Winmail 管理工具﹐再操作托盤上 Winmail 圖示 [image] 重啟一下 Winmail 伺服器程式。

其他遷移操作類似﹐一般先"測試連接"﹐再"導入數據"﹐注意導入將先清空目標資料庫中相關 Winmail 表的全部數據。如果連接或者導入到外部資料庫不成功﹐檢查存取權限﹐可以在伺服器上使用其他資料庫管理軟體測試。

帳號同步

自動同步 Windows 域服器､第三方 LDAP 上用戶到郵件系統中[僅企業版､白金版､旗艦版支援]。

同步第三方 LDAP 或者 AD

AD 帳號同步時﹐AD 用戶資訊修改的會同步修改郵箱用戶資訊﹐AD 用戶禁用的郵箱用戶自動禁用。


Webmail 設定

主要是對 Webmail 頁面參數進行設定。

首頁設定

Webmail 登入頁不顯示網域名稱選擇清單 | 啟用此項﹐可以防止用戶在登入時﹐看到系統的所有網域名稱﹐不顯示網域名稱清單。普通域下用戶登入時需要輸入完整的郵箱位址。
允許使用“Web 管理”功能 | 啟用此項﹐允許管理員通過 Web 方式進行管理。
Webmail 登入頁顯示“Web 管理”連接 | 啟用此項﹐Webmail 登入頁面顯示“Web 管理”的連接。
Webmail 登入頁顯示“忘記密碼”連接 | 啟用此項﹐Webmail 登入頁面顯示“忘記密碼”的連接。
Webmail 允許自動登入 | 啟用此項﹐允許 Webmail 可以自動登入。
Webmail 啟用交談 cookie | 啟用此項﹐Webmail 登入後用 cookie 記錄交談資訊﹐防止拷貝登入後的 URL 直接存取。
Webmail 啟用 IP 檢查 | 啟用此項﹐Webmail 登入後用存取者的 IP 資訊﹐提高安全性。如果有多個出口 IP ﹐隨機變化﹐建議不要啟用此項。
顯示在線輔助說明 | 顯示 webmail 在線輔助說明。
顯示語言列示方塊 | 登入頁面顯示語言選擇列示方塊。
顯示介面風格列示方塊 | 登入頁面顯示介面風格選擇列示方塊。
不同介面風格﹐登入首頁保持一致 | 在不同介面風格下﹐選擇不同的登入風格﹐登入首頁保持一致。
預設語言 | 設定預設的登入語言。
預設介面風格 | 設定預設的登入介面風格。
顯示圖形碼 | 設定顯示圖形驗證碼。

登入後設定

登入後的預設頁 | 設定郵箱用戶登入後的預設顯示頁面。
交談超時時間 | 設定 Webmail 登入後不操作的等待時間。
公告板郵件夾 | 設定 Webmail 公告板的郵件夾。
讀郵件時﹐顯示附件中的圖片 | 閱讀郵件時﹐附件是圖形檔案﹐直接在郵件內容後顯示。
預設編輯器 | 設定郵箱用戶的預設編輯器
外發郵件編碼 | 設定郵件編碼方式。
使用雲附件 | 有網路磁碟權限的用戶﹐可以使用雲附件。發郵件時超過指定大小﹐會自動使用共享鏈接發送。
自動儲存新郵件到[草稿箱] | Webmail 每隔一段時間自動儲存新郵件到“草稿箱”
儲存已發送的郵件到[已發送]郵件夾 | 郵件發送後﹐將發送的郵件存儲到[已發送]郵件夾。
啟用閱讀回條 | 設定是否預設開啟閱讀回條。
允許拼寫檢查 | 開啟/禁止拼寫檢查功能。
允許用戶啟用新郵件通知 | 啟用後﹐用戶可以通過 Webmail 來設定短訊息參數。
允許用戶發送自寫短信 | 允許用戶通過 Webmail 直接發送短訊息。

註冊頁面設定

郵箱名長度限制 | 設定郵箱名的最小長度。
密碼長度限制 | 設定密碼的最小長度。
顯示圖形碼 | 註冊頁面和取回密碼設定是否顯示圖形碼。
欄位值必填項限制 | 設定不能為空的欄位項。
不能被註冊郵箱名 | 設定不能被註冊的郵箱名。

弱密碼設定

弱密碼字典 管理弱密碼字串

二次驗證

二次驗證 設定是否啟用二次驗證﹐以及需要二次驗證的場景和方式


郵件模板

主要是對郵件伺服器的常用的系統郵件模板進行設定。

郵件模板

註冊歡迎信 | 歡迎信是郵箱新建成功後﹐發送到該郵箱中第一封郵件。
錯誤回彈信 | 當一封郵件無法成功遞送時﹐系統將錯誤回彈信發送給發件人﹐敘述錯誤原因。
過濾通知信 | 當郵件系統偵測到有病毒的附件或符合過濾條件的附件﹐會給收件人和郵件系統的管理員發過濾通知信。
容量警告信 | 當用戶郵箱的容量達到設定的警告值時﹐系統會發送到警告信給該郵箱。
郵件簽核通知 | 當郵件需要簽核時﹐會發送簽核通知信給管理員。需要簽核的郵件會作為通知信的附件一同發給管理員。
郵件簽核拒絕 | 當管理員拒絕簽核郵件時﹐會發送簽核拒絕信給發送者。
重載預設值 | 重新載入系統出廠的預設郵件模板。


系統廣播

主要是對系統內的所有用戶或指定域下的所有用戶發送廣播郵件。

系統廣播

發送給 | 可以根據需要選擇發送給所有用戶或指定域下的用戶。
主題 | 廣播郵件的主題。
內容 | 廣播郵件的內容。如果是 HTML 郵件直接輸入 HTML 代碼﹐然後選中“HTML 格式”選擇框。


郵箱監控

對系統內的指定郵箱帳號所有的接到和發出郵件進行監控。

功能選項

1.新增

增加新的郵件監控規則

內部郵件 | 指內部郵箱互相送的郵件。
外部郵件 | 指發送到外部郵箱或從外部郵箱發過來的郵件。
輸入郵件位址 | 可以輸入某個郵箱位址或某網域名稱下的所有郵箱位址。當輸入 *@domain 時﹐監控 domain 域下的所有郵箱。
選擇郵箱位址 | 從清單中列出的所有內部郵箱中選擇一個（批）郵箱﹐增加到“被監控郵箱位址”､“監控發郵件的管理員”或“監控收郵件的管理員”清單中。
被監控郵箱位址 | 被監控的郵箱位址。
監控發郵件的管理員 | 滿足條件的被監控郵箱所發出的郵件將會拷貝一份發送監控發郵件的管理員清單的郵箱中。
監控收郵件的管理員 | 滿足條件的被監控郵箱所收到的郵件將會拷貝一份發送監控發郵件的管理員清單的郵箱中。
郵件主題增加前綴 | 監控管理員郵箱收到的監控郵件主題前面將加 [monitor] 標記。
注意﹕監控管理員郵箱位址不存在或收信出錯﹐受監控的郵箱將會收到錯誤回彈信﹗﹗﹗

當需要設定郵箱監控條件時﹐可以點擊“進階...”來設定條件規則。

2.編輯

修改已選的郵件監控規則。

3.解除

解除已選的郵件監控規則。支援單條和多條記錄的解除。

4.刷新

從後臺資料庫重新讀取數據﹐刷新介面。


郵件簽核

管理員可以限制一些用戶發信是否要經過指定管理員簽核。簽核管理員可以允許和拒絕需要簽核的用戶發送郵件。

功能選項

1.新增

輸入郵件位址 | 可以輸入某個郵箱位址或指定網域名稱下的所有郵箱。當輸入 *@domain 時﹐ domain 域下的所有郵箱都要簽核。
選擇郵箱位址 | 從清單中列出的所有內部郵箱中選擇一個（批）郵箱﹐增加到“發送郵件需要簽核的郵箱”､“發郵件到外域由下列管理員簽核”或“發郵件到本域由下列管理員簽核”郵箱位址清單中。
發送郵件需要簽核的郵箱 | 發送郵件需要由管理員簽核的郵箱。
發郵件到外域由下列管理員簽核 | 需要郵件簽核的郵箱發郵件到外域時﹐需管理員清單中任一管理員簽核。
發郵件到本域由下列管理員簽核 | 需要郵件簽核的郵箱發郵件到本域時﹐需管理員清單中任一管理員簽核。

當需要設定郵件簽核條件時﹐可以點擊“進階...”來設定條件規則。

2.編輯

修改已選的郵件簽核規則。

3.解除

解除已選的郵件簽核規則。支援單條和多條記錄的解除。

4.刷新

從後臺資料庫重新讀取數據﹐刷新介面。


Internet設定

對郵件系統連接到 Internet 的方式進行設定。

Internet設定

在線方式 | 如果您的網路是長時間能夠連接到Internet的(甚至是24小時)﹐推薦選擇“永久在線”﹔ 如果您只是很少時間通過撥號存取Internet的﹐推薦選擇“非永久在線”﹔
啟用撥號網路 | 允許計劃任務撥號。
撥號網路提供商 | 伺服器的作業系統的“網路和撥號連接”中設定的設定撥號網路。
失敗重試次數 | 連接不成功時的重試次數。
使用系統中預設的用戶名和密碼 | 撥號連接已經設定了用戶名和密碼﹐直接從中取出用戶名和密碼。
用戶與密碼 | 設定了撥號的用戶和密碼。
注意﹕用戶在啟用撥號網路前必須在系統的“網路和撥號連接”中設定撥號網路。

Proxy設定

如果是使用 Socks 代理伺服器連接到 Internet 的﹐請設定 Socks 參數。 外發郵件和 POP3 下載時會用到代理伺服器。


TLS/SSL 證書

SSL/TLS 證書

Winmail 伺服器和客戶之間所有的安全(Secure)通訊都使用加密的方式，以保護通訊資料的安全；Winmail 使用 SSL 加密通訊協定，伺服器首先 使用一對不對稱金鑰與客戶交換一個共用的對稱金鑰，此金鑰被用來對通訊 資料加密。

不對稱金鑰有兩個金鑰: 公開金鑰(Public Key)和私密金鑰(Private Key),使用其中任 一個金鑰加密的資料，必須要用另一個金鑰解密。正如它們的名字，公開金鑰被提供 給任何想和伺服器通訊的客戶，而私密金鑰僅僅被伺服器使用，且必須保密；對客戶 而言需要鑒別伺服器的身份(防止伺服器被假冒)，通常使用證書標識伺服器，證書包含伺服器的公開金鑰、伺服器的名稱、有效日期和其它細節；為確保證書的真實性，證書 應該被協力廠商(CA)證明和簽署。

客戶與伺服器的通訊原理概要：客戶產生一個對稱的金鑰K，然後接收伺服器發送過來的 伺服器的證書，並使用證書中公開金鑰(伺服器的公開金鑰)加密對稱金鑰K，然後把加密的金鑰發送給 伺服器，伺服器使用只有自己知道的伺服器的私密金鑰解密資料得到對稱金鑰K；因此對稱金鑰 只有通訊雙方的客戶和伺服器知道,保證了通訊資料的安全。

Winmail 證書

請訪問 http://www.winmail.cn/docs/ssl/ 查看網站上的 "Winmail 配置SSL伺服器憑證"

Winmail 證書和私密金鑰一般放在安裝目錄的certs子目錄下，副檔名為“.crt”的文件 是存放證書的文件，副檔名為“.csr”的是存放請求的檔（下面部分有解釋），副檔名是“.key”的是存放私密金鑰的文件，證書文件(或請求檔)同檔案名相同的私密金鑰檔意義對應。
安裝完成後 會有一個初試的示例證書，建議客戶要及時創建、使用自己的證書。

下面以OE(OutLook Express 6.0)使用Secure IMAP客戶為例，說明證書的應用，如果伺服器 發送給OE的證書不被OE信任將會看到一下的資訊，如果被OE信任將不會顯示以下的資訊。

點擊 "是"， 那麼同伺服器連接將接續
點擊 "否"， 將斷開同伺服器的連接

注意： 如果要讓用戶端直接信任伺服器所發送的證書，不產生警告對話方塊； 可以將伺服器正在使用的證書匯出，然後將此證書發放給各個客戶； 客戶將此證書導入用戶端機器即可，具體的證書的導入可以參照具體 用戶端軟體的?明文檔(以Windows Outlook為例， 只要按兩下證書，再點擊安裝證書按鈕即可)。以上操作的必要條件是： 證書中的主機名稱必須和伺服器正確的主機名稱以及用戶端軟體設置部分 填寫的伺服器主機名稱保持一致才能讓用戶端信任此證書。

證書管理

Winmail 提供了管理證書的功能，主要創建，管理證書和證書請求。
證書：可以創建和管理自簽章憑證，是不被信任的(除非是根證書)，但是可以完成加密的通訊。也可以導入外部證書機構頒發的可信任的加密證書
證書請求：按指定要求生成公私密金鑰證書請求(CSR)，但沒有被簽名，不能用來做為證書完成加密通訊。需要先導出請求，發送協力廠商證書機構簽署後可以正常使用。

1. 新建...

創建新的自簽章憑證或證書請求。
當多個功能變數名稱同時使用一個證書時，需要設置“使用者備用名”，如，DNS:mail.winmail.cn, DNS:mail.119.com, DNS:mail.test.com

2. 查看...

3. 導入...

導入新證書：把本機（管理端）中的證書和與證書對應的金鑰導入服務的證書管理資料庫
導入已簽章憑證：當請求被選中時，可以導入一個這個請求協力廠商被簽名後生成的證書， 如果選擇的證書不是本請求本協力廠商簽名的證書，本導入操作將失敗

4. 匯出...

匯出證書，匯出請求：匯出被選中的證書或者請求，並以檔的形式存儲在本機中，證書的默認副檔名“.crt”，請求的默認副檔名“.csr"，匯出的證書可以產看更為詳細的資訊。
匯出私密金鑰：匯出與被選中證書或者請求相對應的私密金鑰，並以檔的形式存儲在本機中，默認副檔名“.key”

5. 刪除

刪除被選中的證書或者請求，與之對於的私密金鑰也被刪除

6. 啟動

指定 Winmail 服務使用被選定的證書進行 SSL 通訊

7. 刷新

重新獲取 Winmail 伺服器中證書或者請求的列表


IP 歸屬地

設定 IP 位址對應的歸屬地。對於IP 歸屬地庫中標記不正確的 IP 位址﹐可以設定正確的歸屬地進行修正。

功能選項

1.新增

增加 IP 位址段的歸屬地進行調整。

排序號 | 查詢的優先權
起始 IP | 設定起始 IP
結束 IP | 設定終止 IP
歸屬地 | IP 的歸屬地﹐一般以省市形式命名﹐如江蘇南京

2.編輯

修改已選的IP 歸屬地。

3.解除

解除已選的IP 歸屬地。支援單條和多條記錄的解除。

4.刷新

從後臺資料庫重新讀取數據﹐刷新介面。


公共郵件夾

公共郵件夾可以使被授權用戶通過 Webmail 或 IMAP 用戶端共享一個郵件夾﹐以實現郵件在用戶間的共享。

功能選項

1.新增

步驟一﹕設定郵件夾標簽及容量

公共郵箱標簽 | 用戶在 IMAP 用戶端中可以看到的郵箱標簽﹐系統自動加上@前綴以標識是非用戶郵箱
郵箱容量限制 | 指示本公共郵箱的最大容量
允許最大郵件數 | 指出本公共郵箱可容納的最大郵件數

步驟二﹕設定郵件夾操作權限

公共郵箱的權限有三種:讀､寫､解除。將指定的被授權用戶加入右邊的指定的權限列示方塊即可﹐用戶不能看到未授權公共郵件夾。

輸入帳號時﹐“@domain”代表 domain 域下所有的用帳號。

2.編輯

修改郵件夾的屬性設定﹐畫面和操作同新建﹔此時不能修改郵件夾的標簽。

3.解除

解除已經建立的公共郵件夾。

4.刷新

重新獲取在伺服器上公共郵件夾的清單。

5.查看方式

可以通過支援 IMAP 通訊協定的用戶端軟體﹐如 ､Outlook 等軟體查看﹐也可以通過 Webmail 來查看公共郵件夾。


防病毒設定

本系統能與 Windows 上裝的殺毒軟體(支援幾乎所有的殺毒引擎)進行整合﹐掃描來往郵件﹐有效的隔離和清除帶毒郵件。

防病毒引擎

工作模式 | 命令行程式, 殺毒程式 API 接口, 病毒防火牆, 整合防病毒引擎
一､使用命令行程式
殺毒產品標簽 | 給出殺毒產品標簽。
執行程式路徑 | 列出殺毒產品的可執程式的路徑。注意路徑中最好不能有空格﹔如有空格﹐請將路徑以引號括起來。
命令行參數 | 輸出執行程式執行時的參數。
發現字串 | 檢毒結果報告中﹐發現病毒時的特征碼。
沒有發現字串 | 檢毒結果報告中﹐沒有發現病毒時的特征碼。
注意﹕ 1. 在命令行參數中﹐用%TEMPDIR%來表示要殺毒的目錄﹔用 %REPORTFILE% 來表示掃毒結果報告檔案。 2. 使用郵件病毒掃描功能前﹐必須關閉病毒防火牆或病毒即時監控。
二､使用殺毒程式 API
殺毒產品標簽 | 選擇殺毒產品標簽。支援AVG 6.x 和 AVG 7.x
三､使用病毒防火牆
支援幾乎所有的病毒防火牆。使用病毒防火牆時﹐要設定防毒軟體發現病毒自動清除, 並且關閉警告提示。
四､整合防病毒引擎
Winmail 自帶了 ClamAV 防病毒程式和病毒庫﹐winmail 會自動更新病毒庫。(白金版才有此功能) ClamAV 介紹 http://www.clamav.net
發送測試信
發送一無害的國際標準病毒樣本﹐如果設定正確管理員信箱會收到一封警告信。 您可以到 http://www.eicar.org/anti_virus_test_file.htm 下載這個病毒樣本。
注意﹕ 1. 不要在伺服器上裝設多個殺毒產品﹐否則可能帶來無法預知的結果。 2. 為什麼伺服器上裝設了諾頓 Norton 防毒程式後 Winmail 有時會自動關閉﹖ 3. 為什麼伺服器上裝設了瑞星防毒程式後不能正常收發郵件﹖
常用殺毒產品和 Winmail 詳細設定文件: Winmail 和殺毒引擎配合

附件過濾

過濾郵件中含中指定特征的附件。

防病毒動作

注意﹕
1. 如果設定“發送病毒通知信給接收者”﹐當接收者很多的時候可能會比較影響效率。
2. 一般可以不開啟病毒警告郵件通知﹐因正常的郵件收發過程中附件含病毒機率比較小﹔病毒郵件一般都沒有正確的發件人和收件人位址﹐通知郵件會經過多次遞送﹐最終遞送給管理員﹐病毒郵件頻繁的時候會比較影響效率。


新郵件提醒

Winmail 支援三種新郵件提醒示方式﹕手機短信通知﹐微信訊息提醒和釘釘訊息提醒﹐有新郵件到達時﹐可在手機上及時獲得通知。

方式一﹕短信方式

管理員在管理程式裏設定短訊息參數﹐郵箱用戶都使用系統級設定﹐可以設定使用權限。
郵箱用戶自行在 Webmail 中設定自己是否啟短訊息提醒﹐以及設定接收短信的手機號。

目前採用短訊息通訊閘和 GSM 短信貓兩種工作方式。

1）採用網路短信通道方式

網路短信通道方式一般採用預付費方式﹐可以購買一定數量的短信﹐支援移動､聯通和電信﹐不需註冊多個賬號。
目前支援的短信通道有﹕“阿裏大於（www.alidayu.com）”﹐“網易雲信（www.netease.im）”﹐“中國短信（www.china-sms.com）”﹐“動易短信（www.powereasy.net）”﹐“創藍253.com（www.253.com）”﹐“麥訊通（www.mxtong.com）”等﹐ 也支援騰訊通 RTX 訊息通知。 推薦使用基於 OpenAPI 通訊協定的阿裏大於和網易雲信﹐請參考 Winmail 產品網站相關介紹 http://www.winmail.cn/technic_sms.php

* 收費一般 0.05 - 0.10 元/條﹐具體請看各服務商網站的資費敘述。
* 由於網路原因短信的發送延遲時間不確定。

2）採用 GSM 短信貓方式

先要採購一款串口 WAVECOM GSM/GPRS MODEM 接到伺服器的串口上﹐同時要從 Winmail 提供商購買一個 GSM 短信貓支援的激活碼才能使用。

方式二﹕微信方式

a) 認證服務號﹕需要先在微信公眾平臺(https://mp.weixin.qq.com)申請服務號﹐付費認證後取得開發接口﹐在管理程式裏設定微信接口參數。
具體設定請參考 Winmail 產品網站相關介紹 http://www.winmail.cn/technic_wxfw.php。
b) 企業微信（微信企業號）﹕需要先在微信企業平臺(https://work.weixin.qq.com/ )註冊企業微信﹐在管理程式裏增加應用﹐設定微信接口參數。
具體設定請參考 Winmail 產品網站相關介紹 http://www.winmail.cn/technic_wxqy.php。
郵箱用戶在 Webmail 中掃描二維碼﹐綁定微信﹐成功後會收到微信通知。

方式三﹕釘釘方式

需要先在釘釘平臺(http://www.dingtalk.com/)註冊﹐在管理平臺裏增加微應用﹐設定接口參數。
具體設定請參考 Winmail 產品網站相關介紹: http://www.winmail.cn/technic_dd.php。
郵箱用戶在 Webmail 中掃描二維碼﹐綁定釘釘﹐成功後會收到釘釘通知。

短訊息設定

啟用新郵件短信通知 | 是否允許啟用系統的新郵件短信通知
最多接收短訊息數 | 每個用戶﹐每天允許接收的最多新郵件通知短訊息數。
手機短信 | 可以選擇短信通訊閘或 GSM 短信貓通知方式
注意﹕ 要使用 GSM 短信貓來發短信﹐首先要在伺服器的串口接口上接入 GSM 短信貓﹐然後要從 Winmail 提供商購買一個 GSM 短信貓支援的激活碼﹐激活此功能後才能使用。
微信 | 可以選擇使用認證服務號或企業微信來發送微信提醒訊息
釘釘 | 可以使用釘釘的開放接口來發送釘釘提醒訊息

用戶清單

設定允許的使用的此參數的進行短訊息通知的用戶。

短訊息內容

設定發送通知的手機短信內容和企業微信的通知訊息。

新郵件推送

新郵件到達後﹐可以推送到指定的網址

推送 URL 接收新郵件數據的網址﹐支援 http 和 https。
數據格式 POST 提交 json/xml/form 新郵件數據﹐數據格式如下﹕

json數據格式 (UTF-8 編碼)﹕
{
"to":收件人郵件位址;
"msgid":郵件ID;
"sender":SMTP 命令發件人;
"from":郵件頭發件人;
"subject":郵件主題;
"body":郵件內容(前 512 字元);
"attachnum":附件個數;
"attachlist":附件檔案名稱清單(以 || 分隔);
};
xml 數據格式 (UTF-8 編碼)﹕
<?xml version="1.0" encoding="UTF-8"?>
<Request>
<To>收件人郵件位址</To>
<MsgId>郵件ID</MsgId>
<Sender>SMTP 命令發件人</Sender>
<From>郵件頭發件人</From>
<Subject>郵件主題</Subject>
<Body>郵件內容(前 512 字元)</Body>
<AttachNum>附件個數</AttachNum>
<AttachList>附件檔案名稱清單(以 || 分隔)</AttachList>
</Request>
form 數據格式 (UTF-8 編碼)﹕
wm_to=收件人郵件位址;
wm_msgid=郵件ID;
wm_sender=SMTP 命令發件人;
wm_from=郵件頭發件人;
wm_subject=郵件主題;
wm_body=郵件內容(前 512 字元);
wm_attachnum=附件個數;
wm_attachlist=附件檔案名稱清單(以 || 分隔);

Webmail 新郵件提醒

用戶可以通過 Webmail 來設定新郵件提醒的手機號或綁定微信號和釘釘號。


系統備份

支援系統級備份和恢復功能，可選擇備份系統設置資料和使用者郵件資料，可以自動進行。也可以對郵件系統的所有發出的和收到的郵件進行即時備份。

郵件歸檔

啟用郵件歸檔 | 設定是否啟用郵件歸檔。
要歸檔的郵件類型 | 有四種類型：本地郵件、收到的郵件、發出的郵件和中轉的郵件。
備份位置 | 可以分為歸檔到郵箱和歸檔到檔。 當歸檔到資料夾時，用戶可設定資料夾的名稱。資料夾是建立在“高級設置”/“系統參數”中的設置的備份目錄中。如果沒有設置備份目錄，則備份到郵件系統所在目錄下 server\archive 中。
按使用者分目錄保存 | 選擇後每封郵件按各使用者創建目錄保存郵件。如果不選擇這項，系統是單副本存儲歸檔郵件的。
自動清除 | 可以設置系統自動清除舊的歸檔檔。
指定用戶 | 可以設置要歸檔的郵箱用戶，或者排除指定郵箱用戶。

系統備份

備份方式 | 有兩種方式：備份系統資料和備份所有資料。
備份方式 | 備份檔案夾名稱格式。資料夾是建立在“高級設置”/“系統參數”中的設定的備份目錄中。如果沒有設定備份目錄 則備份到郵件系統所在目錄下 server\backup 中。
備份檔案清單 | 列出已有的備份檔案。
備份 | 按現在的備份方式進行即時備份。當選擇備份所有資料時，如果系統使用者郵箱中郵件較多時可能會要等待很長的時間。 建議：如果系統使用者郵箱中郵件較多時，即時備份僅備份系統資料。
恢復 | 選取某一個備份檔案進行恢復。
刪除 | 刪除某一個備份檔案。
自動備份 | 選取一個執行頻率系統自動按照已選的備份方式進行備份。
自動清除 | 可以設置系統自動清除舊的備份檔案。
注意：系統即時備份與恢復時，最好停止系統的 SMTP/POP3/IMAP/HTTP 等服務。具體操作請見“系統服務”


系統狀態

SMTP 過濾
黑白名單設定
RBL/RWL 設定
灰名單設定
郵件過濾
內嵌圖過濾
在線垃圾郵件庫
郵件隔離區


SMTP 過濾

通過設定 SMTP 服務過濾規則﹐來增強對垃圾郵件的檢查和過濾。

SMTP 過濾

允許 MAIL FROM 命令中出現空位址 (MAIL FROM: <>) | 允許 MAIL FROM 命令中出現空位址(MAIL FROM: <>)。在有的郵件系統﹐發送退信時為了防止郵件回圈﹐MAIL FROM 位址是作為空位址。
SMTP 通訊中﹐檢查郵件位址的有效性 | SMTP 命令互動過程中﹐檢查郵件位址是否符合 rfc822 標準。
給本系統內用戶發郵件時﹐檢查郵箱是否存在 | 給本系統內用戶發郵件時﹐檢查收件人郵箱是否是系統內的存在的郵箱用戶。
查詢 DNS 檢查發件人郵件位址中的網域名稱是否存在 | 用 DNS 查詢發件人郵件位址的網域名稱是否是 INTERNET 上的有效網域名稱。檢查發件人網域名稱的 MX 和網域名稱本身指向的位址是否存在。用此項來檢查時需要 DNS 伺服器比較穩定可靠。
連接發件人的郵件伺服器校驗發件人位址是否存在 | 通過 DNS 查詢網域名稱發件人的郵件伺服器﹐連接對方伺服器校驗發件人的位址是否存在。 敘述﹕需要對方伺服器支援 Mail from: <> 的命令
檢查 HELO/EHLO 主機名的 A 記錄或 MX 記錄 | 檢查 HELO/EHLO 主機名的 A 記錄或 MX 記錄與連接的 IP 位址是否匹配。用此項來檢查時需要 DNS 伺服器比較穩定可靠。 匹配型式﹕ A Class﹕比較 A 類位址﹐如﹕119.119.119.119 與 119.51.127.156 是匹配的 B Class﹕比較 B 類位址﹐如﹕119.119.119.119 與 119.119.127.156 是匹配的 C Class﹕比較 C 類位址﹐如﹕119.119.119.119 與 119.119.119.156 是匹配的 D Class﹕比較 D 類位址﹐如﹕119.119.119.119 與 119.119.119.119 是匹配的
拒絕 HELO/EHLO 的主機名 | 拒絕“HELO/EHLO 過濾”中列出的 HELO/EHLO 的主機名。
啟用 SPF 檢查 | SPF 是發送方策略框架 (Sender Policy Framework) 的縮寫﹐主要是通過 DNS 查詢來檢查郵件來源的伺服器位址是不是網域名稱所有者所設定發件伺服器位址﹐防止偽造郵件位址發送垃圾郵件。
啟用 DKIM 檢查 | DKIM 是網域名稱密鑰識別郵件 (DomainKeys Identified Mail) 的縮寫﹐DKIM 的基本工作原理是基於傳統的密鑰認證方式﹐有公鑰(public key)和私鑰(private key)群組成﹐公鑰將會存放在 DNS 的 TXT 記錄中﹐而私鑰會存放在寄信伺服器中。發件者伺服器會自動產生數字簽名﹐並依附在郵件頭中﹐發送到寄信者的伺服器裏。收信的伺服器﹐將則通過 DNS 查詢獲取網域名稱的公鑰﹐驗證郵件頭中的簽名是否有效。如果驗證無效﹐則判定為垃圾郵件。
檢查 MAIL FROM 命令與信頭中的 FROM 欄位位址一致 | 檢查發信時﹐SMTP 命令中的 MAIL FROM 命令的發件人位址與郵件信頭中的 From 欄位中發件人位址是否一致。
檢查 RCPT TO 命令與信頭中 TO/CC/Delivered-To/Received 欄位中的位址一致 | 檢查發信時﹐SMTP 命令中的 RCPT TO 命令的收件人位址與郵件信頭中的 TO/CC/Delivered-To/Received 欄位中收件人位址是否一致。 注意﹕啟用此項檢查後﹐發送時不能使用“密送(Bcc)”
啟用陷阱郵箱 | 將一個本系統內的郵箱公開在網站上﹐讓垃圾郵件發送者收錄﹐當給這個郵箱發郵件時﹐系統會自動將發送者的 IP 屏蔽一段時間。
啟用 SpamAssassin 過濾 | 啟用知名的垃圾郵件過濾軟體 SpamAssassin 來對可疑郵件進行檢查過濾。 SpamAssassin 過濾是採用判斷郵件是否符合某種特征並加以評分的方法來對郵件進行分類。 有關 SpamAssassin 介紹參考 http://spamassassin.apache.org/
動態過濾主機 | 顯示被系統屏蔽主機的 ip 和加入時間﹐可以手工清除﹐系統自動清除 15 分鐘以前的數據﹔ 通過系統過濾檢查信任主機的 ip 和加入時間﹐可以手工清除﹐系統自動清除 60 分鐘以前的數據﹔。
垃圾郵件處理 | SMTP 接收郵件進行上面過濾動作﹐如果被判斷為垃圾郵件﹐可以對此郵件進行如下處理﹕ 1.拒絕接收 － SMTP 通訊過程中﹐直接返回錯誤提示。 2.發送到指定的郵箱 －將所有的垃圾郵件發送到指定的郵箱。 3.郵件主題前綴 － 垃圾郵件的主題前增加 [SPAM] 字串﹐繼續遞送給收件人。 儲存到隔離區﹕被判定為垃圾郵件的﹐可以選擇儲存到隔離區。收件人可以在 Webmail 上可以查看隔離區﹐並取回隔離郵件。隔離郵件最長保留 30 天。
流量控制 | 啟用後﹐認證用戶發信時會進行流量檢查。詳細的用戶流量控制可以在“用戶管理”中“流量控制”進行設定。(特殊版本才有此功能)


黑白名單設定

對發件人﹐收件人﹐IP位址等設定黑名單和白名單。

發件人過濾

發件人黑名單和發件人白名單清單可以是﹕郵件位址､網域名稱。這個位址一般應該從 “系統日誌”/“SMTP”中分析出的郵件位址﹐而不是從收到的郵件頭中看到的郵件位址。因為郵件頭中發件人位址與實際發郵件命令中的發件人( SMTP 通訊協定中的 MAIL FROM 命令)的位址可以不一樣。如果需要過濾或允許 demomail.com 網域名稱所有用戶發過來的郵件﹐可以將 @demomail.com 增加到黑名單或白名單清單中。

發件人黑名單﹕禁止清單中郵件位址發過來的所有郵件。
如果想過濾發件人的 IP 位址時﹐請在“系統服務”中﹐對“SMTP 服務”和“Secure SMTP 服務”的“存取控制”進行設定。

發件人白名單﹕允許清單中郵件位址發過來的所有郵件。
如果信任發件人的 IP 位址時﹐請在“SMTP 設定”中﹐對“信任主機”進行設定。

收件人過濾

收件人黑名單和收件人白名單清單可以是﹕郵件位址､網域名稱。這個位址一般應該從 “系統日誌”/“SMTP”中分析出的郵件位址﹐而不是從收到的郵件頭中看到的郵件位址。因為郵件頭中收件人位址與實際發郵件命令中的收件人( SMTP 通訊協定中的 RCPT TO 命令)的位址可以不一樣。如果需要過濾或允許 demomail.com 網域名稱所有用戶發過來的郵件﹐可以將 @demomail.com 增加到黑名單或白名單清單中。

收件人黑名單﹕為了防止垃圾郵件發送者的攻擊﹐始終給系統中的某些用戶發郵件。
用戶可以過濾一些系統中不存在的用戶的郵件位址﹐請選擇“給本系統內用戶發郵件時﹐檢查郵箱是否存在”。

收件人白名單﹕如果需要對某些收件人不作過濾規則的檢查﹐請增加到白名單的清單中。

IP 過濾

發信 IP 黑名單和發信 IP 白名單清單是填寫 SMTP 日誌中來源伺服器的 IP 位址。

發信 IP 黑名單﹕拒絕某個 IP 位址或某段 IP 位址連接發送郵件。可以填寫 219.159.20. 表示過濾 219.159.20. 開頭的所有 IP。

發信 IP 白名單﹕對某個 IP 位址或某段 IP 位址發送郵件不進行垃圾郵件檢查。

HELO/PTR 過濾

HELO/PTR 主機黑名單和HELO/PTR 主機白名單填寫 SMTP 日誌中的 HELO 主機名。
如果用戶不想接收動態網域名稱主機發過來的郵件﹐可以填寫動態網域名稱到黑名單清單中來過濾動態網域名稱發過來的郵件。

HELO/PTR 主機黑名單﹕拒絕 HELO 主機名是黑名單清單中的主機發來的郵件。如果用戶不想接收動態網域名稱主機發過來的郵件﹐可以填寫動態網域名稱到黑名單清單中來過濾動態網域名稱發過來的郵件。

HELO/PTR 主機白名單﹕接收 HELO 主機名是白名單清單中的主機發來的郵件﹐可以解決有的郵件系統 helo 主機名設定錯誤或 helo 主機名沒有正確解析﹐導致被拒絕接收。如﹕Microsoft Office 365 的企業郵局。


RBL/RWL 設定

RBL(Real-time Black List, 即時黑名單)﹕接收來自外域的郵件時﹐通過 RBL黑名單伺服器對來源 IP 進行檢查﹐決定是否過濾此郵件。

DBL(Domain Black List, 網域名稱黑名單)﹕接收來自外域的郵件﹐通過 DBL黑名單伺服器對發件者的主機名和網域名稱進行檢查﹐決定是否過濾此郵件。

RWL(Real-time White List, 即時白名單)﹕接收來自外域的郵件時﹐通過 RWL白名單伺服器對來源 IP 進行檢查﹐決定是否信任此郵件。

常用的 RBL 伺服器:
sbl.spamhaus.org
cbl.abuseat.org
b.barracudacentral.org
bl.spamcop.net
psbl.surriel.com

常用的 DBL 伺服器:
dbl.spamhaus.org
multi.surbl.org


灰名單

連接延時回應：為了發送大量垃圾郵件，垃圾郵件發送工具不能花費太多時間與內送郵件伺服器通信。通過在 SMTP 通信開始引入延時和流量檢查， 使很多垃圾郵件發送工具放棄而不影響正常郵件接收, 建議設置短一些 10 或者 15。

灰名單(Greylisting)： 系統第一次收到未通過驗證的寄件者和 IP 位址來信時，回應4xx的回傳代碼，待稍後對方系統郵件重新發過來時，才接受郵件，可提高垃圾郵件的識別率，針對正常重新發過來的寄件者，郵件系統會自動加白名單。 可以顯示當前灰名單的清單。
功能原理請訪問：http://www.greylisting.org/ 建議設置執行時間段為垃圾郵件比較多的時間。比如每天的晚上19點到第二天的早上7點，要避開工作時間段。


郵件過濾

在郵件遞送過程﹐分析郵件中的內容是否滿足設定的規則。管理員也可以根據實際情況﹐通過設定過濾規則來完成郵件的分發。

功能選項

1.新增

增加新的過濾規則。

規則標簽 | 由用戶自己命名﹐各過濾規則的標簽不能相同。
排序號 | 過濾規則的優先權
過濾欄位 指出所要過濾的信頭中的欄位名。如要包含如下幾種欄位﹕發件人﹐收件人﹐抄送﹐主題﹐Received﹐郵件頭﹐郵件內容 等。
Received 是指經過各郵件伺服器﹐由郵件伺服器增加的標識欄位。
匹配方式 | 多種型式﹕為空､不存在､包含(不區分大小寫)､包含(區分大小寫)､不包含(不區分大小寫)､不包含(區分大小寫)､等於(不區分大小寫)､等於(區分大小寫)､不等於(不區分大小寫)､不等於(區分大小寫)。
過濾內容

要過濾的內容。可以寫表達式﹐如﹕過濾類似這樣串 test{sex}test 可以寫能表達式 *{*}*
注意﹕多個過濾內容可以用分號(;)隔開
啟用 | 設定此過濾規則是否生效。
動作 滿足條件﹕丟棄､發送通知信給發送者､繼續遞送給接收者､儲存到隔離區。同時也可以設定遞送給某個用戶。
遞送給欄目可以增加多個郵件位址﹐各郵件位址用分號(;)分隔開。
不滿足條件﹕可以繼續過濾規則或終止過濾過濾規則。

2.編輯

修改已選的過濾規則。

3.解除

解除已選的過濾規則。支援單條和多條記錄的解除。

4.刷新

從後臺資料庫重新讀取數據﹐刷新介面。

注意事項

當系統設有“郵件監控”和“過濾規則”情況下﹐滿足過濾條件的動作沒有選擇“繼續遞送給接收者”時﹐被過濾的郵件不會被監控到。


內嵌圖過濾

通過 OCR 識別郵件內嵌圖中的文字﹐包含指定關健字的內嵌圖郵件﹐會被判斷成垃圾郵件


在線垃圾郵件庫

服務期內的用戶可以享受從 Winmail 官網在線更新最新的垃圾郵件過濾規則庫


郵件隔離區

如果在“SMTP 設定”中﹐設定了垃圾郵件儲存在隔離區﹐收到垃圾郵件時﹐會被自動儲存在特定檔案夾﹐以便用戶和管理員能取回。

功能選項

1.發送

重新發送區選中的隔離郵件給收件人。

2.加白名單

將隔離郵件的發件人位址加入到系統的發件人白名單。

3.設定

設定隔離郵件是否發送通知給收件人以及隔離郵件保留多少天。

用戶 Webmail 取回

收件人也可以登入 Webmail 看到自己的隔離郵件並取回﹔也可以通過隔離通知郵件中的連接來取回。


過濾統計

統計各項過濾規則﹐在某個時間段內過濾的總數


網域名稱設定

網域名稱管理
域別名管理


網域名稱管理

對郵件系統中的所用網域名稱進行管理。

功能選項

1.新增

步驟一﹕基本參數

網域名稱

本域的網域名稱。如果要正常的與外域其他郵箱能正常收發郵件﹐一般是要經過網域名稱機構的註冊過的網域名稱。
如果要加入中文網域名稱﹐需要將網域名稱在 http://www.cnnic.cn 進行轉碼﹐然後加入 punycode 碼的網域名稱﹐Webmail 可以正常顯示﹐也能正常收發郵件。
描述 | 本域的相關描述。
域型式 網域名稱型式﹕主域和普通域。
主域的用戶在 Outlook 或 Foxmail 設定中 POP3 用戶時只要郵箱位址的用戶名﹐不需要網域名稱﹔而非主域的用戶在 Outlook 或 Foxmail 設定中POP3用戶時要用寫全位址。
如﹕設定郵件位址 test@domain.com﹐當為主域下郵箱時﹐POP3 用戶名為 test﹔當為非主域下郵箱時﹐POP3用戶名要寫成 test@domain.com。
所有郵箱總容量 | 本域下所有郵箱最多能用的總容量。
最多支援郵箱數 | 本域最可用的郵箱數量。
所有網路磁碟總容量 | 本域下所有網路磁碟最多能用的總容量。
郵件密碼加密方式 | 本域下所有新增用戶的密碼存儲時的加密方式。
本域下﹐增加新用戶自動增加到 everyone 群組 | 此網域名稱下的﹐新增用戶時自動增加 everyone 群組。
本域下的用戶﹐增加個人資訊到公用位址簿 | 當啟用了公用位址簿功能﹐允許增加個人資訊到公用位址簿。
用戶可以決定個人資訊是否到公用位址簿 | 允許用戶選擇是否將個人資訊增加到公用位址簿。
公用位址簿只允許本域下的用戶存取 | 本域下的公用位址簿資訊只允許本網域名稱下的用戶來存取。

步驟二﹕進階屬性

NT 域認證 | 與作業系統下的域進行整合。用戶登陸郵箱或發郵件認證時﹐將使用NT域下的同名用戶的密碼進行認證。 支援 LDAP 格式﹐如 LDAP://192.168.120.102/dc=test,dc=local
域管理員郵箱 | 本域的管理員郵箱位址。
直接登入URL | 直接登入本域的URL, 用此URL登入WebMail時只顯示本網域名稱。
允許通過webmail註冊郵箱 | 允許通過webmail註冊新郵箱。
新註冊的郵箱需管理員確認才生效 | 所有新註冊的郵箱在正常使用前﹐必須經過管理員確認。
發送註冊通知郵件給域管理員 | 當有用戶註冊新郵箱時﹐發送通知郵件給本域的管理員。
彈回錯誤信給發送者 | 若用戶所發的信不在本域﹐則postmaster會發錯誤信給該用戶。
遞送至郵箱 | 若用戶所發的信不在本域﹐則系統會把此信投遞到該郵箱。
發送到Internet | 若用戶所發的信不在本域﹐則系統會把此信外發到Internet。

步驟三﹕預設容量

郵箱容量 | 本域下新增郵箱的預設容量。
郵箱郵件數 | 本域下新增郵箱的預設郵件數。
郵箱容量警告 | 本域下新增郵箱的預設容量警告限制。
郵箱存儲目錄 | 本域下新增郵箱的預設存儲目錄。為空時﹐使用系統定義的郵箱存儲目錄。
網路磁碟容量 | 本域下新增郵箱的網路磁碟預設容量。
網路磁盤檔數 | 本域下新增郵箱的網路磁碟預設檔案數。
網路磁碟存儲目錄 | 本域下新增郵箱的網路磁碟預設存儲目錄。為空時﹐使用系統定義的網路磁碟存儲目錄。

步驟四﹕預設權限

失效日期 | 本域下新增郵箱預設失效時間。設定禁止後﹐域管理員無權來對域下用戶取消失效日期。
禁止 SMTP | 本域下新增郵箱預設禁止 SMTP。
禁止 POP3 | 本域下新增郵箱預設禁止 POP3。
禁止 IMAP | 本域下新增郵箱預設禁止 IMAP。
禁止 Webmail | 本域下新增郵箱預設禁止 Webmail。
禁止修改用戶資訊 | 本域下新增郵箱預設禁止網路磁碟。
禁止外部 POP3 郵箱 | 本域下新增郵箱預設禁止外部 POP3 郵箱。
禁止自動轉發 | 本域下新增郵箱預設禁止自動轉發。
禁止自動回復 | 本域下新增郵箱預設禁止自動回復。
禁止解除 | 本域下新增郵箱預設禁止用戶解除郵件。
禁止公用位址簿 | 本域下新增郵箱預設禁止存取公用位址簿。設定禁止後﹐域管理員無權來對域下用戶啟用/禁止此功能。
禁止查詢歸檔郵件 | 本域下新增郵箱預設禁止通過 Web 來查詢和取回本人接收和發送時系統歸檔的郵件。設定禁止後﹐域管理員無權來對域下用戶啟用/禁止此功能。
禁止 PushMail(EAS) | 本域下新增郵箱預設禁止通過 PushMail(EAS) 來同步郵件﹐聯繫人以及行事歷。設定禁止後﹐域管理員無權來對域下用戶啟用/禁止此功能。
禁止網路磁碟 | 本域下新增郵箱預設禁止網路磁碟。設定禁止後﹐域管理員無權來對域下用戶啟用/禁止此功能。
禁止網路行事歷 | 本域下新增郵箱預設禁止網路行事歷。設定禁止後﹐域管理員無權來對域下用戶啟用/禁止此功能。
禁止網路記事本 | 本域下新增郵箱預設禁止網路記事本。設定禁止後﹐域管理員無權來對域下用戶啟用/禁止此功能。
禁止短信通知 | 本域下新增郵箱預設禁止新郵件短信通知。
禁止發送短信 | 本域下新增郵箱預設禁止 Webmail 上發送短信。

步驟五﹕預設發送/接收

發送 | 本域下新增郵箱預設的“禁止發送郵件到本域下其他用戶”﹐“禁止發送郵件到系統內的其他域”﹐“禁止發送郵件到系統外的域”設定。
收外 | 本域下新增郵箱預設的“禁止接收本域下其他用戶發來的郵件”﹐“本系統內其他域發來的郵件”﹐“接收系統外的域發來的郵件”設定。

步驟六﹕預設流量控制

發送限制 | 本域下新增郵箱預設的發送的最大郵件位元組數和每小時發送的收件人數。
本地遞送 | 本域下新增郵箱預設發系統內郵件時﹐每天發送的收件人數限制和發送的郵件總位元組數限制。
遠端遞送 | 本域下新增郵箱預設外發郵件時﹐每天發送的收件人數限制和發送的郵件總位元組數限制。

步驟七﹕預設密碼策略

安全 | 本域下新增郵箱預設設定下次登入必須修改密碼﹐多少天必須修改密碼以及禁止用戶修改密碼。
強度 | 本域下新增郵箱預設密碼最小長度和密碼字串的必須達到的強度。
用戶端授權碼 | 第三方用戶端（如 Outlook､移動設備上的郵件 APP）專屬的授權密碼﹐用授權碼代替郵箱密碼登入用戶端﹐用戶可以在 Webmail 裏設定多個授權碼。

步驟八﹕預設郵件處理

歸檔郵件 | 本域下新增郵箱預設自動歸檔設定。
解除郵件 | 本域下新增郵箱預設自動解除設定。

步驟九﹕第三方認證

型式 | 選擇第三方認證通訊協定﹐支援 LDAP, Radius
主機名 | 設定第三方認證伺服器的主機。如 LDAP://192.168.120.102/dc=test,dc=local
連接埠 | 設定第三方認證伺服器的存取連接埠。
用戶名 | 設定第三方認證伺服器存取用戶名。如﹕cn=mytest,cn=users,dc=mydomain,dc=com
密碼 | 設定第三方認證伺服器存取密碼。Radius 伺服器設定密鑰
搜索起點 | LDAP 伺服器設定搜索起點。如 dc=mydomain,dc=com
搜索過濾器 | LDAP 伺服器設定搜索過濾器。如 Windows 活動目錄﹕(&(objectCategory=person)(objectClass=user)(sAMAccountName=$uid))

步驟十﹕遷移

通訊協定 | 選擇郵件收取通訊協定﹐支援 POP3, IMAP
主機位址 | 設定原郵件伺服器的位址
連接埠 | 設定原郵件伺服器相關通訊協定的存取連接埠。
用戶名格式 | 設定認證用戶名的格式
保留備份 | 設定是否在原伺服器上保留備份
郵件數 | 設定每次收取的郵件數

步驟十一﹕簽名檔

簽名內容 本域下用戶發送郵件時﹐郵件附帶的簽名內容。當要增加 HTML 簽名內容時﹐直接輸入 HTML 代碼﹐選中“HTML 格式”

步驟十二﹕Webmail 定制

公司標簽 | 設定網域名稱對應公司的標簽﹐這個標簽會顯示在網頁的標題裏﹐可以設定成﹕***公司郵件系統
網站位址 | 設定公司的網站的位址。Webmail 首頁鏈接可以存取
ICP 備案號 | 設定ICP 備案號﹐可以在 Webmail 首頁顯示
Logo 圖像 | 網域名稱對應的的 logo 圖像。可以上傳 jpg/gif/png 圖片﹐為了有更好的顯示效果﹐建議圖片的像素大小不要大於 180 * 60 px

步驟十三﹕DKIM 設定

選擇器 | 設定 DKIM 的選擇器
私鑰 | 設定 DKIM 的私鑰﹐有關 DKIM 密鑰產生參考 DKIM Core

步驟十四﹕分散式

同步密碼 | 設定主/從伺服器之間同步帳號資訊時的認證密碼
作為主伺服器 | 設定作為主伺服器執行﹐同時增加允許的從伺服器的位址。
作為從伺服器 | 設定作為主伺服器執行﹐同時設定主伺服器的位址和連接埠。

敘述﹕
1. 啟用分散式域必須在“系統設定”/"進階設定"/“系統參數”中設定"本機主機名/IP 位址"。
2. 主伺服器的管理連接埠必須對外開放﹐允許從伺服器存取。
3. 主伺服器損壞時﹐必須另選擇一臺伺服器設定成主伺服器﹐否則影響從伺服器的正常執行。

步驟十五﹕用戶同步

同步型式 支援從 AD, LDAP, 企業微信﹐釘釘同步用戶

步驟十六﹕郵箱限制

最多簽名數 | 本域下用戶允許的最多的簽名數。
最多聯繫人數 | 本域下用戶允許的最多的聯繫人數。
最多POP3郵箱數 | 本域下用戶允許的最多的外部POP3郵箱數。
POP3收取的最多郵件數 | 本域下用戶每個外部POP3能收取的最多的郵件數。
POP3收取的最大郵件 | 本域下用戶每個外部POP3能收取的最大的郵件。
最多的過濾規則 | 本域下用戶允許的最多的郵件過濾規則。

2.編輯

對已選的域參數進行修改。各項內容與“新增”相同。

3.解除

解除已選的域。支援單條和多條記錄的解除。注﹕主域不能被解除。

4.重算佔用空間

重新計算域下已分配的空間情況。

5.刷新

從後臺資料庫重新讀取數據﹐刷新介面。

注意事項

1. 主域的用戶在 Outlook 或 Foxmail 設定中 POP3 用戶時只要郵箱位址的用戶名﹐不需要網域名稱﹔而非主域的用戶在 Outlook 或 Foxmail 設定中POP3用戶時要用寫全位址。
如﹕設定郵件位址 test@domain.com﹐當為主域下郵箱時﹐POP3 用戶名為 test﹔當為非主域下郵箱時﹐POP3用戶名要寫成 test@domain.com。
2. 主域不能被解除。但可以被改名。普通域可以被解除﹐但不能改名。
3. 解除網域名稱前的一定要解除此網域名稱下所有用戶郵箱﹐用戶別名以及郵件群組記錄。
4. 如果對網域名稱和DNS有疑問﹐請見﹕郵件/網域名稱/DNS相關知識 郵件/動態網域名稱專題。


域別名管理

對郵件系統中的域別名進行管理。

功能選項

1.新增

輸入域別名﹐選擇對應的網域名稱。

2.移除

移除已選的域別名。支援單條和多條記錄的移除。

3.刷新

從後臺資料庫重新讀取數據﹐刷新介面。


用戶和群組

用戶管理
群組管理
用戶別名管理
公共位址簿


用戶管理

對系統中的郵箱用戶進行管理。

功能選項

1.新增

步驟一﹕基本設定

用戶名 | 用戶登陸郵箱的帳號。用戶名和密碼不能為空
密碼提示問題 | 取回帳號密碼時的提示問題。
取回密碼答案 | 取回帳號密碼時的問題答案。
認證型式 支援以下三種認證方法﹕
“內部數據認證”﹐用系統內密碼進行認證。
“NT 域認證”﹐連接網域名稱參數中設定 NT 網域名稱相關用戶的密碼進行認證。
“第三方認證”﹐連接網域名稱參數中設定認證伺服器進行認證。
帳號狀態 “正常”﹕此用戶為可用的正常郵箱。
“禁止”﹕此用戶為無效﹐無法登入､接收和發送郵件﹐管理員將狀態修改成“禁止”不會影響該郵箱裏原有的郵件。
“待審核”﹕用戶為 Webmail 申請新用戶﹐等待管理員審核批準﹐管理員將狀態修改成“正常”後就可以正常使用。
“暫停”﹕用戶被臨時凍結﹐無法登入郵箱﹐一般是登入密碼多次錯誤導致的﹐10分鐘後系統自動解凍﹐管理員也可以手工將狀態改回“正常”。
失效日期 | 郵箱用戶的失效時間。網域名稱設定禁止後﹐域管理員無權來啟用/禁止此功能。
密級 | 設定郵箱用戶的密級﹐密級從低到高分為“無”､“限制”､“秘密”和“機密”。相對應的郵件也分“無”､“限制”､“秘密”和“機密”三個密級。 郵箱用戶不可以發送和閱讀高於自己密級的郵件。

步驟二﹕個人資訊

注意﹕若開啟公用位址簿功能﹐選擇了“增加個人資訊到公用位址簿”﹐則可以增加這些資訊到公用位址簿中。

步驟三﹕群組設定

步驟四﹕容量設定

郵箱容量 | 分配給用戶郵箱的最大容量﹔值為0﹐則不限郵箱容量
最多的郵件數 | 此郵箱能容納的最多郵件數﹔值為0﹐則不限郵件數目
容量警告限制 當用戶郵箱容量使用率的達到所設的值﹐系統會給此用戶發警告信﹔
值為0﹐則不予警告
郵件存儲目錄 | 此用戶的郵箱存儲目錄路徑。為空時﹐使用域屬性中定義郵箱存儲目錄。
網路磁碟容量 | 分配給用戶郵箱網路磁碟預設的最大容量。
最多的檔案數 | 此郵箱網路磁碟預設的最多檔案數。
網路磁碟存儲目錄 | 此用戶的網路磁碟的存儲目錄路徑。為空時﹐使用域屬性中定義網路磁碟存儲目錄。

步驟五﹕權限設定

禁止 SMTP | 禁止用戶使用 SMTP 服務。
禁止 POP3 | 禁止用戶使用 POP3 服務。
禁止 IMAP | 禁止用戶使用 IMAP 服務。
禁止 Webmail | 禁止用戶使用 Webmail 服務。
禁止修改用戶資訊 | 禁止用戶修改用戶資訊。
禁止外部 POP3 郵箱 | 禁止用戶使用 POP3 郵箱。
禁止自動轉發 | 禁止用戶設定自動轉發。
禁止自動回復 | 禁止用戶設定自動回復。
禁止解除郵件 | 禁止用戶解除本郵箱的郵件﹐包括用戶端和 Webmail。
禁止公用位址簿 | 禁止用戶存取公用位址簿。網域名稱設定禁止後﹐域管理員無權來啟用/禁止此功能。
禁止查詢歸檔郵件 | 禁止用戶通過 Web 來查詢和取回本人接收和發送時系統歸檔的郵件。設定禁止後﹐域管理員無權來對域下用戶啟用/禁止此功能。
禁止 PushMail(EAS) | 禁止用戶通過 PushMail(EAS) 來同步郵件﹐聯繫人以及行事歷。設定禁止後﹐域管理員無權來對域下用戶啟用/禁止此功能。
禁止網路磁碟 | 禁止用戶使用網路磁碟。網域名稱設定禁止後﹐域管理員無權來啟用/禁止此功能。
禁止網路行事歷 | 禁止用戶使用網路行事歷。網域名稱設定禁止後﹐域管理員無權來啟用/禁止此功能。
禁止網路記事本 | 禁止用戶使用網路記事本。網域名稱設定禁止後﹐域管理員無權來啟用/禁止此功能。
禁止短信通知 | 禁止用戶設定郵件短信通知。
禁止發送短信 | 禁止用戶使用 Webmail 發送短信。

步驟六﹕發送/接收

發送 | 可以設定“禁止發送郵件到本域下其他用戶”﹐“禁止發送郵件到系統內的其他域”﹐“禁止發送郵件到系統外的域”。
接收 | 可以設定“禁止接收本域下其他用戶發來的郵件”﹐“禁止接收本系統內其他域發來的郵件”﹐“禁止接收系統外的域發來的郵件”。

步驟七﹕流量控制

發送限制 | 設定用戶發送的最大郵件位元組數和每小時發送的收件人數。
本地遞送 | 設定用戶發系統內郵件時﹐每天發送的收件人數限制和發送的郵件總位元組數限制。
遠端遞送 | 設定用戶外發郵件時﹐每天發送的收件人數限制和發送的郵件總位元組數限制。

步驟八﹕密碼策略

安全 | 設定用戶下次登入必須修改密碼﹐多少天必須修改密碼以及禁止用戶修改密碼。
用戶端授權碼 | 第三方用戶端（如 Outlook､移動設備上的郵件 APP）專屬的授權密碼﹐用授權碼代替郵箱密碼登入用戶端﹐用戶可以在 Webmail 裏設定多個授權碼﹔建議為每個用戶端加不同的授權碼﹔ 用戶啟用使用授權碼後﹐用戶端裏必須使用﹐不能再使用郵箱密碼﹐Webmail 還是使用原郵箱密碼登入。

步驟九﹕存取控制

設定指定用戶存取 SMTP/Secure SMTP, POP3/Secure POP3, IMAP/Secure IMAP, Webmail/Secure Webmail, FTP/Secure FTP 各服務的允許和禁止的 IP 位址。

步驟十﹕郵箱設定

自動轉發 設定了自動轉發郵箱﹐則發往此用戶的信件自動轉發到此郵箱。
如果設定了保留備份﹐郵件自動轉發後會繼續遞送此郵件給本郵箱。
啟用自動回復 | 啟用自動回復後﹐收到新郵件後將會自動回復發件人。
啟用新郵件短信通知 | 啟用新郵件短信通知後﹐收到新郵件會發手機短信給用戶個人資訊中設定的手機號碼。前提條件是系統必須在“系統設定”-》“短訊息通知”中﹐正確設定發送手機短信的參數。
垃圾郵件處理 收到的郵件如被判定為垃圾郵件﹐可以進行以下 2 種動作﹕
1.遞送到垃圾郵件夾;
2.郵件主題增加[SPAM]標識﹐繼續遞送到[收件匣]。

步驟十﹕郵件處理

自動歸檔 | 設定用戶郵件多少天前的﹐自動按年歸檔
自動解除 | 設定用戶郵件的各個郵件夾郵件多少天前的自動解除。

2.編輯

對已選的用戶做參數修改。畫面同“新增”。

1)郵箱狀態

在“個人資訊”中﹐顯示此用戶自定的外部POP3郵箱資訊及已用空間資訊。

“重算郵箱空間”可以對用戶的已用空間進行重新計算。
“清空用戶郵箱”可以直接清除用戶郵箱中的所有郵件。
“清空網路磁碟”可以直接清除用戶郵箱的網路磁碟中的所有檔案。

2)發送記錄

顯示郵箱用戶最近的發送郵件記錄﹐並統計當天的發送到本地/外部的收件人數和郵件位元組數

3)接收記錄

顯示郵箱用戶最近的接收郵件記錄﹐並統計當天的接收到本地/外部的收件人數和郵件位元組數

4)存取記錄

顯示郵箱用戶的 POP3﹐IMAP﹐Webmail 存取的記錄。

5)郵件解除記錄

顯示郵箱用戶郵件解除的記錄。

3.解除

解除已選的用戶。支援單條和多條記錄的解除。
注意﹕解除用戶時﹐郵箱目錄中的所有郵件和網路磁碟中的所有檔案也會被解除。不能恢復
Winmail 6.0 增加郵箱目錄郵件保留 15 天的功能。以防管理員誤解除﹐過期會自動清除。

4.導入

1) 從檔案導入

選擇一下導入檔案﹐並根據選擇導入檔案格式選擇注解符號與分隔符號。

選擇導入檔案中的欄位與用戶資訊欄位的映射關係。

進行導入﹐如果導入檔案很大時﹐可能需要等待。最後顯示導入結果。

2) 從系統導入

設定要導入用戶的伺服器﹐列出伺服器上的所有帳號﹐選擇要導入的用戶﹐導入到指定的域下。
如果導入用戶比較多時﹐可能需要等待。最後顯示導入結果。

5.導出

選擇導出檔案﹐然後選擇要導出的欄位﹐進行導出。

6.批量更新

選取需要批量更新的用戶﹐選擇需要批量更新的記錄﹐然後更新批量更新。

7.遷移

域開啟了分散式功能後﹐主伺服器可以將用戶從一臺機器遷移到另一臺機器。

敘述﹕
1. 只遷移郵件帳號到新郵件主機﹐不遷移用戶郵件。可以拷貝用戶的郵件存儲目錄到新的郵件主機。
2. 請確保新郵件主機有足夠的授權用戶數﹐否則會影響新郵件主機的正常執行。

8.刷新

從後臺資料庫重新讀取數據﹐刷新介面。

注意事項

1. 主域的用戶在 Outlook 或 Foxmail 設定中 POP3 用戶時只要郵箱位址的用戶名﹐不需要網域名稱﹔而非主域的用戶在 Outlook 或 Foxmail 設定中POP3用戶時要用寫全位址。
如﹕設定郵件位址 test@domain.com﹐當為主域下郵箱時﹐POP3 用戶名為 test﹔當為非主域下郵箱時﹐POP3用戶名要寫成 test@domain.com。


群組管理

對系統中的郵件群組進行管理。郵件群組也是一個郵件位址﹐給群組位址發郵件﹐群組下的所有成員都將會收到該郵件。支援多層級郵件群組。

功能選項

1.新增

步驟一﹕基本設定

步驟二﹕群組成員

步驟三﹕發信權限

步驟四﹕允許發信群組員

步驟五﹕群組管理員

指定的群組管理員可以通過 Webmail 來對群組成員和發信權限進行管理。

步驟六﹕發信代表

指定的群組發信代表﹐可以用群組位址發信給其他人。

2.編輯

對已選的群組作參數修改。畫面同“新增”。

3.解除

解除已選的用戶。支援單條和多條記錄的解除。

4.導入

導入所有群組的成員清單和群組的所有資訊。

5.導出

導出所有群組的成員清單和群組的所有資訊。

4.刷新

從後臺資料庫重新讀取數據﹐刷新介面。


用戶別名管理

對系統中的用戶別名進行管理。

功能選項

1.新增

步驟一﹕ 輸入用戶別名

步驟二﹕選擇真實郵箱位址

2.編輯

對已選的用戶別名作參數修改。畫面同“新增”。

3.移除

移除已選的用戶。支援單條和多條記錄的移除。

4.刷新

從後臺資料庫重新讀取數據﹐刷新介面。


管理員管理

對郵件系統的管理員進行增加﹐解除和編輯操作。郵件系統有﹕超級管理員､域管理員､角色管理員。超級管理員可以管理全部系統設定﹔域管理員只可以管理得到授權的域下的部份屬性﹐以及域下郵箱用戶﹐郵箱別名以及群組﹔ 角色管理員可以管理一項或者多項指定功能。

功能選項

1.新增

用戶名 | 管理員的登入名
密碼 | 管理員的登入密碼
描述 | 管理員的相關描述
管理員型式 | 三種型式﹕超級管理員､域管理員､角色管理員

2.編輯

對已選的管理員參數進行修改。各項內容與“新增”相同。

3.解除

解除已選的管理員。

4.刷新

從後臺資料庫重新讀取數據﹐刷新介面。


公共位址簿

在LDAP中所有用戶的資訊﹐包括郵件系統的帳號和外部位址﹔利用此功能可以加入 其它聯繫人資訊以供用戶找到。
Outlook, Webmail 等可找到, 請參考公共位址簿用戶端。

公用聯繫人的型式共有兩種﹕
1.是郵件系統的用戶﹐在用戶管理中被設定加入了公共 位址簿(系統帳號)﹔
2.在此開新文件的其它聯繫人的帳號(非系統帳號)

功能選項

1.新增

步驟一﹕聯繫人基本資訊

填寫帳號標簽和E-MAIL位址﹐最上面的E-MAIL位址被優先找到

步驟二﹕聯繫人的業務資訊

步驟三﹕聯繫人的家庭資訊

2.編輯

對已選的聯繫人資訊作參數修改﹔畫面同“新增”。 系統帳號的資訊此處不可修改﹐修改系統帳號的資訊請到用戶管理部分

3.解除

從LDAP公共位址簿解除聯繫人﹐不影響系統帳號原有的資訊

4.導入

步驟一﹕選擇導入檔案﹐設定導入選項

步驟二﹕顯示從導入檔案中提取的聯繫人資訊

步驟三﹕顯示導入成功的聯繫人

5.導出

選擇需要導入的欄位

6.刷新

從後臺資料庫重新讀取數據﹐刷新介面。


系統狀態

郵件隊列
短消息隊列
系統狀態統計表
系統流量統計圖
用戶流量統計表
活動連接


郵件佇列

郵件標識 | 郵件在佇列中的ID。
建立時間 | 郵件進行入佇列的時間。
最近重發時間 | 郵件最近一次的發送時間。
郵件大小 | 郵件的位元組數。
發件人 | 郵件的發送者位址。
接收人 | 郵件的接收者位址﹐多個接收人之間用分號分隔。
狀態 | 標識郵件的在佇列中的遞送狀態。 佇列遞送狀態﹕正在遞送﹔等待遞送﹔等待重試遞送﹔等待簽核
認證用戶 | 該郵件的認證用戶﹐可能和發件人不一樣。
用戶端IP | 該郵件的來源IP。

功能選項

解除: 解除選中的郵件。支援單條和多條。

清空: 解除郵件佇列中的所有的郵件。

查看: 查看郵件佇列中的所選郵件。

刷新: 從後臺資料庫重新讀取數據﹐刷新介面。

注意事項

當您郵件系統佇列中總是有很多的郵件﹐可能是有的郵箱密碼被猜解﹐郵件系統被作為垃圾郵件轉發伺服器了。 請修改一下對應"認證用戶"的密碼。
如果要清除佇列裏全部代發郵件﹐ 可以停止郵件系統﹐解除郵件系統所在目錄中的 server\queue 目錄下的所有子目錄和檔案﹐系統會自動重新所有子目錄﹐然後重新啟動郵件系統。


短訊息佇列

佇列標識 | 短訊息在佇列中的ID。
建立時間 | 短訊息進行入佇列的時間。
最近重發時間 | 短訊息最近一次的發送時間。
發件者 | 短訊息的發送者位址。
接收者 | 短訊息的接收者位址﹐多個接收人之間用分號分隔。
狀態 | 標識短訊息的在佇列中的遞送狀態。 佇列中遞送狀態﹕正在遞送﹔等待遞送

功能選項

解除: 解除選中的短訊息。支援單條和多條。

清空: 解除短訊息佇列中的所有的短訊息。

刷新: 從後臺資料庫重新讀取數據﹐刷新介面。


系統狀態統計表

1. SMTP/Secure SMTP狀態統計

顯示了 SMTP/Secure SMTP 伺服器當日的連接次數､連接失敗次數､認證錯誤次數､遞送的位元組數､被過濾的郵件總數(郵件來源過濾)等統計情況。

2. POP3/Secure POP3狀態統計

顯示了 POP3/Secure POP3 伺服器當日的連接次數､連接失敗次數､認證失敗次數､用戶取得的總位元組數等統計情況。

3. IMAP/Secure IMAP狀態統計

顯示了 IMAP/Secure IMAP 伺服器當日的連接次數､連接失敗次數､認證失敗次數､上傳的郵件數與下載的郵件數等統計情況。

4. FTP/Secure FTP狀態統計

顯示了 FTP/Secure FTP 伺服器當日的連接次數､連接失敗次數､認證失敗次數､上傳檔案數與下載的檔案數等統計情況。

5. ADMIN狀態統計

列出了ADMIN伺服器當日的連接次數､連接失敗次數､登陸錯誤次數等統計情況。

6. 郵件佇列狀態統計

統計了當日內的佇列處理過程中回圈遞送的郵件總數､延時再遞送郵件總數､彈回的郵件總數､被過濾的郵件總數(符合用戶自定義的過濾規則的郵件數)。

7. 郵件遞送狀態統計

統計了當日內的郵件遞送過程中遞送次數､遞送郵件位元組數､遞送失敗次數､本地遞送次數､本地遞送郵件位元組數､本地遞送失敗次數､遠端遞送次數､遠端遞送郵件位元組數､遠端遞送失敗次數及被過濾的郵件總數。


系統流量統計圖

顯示一天各時段的各郵件相關網路服務（SMTP, POP3, IMAP等）的存取流量圖﹐也可以按照日期顯示30天的流量圖。


用戶流量統計表

[白金版功能] 顯示各郵箱用戶每天的發送郵件個數和位元組數等數據﹐可以按照某個欄位排序﹐讓管理員可以分析系統執行情況﹐及時發現異常郵箱。
連續按兩下一個用戶﹐可以顯示該用戶的詳細存取記錄､發送記錄､接受記錄。


活動連接

顯示目前系統各郵件服務連接情況﹐只顯示目前打開中的連接﹐正常的郵件服務連接時間都很短暫﹐通常不會有很多打開中的連接。


系統日誌

管理員可以在系統日誌中查看有關的系統的運行情況記錄。系統記錄了有關 SYSTEM(系統日誌)、SMTP/Secure SMTP、POP3/Secure POP3、IMAP/Secure IMAP、QUEUE(郵件佇列)、Webmail/Secure Webmail、FTP/Secure FTP(網路磁片) 和 ADMIN 等運行情況，以便管理員能及時的瞭解系統的運行情況。

在上述的SMTP日誌記錄中，每條記錄都遵循一定的記錄格式：日期-時間 執行緒ID 日誌資訊

管理員也可以通過點擊清空某一個日誌檔或刪除某一個日誌檔，也可刷新日誌。

可以在"系統設置"-"高級設置"-"系統參數"-"基本參數"裡設置日誌語言為簡體中文 Chinese(Simplified)。


修改密碼

修改目前管理員的登入密碼


授權資訊

授權給 | 本系統授權給誰來使用。
最多可用郵箱數 | 顯示目前系統授權中允許使用的最多郵箱用戶數。
已分配郵箱數 | 顯示目前系統中已經增加的郵箱總數。
已有網域名稱數 | 顯示目前系統中已經增加的網域名稱數。
授權日期/裝設日期 | 顯示目前系統授權授權日期。如果沒有得到授權﹐則顯示系統的裝設日期。
還能使用天數 | 顯示目前系統授權還能使用的時間。
技術服務與版本升級截止日期 | 本系統所享受的技術服務與版本升級的終止日期。

註冊

用戶可通過點擊“註冊”按鈕﹐系統會彈出註冊視窗用來輸入用戶和註冊碼。

如果正確﹐系統授權資訊會顯示為您實際註冊最多可用信箱數。
如果系統提示出錯“Invalid License”﹐則表示註冊碼不正確﹐請重新輸入。
如果重試多次還是不成功﹐請和 register@winmail.cn 聯繫。

注意

1. 不要包含空格和換行﹐您可以採用從Email貼上去拷貝的方式輸入。
2. 如果確認註冊碼正確﹐還是提示“Invalid License”﹐則要檢查系統中已有用戶數超過授權許可。


公共位址簿用戶端

啟用公共位址簿

如果管理員在網域名稱設定時﹐選中“本域下的用戶﹐增加個人資訊到公用位址簿”﹐則在增加用戶時﹐用戶資訊將會自動增加到公用位址簿中。

設定與使用

用戶可以在Webmail中查看到公用位址簿中的用戶資訊。也可以通過郵件用戶端軟體來查看。前者在比較簡單﹐在此不作詳述。在此主要以Outlook 來敘述後者的設定與使用。

啟用郵件用戶端軟體﹕“開始”->“程式”->“附件”->“通訊錄”。

增加公共位址簿主機﹕選單上“工具”->“帳戶...”

點擊“加入...”﹐並輸入您的公共位址簿LDAP的主機。

選中新加帳戶屬性﹐點擊“屬性”﹐設定主機屬性。

當LDAP服務不允許匿名存取時﹐服務要選中此伺服器要求登入。有關是否允許匿名存取﹐請見“進階設定”/“系統參數”

登入用戶與用戶郵箱登入用戶名相同。主域下用戶為﹕郵箱名﹔普通域下用戶為﹕郵箱名@網域名稱。
密碼與用戶郵箱登入密碼相同。

在搜索範圍中選擇﹐公共位址簿主機。然後輸入搜索關鍵字進行搜索。


 COM 群組件功能

為了方便郵件系統與其他系統進行整合﹐郵件系統提供一個COM群組件接口﹐可以用來增刪用戶､域以及管理員。COM群組件接口程式存放在 ~\server\MailServerCtrl.dll﹐控件的名字為﹕MailServerCtrl.MailDBInterface﹐ eg: newObject.CreateObject("MailServerCtrl.MailDBInterface")

方法敘述

void InitControl(BSTR strProgPath)
敘述﹕初始化控制
參數﹕strProgPath郵件系統資料庫檔案所在目錄﹐如果為空串("")時﹐取回 Winmail 裝設時記錄在註冊表中的路徑。
返回﹕無。

BSTR GetDBPath()
敘述﹕取得資料庫檔案所在目錄。
參數﹕無。
返回﹕返回資料庫檔案所在目錄。

short AddDomain(BSTR strDomain)
敘述﹕增加一個網域名稱
參數﹕
strDomain - 網域名稱。
返回﹕
0 - 增加網域名稱成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 增加網域名稱失敗。

short ModifyDomain(BSTR strDomain, BSTR strNTDomain, BSTR strHost, BSTR strIP, BSTR strAdmin, short uRegister, short uConfirm)
敘述﹕修改域的屬性
參數﹕
strDomain - 網域名稱。
strNTDomain - NT 認證域的網域名稱﹔
strHost - 直接登入此域的主機名﹔
strIP - 直接登入此域的 IP 位址﹔
strAdmin - 此域的管理員郵箱﹔
uRegister - 是否允許 Webmail 註冊新用戶﹐1 - 允許﹐0 - 禁止﹔
uConfirm - Webmail 註冊新用戶後﹐是否需要管理員審核後生效﹐1 - 需要審核後生效﹐0 - 不需要審核直接生效。
返回﹕
0 - 修改域的屬性成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 域不存在或或讀取域資訊失敗﹔
3 - 修改域的屬性失敗。

short ModifyDomainStorage(BSTR strDomain, long lMailboxStorage, int iMailboxTotal, long lNetStoreStorage, long lMinMailboxQuota)
敘述﹕修改域的容量限制
參數﹕
strDomain - 網域名稱。
lMailboxStorage - 所有郵箱總容量﹐ O 表示不限制﹐單位﹕千位元組(KB)﹔
iMailboxTotal - 最多支援郵箱數﹐ O 表示不限制﹔
lNetStoreStorage - 所有網路磁碟總容量﹐ O 表示不限制﹐單位﹕千位元組(KB)﹔
lMinMailboxQuota - 單個郵箱最小容量﹐ 當值為 O 時﹐而 lMailboxStorage 值不為 0 時﹐自動設定為 3 M。
返回﹕
0 - 修改域的容量成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 域不存在或或讀取域資訊失敗﹔
3 - 修改域的容量失敗。

short ModifyDomainRight(BSTR strDomain, long lExpireTime, short uPop3Control, short uImapControl, short uWebmailControl, short uNetStoreControl, short uCalendarControl, short uNotebookControl, short uExternalPop3)
敘述﹕修改域下郵箱的預設權限
參數﹕
strDomain - 網域名稱。
lExpireTime - 郵箱過期時間﹐ O 表示沒有時間限制﹐時間值為 UNIX 時間戳﹔
uPop3Control- 禁止 POP3 服務﹐ O 表示允許﹐1 表示禁止﹔
uImapControl - 禁止 IMAP 服務﹐O 表示允許﹐1 表示禁止﹔
uWebmailControl - 禁止 Webmail 服務﹐ O 表示允許﹐1 表示禁止﹔
uNetStoreControl - 禁止網路磁碟﹐ O 表示允許﹐1 表示禁止﹔
uCalendarControl - 禁止網路行事歷﹐ O 表示允許﹐1 表示禁止﹔
uNotebookControl - 禁止網路記事本﹐ O 表示允許﹐1 表示禁止﹔
uExternalPop3 - 禁止外部 POP3 郵箱﹐ O 表示允許﹐1 表示禁止。
返回﹕
0 - 修改域下郵箱的預設權限成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 域不存在或或讀取域資訊失敗﹔
3 - 修改域下郵箱的預設權限失敗。

short ModifyDomainRight1(BSTR strDomain, short uModifyUserInfo, short uExternalPop3, short uAutoForward, short uAutoReply, short uSpamControl, short uPublicContact)
敘述﹕修改域下郵箱的預設權限
參數﹕
strDomain - 網域名稱。
uModifyUserInfo - 禁止用戶修改個人資訊﹐ O 表示允許﹐1 表示禁止﹔
uExternalPop3 - 禁止外部 POP3 郵箱﹐ O 表示允許﹐1 表示禁止﹔
uAutoForward - 禁止設定自動轉發﹐ O 表示允許﹐1 表示禁止﹔
uAutoReply - 禁止設定自動回復﹐ O 表示允許﹐1 表示禁止﹔
uSpamControl - 禁止啟用 SpamAssassin﹐ O 表示允許﹐1 表示禁止﹔
uPublicContact - 禁止公共位址簿﹐ O 表示允許﹐1 表示禁止。
返回﹕
0 - 修改域下郵箱的預設權限成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 域不存在或或讀取域資訊失敗﹔
3 - 修改域下郵箱的預設權限失敗。

short ModifyDomainRight2(BSTR strDomain, short uSmsNotify, short uSendSms)
敘述﹕修改域下郵箱的預設權限
參數﹕
strDomain - 網域名稱。
uSmsNotify - 禁止新郵件短信通知 POP3﹐ O 表示允許﹐1 表示禁止﹔
uSendSms - 禁止發送短信﹐O 表示允許﹐1 表示禁止。
返回﹕
0 - 修改域下郵箱的預設權限成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 域不存在或或讀取域資訊失敗﹔
3 - 修改域下郵箱的預設權限失敗。

short ModifyDomainSendRecv(BSTR pstrDomain, short uSendControl, short uRecvControl, BSTR pstrSendDomainList, BSTR pstrRecvDomainList)
敘述﹕修改域下郵箱的預設收發權限
參數﹕
strDomain - 網域名稱。
uSendControl - 發送限制﹐ 1 - 禁止發送郵件到本域下其他用戶﹐ 2 - 禁止發送郵件到系統內的其他域﹐ 4 - 禁止發送郵件到系統外的域﹔
uRecvControl - 接收限制﹐ 1 - 禁止接收本域下其他用戶發來的郵件﹐ 2 - 禁止接收本系統內其他域發來的郵件﹐ 4 - 禁止接收系統外的域發來的郵件﹔
pstrSendDomainList - 發送例外的網域名稱清單﹐與上述發送限制執行相反的操作﹐填寫多個網域名稱時﹐各網域名稱間用分號(;)隔開﹔
pstrRecvDomainList - 接收例外的網域名稱清單﹐與上述接收限制執行相反的操作﹐填寫多個網域名稱時﹐各網域名稱間用分號(;)隔開。
返回﹕
0 - 修改域下郵箱的預設收發權限成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 域不存在或或讀取域資訊失敗﹔
3 - 修改域下郵箱的預設收發權限失敗。

short ModifyDomainFlow(BSTR pstrDomain, long lSendMaxMsgSize, short uSendFreq, short uLocalTimes, long lLocalSize, short uRemoteTimes, long lRemoteSize)
敘述﹕修改域下郵箱的預設流量控制
參數﹕
strDomain - 網域名稱。
lSendMaxMsgSize - 允許的發送接收的單郵件最大位元組數﹐ O 表示使用“SMTP 設定”中的參數值﹐單位﹕位元組(B)﹔
uSendFreq - 每小時發送的收件人數﹐ O 表示不限制﹔
uLocalTimes - 發內部郵件時﹐每天發送的收件人數限制﹐ O 表示不限制﹔
lLocalSize - 發內部郵件時﹐發送的郵件總位元組數限制﹐ O 表示不限制﹐單位是 KB﹔
uRemoteTimes - 發外部郵件時﹐每天發送的收件人數限制﹐ O 表示不限制﹔
lRemoteSize - 發外部郵件時﹐發送的郵件總位元組數限制﹐ O 表示不限制﹐單位是 KB。
返回﹕
0 - 修改域下郵箱的預設流量控製成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 域不存在或或讀取域資訊失敗﹔
3 - 修改域下郵箱的預設流量控制失敗。

short ModifyDomainPwdPolicy(BSTR pstrDomain, short uChgPwd, short uExpiryDays, short uPwdLength, short uPwdStrength)
敘述﹕修改域下郵箱的預設密碼策略
參數﹕
strDomain - 網域名稱。
uChgPwd - 設定密碼安全性﹐ 1 - 用戶不能修改密碼﹐ 2 - 用戶每隔 N 天必須修改密碼﹐4 - 用戶下次時登入必須修改密碼﹔
uExpiryDays - 用戶修改密碼間隔的天數﹐ 預設 30 天﹔
uPwdLength - 密碼最少長度﹐ O 表示不限制﹔
uPwdStrength - 密碼的安全等級﹐ 0 - 低﹐ 1 - 中﹐ 2 - 高。
返回﹕
0 - 修改域下郵箱的預設密碼成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 域不存在或或讀取域資訊失敗﹔
3 - 修改域下郵箱的預設密碼失敗。

short ModifyDomainLimit(BSTR strDomain, short uSignatureNum, short uAddressNum, short uMailFilterNum, short uExternalMailNum, long lMaxPop3MailSize, short uMaxPop3MailTotal)
敘述﹕修改域下郵箱的組態
參數﹕
strDomain - 網域名稱。
uSignatureNum - 允許的最多簽名數量﹐ O 表示不限制﹔
uAddressNum - 允許的最多聯繫人數量﹐ O 表示不限制﹔
uMailFilterNum - 允許的最多過濾規則數量﹐ O 表示不限制﹔
uExternalMailNum - 允許的最多外部 POP3 郵箱數量﹐ O 表示不限制﹔
lMaxPop3MailSize - 外部 POP3 郵箱最大的郵件位元組數﹐ O 表示不限制﹐單位﹕位元組(B)﹔
uMaxPop3MailTotal - 外部 POP3 郵箱最多的郵件數﹐ O 表示不限制﹔
返回﹕
0 - 修改域下郵箱的組態成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 域不存在或或讀取域資訊失敗﹔
3 - 修改域下郵箱的組態失敗。

short DeleteDomain(BSTR strDomain)
敘述﹕解除一個網域名稱
參數﹕
strDomain - 網域名稱。
返回﹕
0 - 解除網域名稱成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 網域名稱下存在用戶﹐群組或別名﹔
3 - 解除網域名稱失敗。

short AddDomainAlias(BSTR strAliasDomain, BSTR strRealDomain)
敘述﹕增加一個域別名
參數﹕
strAliasDomain - 域的別名﹔
strRealDomain - 網域名稱別名對應的實際網域名稱。
返回﹕
0 - 增加域別名成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 增加域別名失敗。

short DeleteDomainAlias(BSTR strAliasDomain)
敘述﹕解除一個域別名
參數﹕
strAliasDomain - 域的別名。
返回﹕
0 - 解除域別名成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 解除域別名失敗。

short AddUser(BSTR strUser, BSTR strDomain, BSTR strPassword)
敘述﹕增加一個郵箱用戶
參數﹕
strUser - 用戶的郵箱名﹔
strDomain - 郵箱的網域名稱﹔為空串("")時﹐即為主域﹔
strPassword - 郵箱的密碼。
返回﹕
0 - 增加新郵箱成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 已經存在同名的郵箱﹔
3 - 已經存在同名的用戶別名﹔
4 - 已經存在同名的群組名﹔
5 - 此域下﹐用戶的郵箱數已經達到域的限制﹔
6 - 此域下﹐用戶的郵箱空間或網路磁碟空間已經達到域的限制﹔
7 - 所要增加的域不存在。
8 - 密碼太簡單或不符合網域名稱的密碼策略﹐要用數字﹐字母和符號群組合﹐要避免與用戶名相同或包含用戶名。

short ModifyUser(BSTR strUser, BSTR strDomain, BSTR strFullName, BSTR strDescription, BSTR strCompany, BSTR strOffice)
敘述﹕修改用戶資訊
參數﹕
strUser - 用戶的郵箱名﹔
strDomain - 郵箱的網域名稱﹔為空串("")時﹐即為主域﹔
strFullName - 用戶的全名﹔
strDescription - 用戶的描述﹔
strCompany - 用戶的公司/部門標簽﹔
strOffice - 用戶的辦公室。
返回﹕
0 - 修改用戶資訊成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 郵箱用戶不存在或讀取用戶資訊失敗﹔
3 - 修改用戶資訊失敗。

short ModifyUser1(BSTR pstrUser, BSTR pstrDomain, BSTR pstrMobile, BSTR pstrHomePhone, BSTR pstrHomeAddress, BSTR pstrJobTitle, BSTR pstrOfficePhone)
敘述﹕修改用戶資訊
參數﹕
strUser - 用戶的郵箱名﹔
strDomain - 郵箱的網域名稱﹔為空串("")時﹐即為主域﹔
pstrMobile - 用戶的手機號碼﹔
pstrHomePhone - 用戶的住宅電話﹔
pstrHomeAddress - 用戶的住宅位址﹔
pstrJobTitle - 用戶的職務﹔
pstrOfficePhone - 用戶的辦公室電話。
返回﹕
0 - 修改用戶資訊成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 郵箱用戶不存在或讀取用戶資訊失敗﹔
3 - 修改用戶資訊失敗。

short ModifyUserStatus(BSTR strUser, BSTR strDomain, short uStatus)
敘述﹕修改用戶郵箱狀態
參數﹕
strUser - 用戶的郵箱名﹔
strDomain - 郵箱的網域名稱﹔為空串("")時﹐即為主域﹔
uStatus - 郵箱狀態﹐ O 表示正常﹐1 表示禁止﹐2 表示等待審核。
返回﹕
0 - 修改用戶郵箱狀態成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 郵箱用戶不存在或讀取用戶資訊失敗﹔
3 - 修改用戶郵箱狀態失敗。

short ModifyUserQuota(BSTR strUser, BSTR strDomain, long lMailQuota, short iMailTotalLimit, short iWarningLimit, long lNetStoreQuota, int iNetStoreTotalLimit)
敘述﹕修改用戶郵箱容量
參數﹕
strUser - 用戶的郵箱名﹔
strDomain - 郵箱的網域名稱﹔為空串("")時﹐即為主域﹔
lMailQuota - 郵箱最大的容量﹐ O 表示不限制﹐單位﹕位元組(B)﹔
iMailTotalLimit - 郵箱最多的郵件數﹐ O 表示不限制﹔
iWarningLimit - 郵箱的容量警告﹐O 表示不限制﹐單位﹕百分比﹔
lNetStoreQuota - 網路磁碟的最大容量﹐ O 表示不限制﹐單位﹕位元組(B)﹔
iNetStoreTotalLimit - 網路磁碟的最多檔案數﹐ O 表示不限制。
返回﹕
0 - 修改用戶郵箱容量成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 郵箱用戶不存在或讀取用戶資訊失敗﹔
3 - 郵箱用戶所屬域不存在或讀取域資訊失敗﹔
4 - 此域下﹐用戶的郵箱空間或網路磁碟空間已經達到域的限制﹔
5 - 修改用戶郵箱容量失敗。

short ModifyUserRight(BSTR strUser, BSTR strDomain, long lExpireTime, short uPop3Control, short uImapControl, short uWebmailControl, short uNetStoreControl, short uCalendarControl, short uNotebookControl, short uExternalPop3)
敘述﹕修改郵箱用戶的權限
參數﹕
strUser - 用戶的郵箱名﹔
strDomain - 郵箱的網域名稱﹔為空串("")時﹐即為主域﹔
lExpireTime - 郵箱過期時間﹐ O 表示沒有時間限制﹐時間值為 UNIX 時間戳﹔
uPop3Control- 禁止 POP3 服務﹐ O 表示允許﹐1 表示禁止﹔
uImapControl - 禁止 IMAP 服務﹐O 表示允許﹐1 表示禁止﹔
uWebmailControl - 禁止 Webmail 服務﹐ O 表示允許﹐1 表示禁止﹔
uNetStoreControl - 禁止網路磁碟﹐ O 表示允許﹐1 表示禁止﹔
uCalendarControl - 禁止網路行事歷﹐ O 表示允許﹐1 表示禁止﹔
uNotebookControl - 禁止網路記事本﹐ O 表示允許﹐1 表示禁止﹔
uExternalPop3 - 禁止外部 POP3 郵箱﹐ O 表示允許﹐1 表示禁止。
返回﹕
0 - 修改用戶郵箱權限成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 郵箱用戶不存在或讀取用戶資訊失敗﹔
3 - 郵箱用戶所屬域不存在或讀取域資訊失敗﹔
4 - 此域下﹐用戶的網路磁碟空間已經達到域的限制﹔
5 - 修改用戶郵箱權限失敗。

short ModifyUserRight1(BSTR strUser, BSTR strDomain, short uModifyUserInfo, short uExternalPop3, short uAutoForward, short uAutoReply, short uSpamControl, short uPublicContact)
敘述﹕修改郵箱用戶的權限
參數﹕
strUser - 用戶的郵箱名﹔
strDomain - 郵箱的網域名稱﹔為空串("")時﹐即為主域﹔
uModifyUserInfo - 禁止用戶修改個人資訊﹐ O 表示允許﹐1 表示禁止﹔
uExternalPop3 - 禁止外部 POP3 郵箱﹐ O 表示允許﹐1 表示禁止﹔
uAutoForward - 禁止設定自動轉發﹐ O 表示允許﹐1 表示禁止﹔
uAutoReply - 禁止設定自動回復﹐ O 表示允許﹐1 表示禁止﹔
uSpamControl - 禁止啟用 SpamAssassin﹐ O 表示允許﹐1 表示禁止﹔
uPublicContact - 禁止公共位址簿﹐ O 表示允許﹐1 表示禁止。
返回﹕
0 - 修改用戶郵箱權限成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 郵箱用戶不存在或讀取用戶資訊失敗﹔
3 - 修改用戶郵箱權限失敗。

short ModifyUserRight2(BSTR strUser, BSTR strDomain, short uSmsNotify, short uSendSms)
敘述﹕修改郵箱用戶的權限
參數﹕
strUser - 用戶的郵箱名﹔
strDomain - 郵箱的網域名稱﹔為空串("")時﹐即為主域﹔
uSmsNotify - 禁止新郵件短信通知 POP3﹐ O 表示允許﹐1 表示禁止﹔
uSendSms - 禁止發送短信﹐O 表示允許﹐1 表示禁止。
返回﹕
0 - 修改用戶郵箱權限成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 郵箱用戶不存在或讀取用戶資訊失敗﹔
3 - 修改用戶郵箱權限失敗。

short ModifyUserSendRecv(BSTR strUser, BSTR pstrDomain, short uSendControl, short uRecvControl, BSTR pstrSendDomainList, BSTR pstrRecvDomainList)
敘述﹕修改用戶郵箱的收發限制
參數﹕
strUser - 用戶的郵箱名﹔
strDomain - 郵箱的網域名稱﹔為空串("")時﹐即為主域﹔
uSendControl - 發送限制﹐ 1 - 禁止發送郵件到本域下其他用戶﹐ 2 - 禁止發送郵件到系統內的其他域﹐ 4 - 禁止發送郵件到系統外的域﹔
uRecvControl - 接收限制﹐ 1 - 禁止接收本域下其他用戶發來的郵件﹐ 2 - 禁止接收本系統內其他域發來的郵件﹐ 4 - 禁止接收系統外的域發來的郵件﹔
pstrSendDomainList - 發送例外的網域名稱清單﹐與上述發送限制執行相反的操作﹐填寫多個網域名稱時﹐各網域名稱間用分號(;)隔開﹔
pstrRecvDomainList - 接收例外的網域名稱清單﹐與上述接收限制執行相反的操作﹐填寫多個網域名稱時﹐各網域名稱間用分號(;)隔開。
返回﹕
0 - 修改用戶郵箱的收發限製成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 郵箱用戶不存在或讀取用戶資訊失敗﹔
3 - 修改用戶郵箱的收發限制失敗。

short ModifyUserFlow(BSTR strUser, BSTR strUser, BSTR pstrDomain, long lSendMaxMsgSize, short uSendFreq, short uLocalTimes, long lLocalSize, short uRemoteTimes, long lRemoteSize)
敘述﹕修改用戶郵箱的流量控制
參數﹕
strUser - 用戶的郵箱名﹔
strDomain - 郵箱的網域名稱﹔為空串("")時﹐即為主域﹔
lSendMaxMsgSize - 允許的發送接收的單郵件最大位元組數﹐ O 表示使用“SMTP 設定”中的參數值﹐單位﹕位元組(B)﹔
uSendFreq - 每小時發送的收件人數﹐ O 表示不限制﹔
uLocalTimes - 發內部郵件時﹐每天發送的收件人數限制﹐ O 表示不限制﹔
lLocalSize - 發內部郵件時﹐發送的郵件總位元組數限制﹐ O 表示不限制﹐單位是 KB﹔
uRemoteTimes - 發外部郵件時﹐每天發送的收件人數限制﹐ O 表示不限制﹔
lRemoteSize - 發外部郵件時﹐發送的郵件總位元組數限制﹐ O 表示不限制﹐單位是 KB。
返回﹕
0 - 修改用戶郵箱的流量控製成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 郵箱用戶不存在或讀取用戶資訊失敗﹔
3 - 修改用戶郵箱的流量控制失敗。

short ModifyUserPwdPolicy(BSTR strUser, BSTR pstrDomain, short uChgPwd, short uExpiryDays, short uPwdLength, short uPwdStrength)
敘述﹕修改用戶郵箱的密碼策略
參數﹕
strUser - 用戶的郵箱名﹔
strDomain - 郵箱的網域名稱﹔為空串("")時﹐即為主域﹔
uChgPwd - 設定密碼安全性﹐ 1 - 用戶不能修改密碼﹐ 2 - 用戶每隔 N 天必須修改密碼﹐4 - 用戶下次時登入必須修改密碼﹔
uExpiryDays - 用戶修改密碼間隔的天數﹐ 預設 30 天﹔
uPwdLength - 密碼最少長度﹐ O 表示不限制﹔
uPwdStrength - 密碼的安全等級﹐ 0 - 低﹐ 1 - 中﹐ 2 - 高。
返回﹕
0 - 修改用戶郵箱的密碼成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 郵箱用戶不存在或讀取用戶資訊失敗﹔
3 - 修改用戶郵箱的密碼失敗。

short ModifyUserAccess(BSTR pstrUser, BSTR pstrDomain, short uSevice, short uControl, BSTR pstrIPList)
敘述﹕修改用戶郵箱存取控制
參數﹕
strUser - 用戶的郵箱名﹔
strDomain - 郵箱的網域名稱﹔為空串("")時﹐即為主域﹔
uSevice - 設定存取控制的服務﹐ 0 - SMTP/Secure SMTP, 1 - POP3/Secure POP3, 2 - IMAP/Secure IMAP, 3 - Webmail/Secure Webmail, 4 - FTP/Secure FTP﹔
uControl - 設定存取控制動作﹐ 0 - 不限制﹐ 1 - 允許﹐ 2 - 拒絕﹔
pstrIPList - 允許存取和拒絕存取的 IP 位址﹐填寫多個 IP 位址時﹐各域 IP 間用分號(;)隔開。
返回﹕
0 - 修改用戶郵箱的存取控製成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 郵箱用戶不存在或讀取用戶資訊失敗﹔
3 - 修改用戶郵箱的存取控制失敗。

short DeleteUser(BSTR strUser, BSTR strDomain);
敘述﹕解除一個郵箱用戶
參數﹕
strUser - 用戶的郵箱名﹔
strDomain - 郵箱的網域名稱﹔為空串("")時﹐即為主域。
返回﹕
0 - 解除郵箱用戶成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 郵箱用戶不存在或讀取用戶資訊失敗﹔
3 - 解除郵箱用戶失敗。

short ChangePassword(BSTR strUser, BSTR strDomain, BSTR strOldPwd, BSTR strNewPwd)
敘述﹕修改用戶密碼
參數﹕
strUser - 用戶的郵箱名﹔
strDomain - 郵箱的網域名稱﹔為空串("")時﹐即為主域﹔
strOldPwd - 郵箱的舊密碼﹐舊密碼為空串("")時﹐即不驗證舊密碼﹔
strNewPwd - 郵箱的新密碼。
返回﹕
0 - 修改用戶密碼成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 郵箱用戶不存在或讀取用戶資訊失敗﹔
3 - 郵箱用戶不是內部資料庫認證﹔
4 - 舊密碼不正確﹔
5 - 修改密碼失敗。

short CheckUser(BSTR strUser, BSTR strDomain)
敘述﹕檢查一個郵箱用戶是否存在
參數﹕
strUser - 用戶的郵箱名﹔
strDomain - 郵箱的網域名稱﹔為空串("")時﹐即為主域。
返回﹕
0 - 不存在﹔
1 - 參數不正確或參數格式無效﹔
2 - 已經存在同名的郵箱﹔
3 - 已經存在同名的用戶別名﹔
4 - 已經存在同名的群組名﹔

short Authenticate(BSTR strUser, BSTR strDomain, BSTR strPass)
敘述﹕檢查用戶密碼
參數﹕
strUser - 用戶的郵箱名﹔
strDomain - 郵箱的網域名稱﹔為空串("")時﹐即為主域﹔
strPass - 郵箱的密碼。
返回﹕
0 - 用戶密碼檢查成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 郵箱用戶不存在或讀取用戶資訊失敗﹔
3 - NT 網域名稱認證失敗﹔
4 - 用戶密碼檢查不成功。

short AddUserAlias(BSTR strAliasUser, BSTR strDomain, BSTR strRealMailbox)
敘述﹕增加一個用戶別名
參數﹕
strAliasUser - 用戶的別名﹔
strDomain - 郵箱的網域名稱﹔為空串("")時﹐即為主域﹔
strRealMailbox - 郵箱名別名對應的實際郵箱。
返回﹕
0 - 增加用戶別名成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 增加用戶別名失敗。

short DeleteUserAlias(BSTR strAliasUser, BSTR strDomain)
敘述﹕解除一個用戶別名
參數﹕
strAliasUser - 用戶的別名﹔
strDomain - 郵箱的網域名稱﹔為空串("")時﹐即為主域。
返回﹕
0 - 解除用戶別名成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 解除用戶別名失敗。

short AddGroup(BSTR strName, BSTR strDomain, BSTR strDescription, BSTR strMemberList, short uRight, BSTR strSenderList)
敘述﹕增加一個通信群組
參數﹕
strName - 通信群組名﹔
strDomain - 通信群組的網域名稱﹔為空串("")時﹐即為主域﹔
strDescription - 群組描述。
strMemberList - 群組成員清單﹐各個成員郵箱位址用分號(;)隔開。
uRight - 發信權限。
0 - 表示“任何人都可以給群組員發信”﹔
1 - 表示“只有群組員可以發信”﹔
2 - 表示“指定成員可以發信”。
strSenderList - 允許發信的成員清單﹐各個成員郵箱位址用分號(;)隔開。
返回﹕
0 - 增加新通信群組成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 已經存在同名的郵箱﹔
3 - 已經存在同名的用戶別名﹔
4 - 已經存在同名的群組名﹔
5 - 所要增加的域不存在。

short ModifyGroup(BSTR strName, BSTR strDomain, BSTR strDescription, BSTR strMemberList, short uRight, BSTR strSenderList)
敘述﹕修改一個通信群組
參數﹕
strName - 通信群組名﹔
strDomain - 通信群組的網域名稱﹔為空串("")時﹐即為主域﹔
strDescription - 群組描述﹔
strMemberList - 群組成員清單﹐各個成員郵箱位址用分號(;)隔開﹔
uRight - 發信權限﹐ 0 - 表示“任何人都可以給群組員發信”﹐1 - 表示“只有群組員可以發信”﹐2 - 表示“指定成員可以發信”﹐ 3 - 表示“本域下用戶可以發信”。
strSenderList - 允許發信的成員清單﹐各個成員郵箱位址用分號(;)隔開。
返回﹕
0 - 修改通信群組成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 郵件群組不存在或讀取郵件群組資訊失敗﹔
3 - 修改通信群組失敗﹔

short ModifyGroup1(BSTR pstrName, BSTR pstrDomain, BSTR pstrSubGroup, BSTR pstrManager, short uVisual, short uSender)
敘述﹕修改一個通信群組
參數﹕
strName - 通信群組名﹔
strDomain - 通信群組的網域名稱﹔為空串("")時﹐即為主域﹔
pstrSubGroup - 子分群組﹐各個群組位址用分號(;)隔開﹔
pstrManager - 群組管理員員清單﹐各個管理員位址用分號(;)隔開﹔
uVisual - 群組的可見權限﹐
0 - 表示“任何人可以看到此通訊群組及其成員”﹐1 - 表示“任何人可以看到此通訊群組”﹐
2 - 表示“本域用戶可以看到此通訊群組及其成員”﹐ 3 - 表示“域用戶可以看到此通訊群組”﹐
4 - 表示“群組成員可以看到此通訊群組及其成員”﹐ 5 - 表示“群組成員可以看到此通訊群組”﹐
6 - 表示“只有管理員可以看到此通訊群組及成員”﹔
uSender - 發信成員的可見度﹐0 - 沒有特別可見權限﹐1 - 發信成員有相同的可見度。
返回﹕
0 - 修改通信群組成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 郵件群組不存在或讀取郵件群組資訊失敗﹔
3 - 修改通信群組失敗﹔

short DeleteGroup(BSTR strName, BSTR strDomain)
敘述﹕解除一個通信群組
參數﹕
strName - 通信群組名﹔
strDomain - 通信群組的網域名稱﹔為空串("")時﹐即為主域﹔
返回﹕
0 - 解除通信群組成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 解除通信群組失敗。

short AddAdminUser(BSTR strUser, BSTR strPass, short uUserType, BSTR strAdminRange)
敘述﹕增加一個系統管理員
參數﹕
strUser - 系統管理員用戶名﹔
strPass - 管理員的密碼﹔
uUserType - 管理員型式﹐0 - 超級管理員﹐1 - 域管理員﹔
strAdminRange - 允許管理的域﹐多個網域名稱之間用逗號分隔（;）﹐域管理員的允許管理的域不能為空。
返回﹕
0 - 增加管理員成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 增加管理員不成功。

short DeleteAdminUser(BSTR strUser)
敘述﹕解除一個系統管理員
參數﹕
strUser - 系統管理員用戶名﹔
返回﹕
0 - 解除系統管理員成功﹔
1 - 參數不正確或參數格式無效﹔
2 - 解除系統管理員失敗。

BSTR GetFolderMsgCount(BSTR strUser, BSTR strDomain, BSTR strPasswd, BSTR strFolder, short uOnlyNew)
敘述﹕取得用戶郵箱中指定郵件夾的新郵件數或郵件數
參數﹕
strUser - 用戶的郵箱名﹔
strDomain - 郵箱的網域名稱﹔為空串("")時﹐即為主域﹔
strPasswd - 郵箱的密碼﹔
strFolder - 要取得郵件數的郵件夾﹐多個郵件夾用 | 隔開﹐如﹕取得收件匣與發件箱的郵件數﹐參數為 "inbox|sent"。
系統郵件夾的標簽﹐inbox - 收件匣﹐sent - 已發送發件﹐draft - 草稿箱﹐trash - 已解除郵件﹐spam - 垃圾郵件﹐
如為空串("")時﹐則取回所有系統郵件夾（inbox|sent|draft|trash|spam）的新郵件數和郵件數﹔
uOnlyNew - 僅取新郵件數﹔0 -- 新郵件數和郵件數﹐ 1 -- 新郵件數。
返回﹕
如果取得新郵件數和郵件數（uOnlyNew = 0）﹐返回值為﹕新郵件數/郵件總數﹐ 如 2/3
如果僅取得新郵件數（uOnlyNew = 1）﹐返回值為﹕新郵件數﹐ 如 2
如果取得郵件數的郵件夾為多個郵件夾﹐則取得新郵件數和郵件數（uOnlyNew = 0）時﹐返回值為﹕新郵件數1/郵件總數1|新郵件數2/郵件總數2﹐ 如 2/3|5/8﹔僅取得新郵件數（uOnlyNew = 1）時﹐返回值為﹕新郵件數1|新郵件數2﹐如 2|5

操作實例


Webmail 與其他 Web 伺服器整合

Webmail 可以由多款 Web 伺服器來解釋運行，如 IIS，Apache，Nginx、Lighttpd。本節主要講述與IIS 和Apache 整合，其他伺服器可以參考相關方檔，自行研究。

設置 Webmail 到 IIS
設置 Webmail 到 Apache


應用實例

Please go to http://www.winmail.cn/technic_case.php


 版本歷史

Version 7.2(Build 0310)(2023/03/10)

1. [企業版]增加其他郵件存儲目錄設定﹐優先存放在空閒空間佔比最大磁碟.
2. [企業版]增加郵箱代理功能﹐郵箱用戶可在 Webmail 組態箱發件人管理裏設定.
3. Webmail 設定增加二次認證（2FA雙因素認證）設定﹐支援 TOTP 動態密碼驗證.
4. 進階設定中增加 ADMIN 組態﹐管理端可組態 TOTP 動態密碼驗證､密碼防猜解.
5. 猜密碼偵測增加主機名白名單﹐可結合動態網域名稱設定存取白名單.
6. 猜密碼偵測去掉認證次數超限､外發超限屏蔽 IP﹐防止影響同網路其他用戶收發.
7. 郵件過濾下內嵌圖過濾支援識別二維碼的內容.
8. Webmail 大量發信﹐將顯示圖形驗證碼﹐防止群發.
9. [企業版]管理端增加垃圾郵件過濾統計.
10. 系統狀態下郵件佇列和活動連接 15秒自動刷新.
11. 取回密碼可增加企業微信､釘釘掃碼.
12. 管理端用戶屬性裏增加密碼修改記錄.
13. 用戶管理可清除企業微信､釘釘ID､TOTP密鑰.
14. 用戶群組可以設定發信代表﹐可以在 Webmail 直接以群組名義發信.
15. 修正定時郵件沒有發信記錄問題.
16. 修正 MSMS 服務沒有啟動﹐短信佇列不重試﹐永遠堆積問題.
17. 修正 LDAP導入時﹐用戶姓名不對問題.
18. 升級 Apache 到2.4.58.
19. 升級 PHP 到 8.2.16.
20. 升級 OpenSSL 到 3.0.13.
21. 升級 ClamAV 到 1.3.0.
22. 修正數個 Webmail 安全漏洞.

Version 7.1(Build 0518)(2023/05/18)

1. [企業版/白金版]網域名稱屬性下增加用戶和群組同步﹐支援 ADSI､LDAP.
2. [企業版/白金版]網域名稱屬性下增加用戶和群組同步﹐支援企業微信﹐後臺綁定新郵件通知.
3. [企業版/白金版]網域名稱屬性下增加用戶和群組同步﹐支援釘釘﹐後臺綁定新郵件通知.
4. 增強密碼策略設定功能﹐可設定多項細分策略規則﹐可設定弱密碼字典.
5. Webmail 可組態雙因素認證﹐支援短信驗證碼.
6. Webmail 雙因素認證可組態支援企業微信掃碼或發驗證碼.
7. Webmail 雙因素認證可組態支援釘釘掃碼或發驗證碼.
8. 用戶屬性密碼策略中可設定是否開啟雙因素認證.
9. HTTP 設定中增加允許主機頭﹐滿足網域名稱備案要求.
10. 外部資料庫增加支援 ODBC 連接達夢資料庫.
11. 猜密碼偵測中增加僅允許指定歸屬地的 IP 認證﹐可實現僅特定地區使用郵件功能.
12. 允許修改普通域的網域名稱﹐主域､普通域都可以改名.
13. 調整用戶郵件存儲目錄結構﹐按網域名稱分目錄存放﹐已有用戶郵件會自動遷移。
14. 允許修改群組名和用戶別名.
15. 增加自定義 IP 歸屬地記錄功能﹐自行增加內置 IP 歸屬地記錄.
16. [企業版/白金版]支援導出用戶存取記錄､發送記錄､接收記錄.
17. 網域名稱屬性 Webmail 定制功能中增加 ICP 備案號設定.
18. 郵件遷移支援多線程下載郵件.
19. 修正一些安全和功能問題.
20. 升級 Apache 到 2.4.55.
21. 升級 OpenSSL 到 1.1.1t.
22. 升級 PHP 到 7.4.33.
23. 升級 Clamav 到 1.0.1.
24. 升級 Spamassassin 到 3.4.4.

Version 7.0(Build 0630)(2022/06/30)

1. [企業版/白金版] 增加內置 MySQL 資料庫支援﹐提高系統性能.
2. [企業版/白金版] 增加支援外部 MySQL､MariaDB､PostgresSQL 資料庫.
3. [企業版/白金版] 增加 LDAP 通訊協定自動同步用戶功能.
4. [企業版]支援分散式､內嵌查毒引擎､通訊群組排序等原白金版特有功能.
5. 增加批量更新用戶密碼功能.
6. 域和用戶屬性裏﹐增加密碼不符合策略強制修改選項.
7. 增強郵件過濾規則設定﹐設定群組合規則更方便.
8. 增加用戶端登入授權碼功能﹐讓用戶密碼更安全.
9. 增強資訊安全﹐可設定郵件頭不記錄用戶端IP.
10. Webmail 增加時區設定﹐跨國使用更方便.
11. Webmail 個人資訊中顯示 APP 設備清單.
12. Webmail忘記密碼可通過短信驗證碼重設密碼﹐增加驗證手機號碼.
13. Webmail 郵件清單顯示發件人聯繫資訊.
14. 增強整合企業微信功能﹐可使用企業微信 APP 掃描登入 Webmail.
15. 增強整合釘釘功能﹐可使用釘釘 APP 掃描登入 Webmail.
16. 修正 IMAP 已發郵件﹐Webmail 解除失敗問題.
17. 修正某些隔離郵件發件人顯示不正確問題.
18. 修正無法在線更新垃圾郵件庫問題.
19. 升級 Apache 到 2.4.53.
20. 升級 OpenSSL 到 1.1.1n.
21. 升級 PHP 到 7.4.29.
22. 支援 Windows Server 2022﹐Windows 11.

Version 6.7(Build 0112)(2021/01/12)

1. 內置 Apache 支援 http2 通訊協定.
2. 增強檢查偽造郵件功能.
3. 猜密碼偵測模組屏蔽清單增加屏蔽原因欄位.
4. 猜密碼偵測模組可設定將屏蔽 IP 加入系統防火牆.
5. 猜密碼偵測模組可設定 IP 位置白名單.
6. 增加 SMTP 過濾次數達到限制自動屏蔽功能.
7. 取回密碼安全性加強﹐增加安全問題答案長度檢查.
8. 分散式認證增強防止猜密碼.
9. Webmail 刷新郵件清單時﹐更新對應檔案夾的郵件數.
10. 修正外發超過限制時﹐程式異常重啟問題.
11. 修正打開亂碼日誌時長時間等待問題.
12. 修正 Outlook 部分郵件誤判成撤回郵件問題.
13. 升級 Apache 到 2.4.46.
14. 升級 OpenSSL 到 1.1.1i.
15. 升級 PHP 到 7.2.34.

Version 6.6(Build 0812)(2020/08/12)

1. 增加角色管理員﹐可授權使用指定功能.
2. 改善SSL/TLS 相容性和安全性.
3. [白金版]郵件密級改為限制､秘密､機密﹐更符合國標.
4. 網域名稱管理清單增加域下用戶已用空間統計.
5. 修正特定計劃任務導致用戶資訊丟失問題.
6. 修正公共位址簿導入錯誤問題.
7. 修正Web註冊新郵箱密碼規則檢查異常問題.

Version 6.6(Build 0706)(2020/07/06)

1. [白金版]支援 IPv6﹐可設定優先使用 IPv6.
2. [白金版]增強分散式部署功能﹐可實現負載均衡架構.
3. SMTP､POP3､IMAP 等各服務可以綁定多個本機IP和多個連接埠.
4. 優化 SMTP､POP3､IMAP 等服務程式代碼﹐提高系統性能.
5. 增加系統級新郵件訊息推送﹐可指定 URL﹐推送數據格式支援 JSON､XML､Form.
6. 增強在線遷移功能﹐讓遷移更平滑無感.
7. 通訊群組發信成員可指定某個外域､某個通訊群組及子群組.
8. 郵件監控､郵件簽核､外發中繼､計劃任務､歸檔等支援選擇群組作為動作物件.
9. 可禁止 25 連接埠發信認證﹐防密碼猜解更安全.
10. OpenSSL 升級到 1.1.1d, 支援更安全的 TLSv1.3 版本通訊協定(Windows 2008 以上系統).
11. 證書管理中可以設定禁止特定的 SSL/TLS 版本﹐讓系統更安全.
12. 改進密碼策略設定﹐強度規則更清晰明白.
13. 導出用戶賬號數據增加狀態､建立時間､最近存取時間欄位.
14. 用戶屬性裏可顯示最近修改密碼時間.
15. 增加郵箱密碼加密格式﹐支援更安全的 SHA256 和國密SM3算法.
16. 增加垃圾郵件內嵌圖片裏文字識別過濾識別功能.
17. 增加垃圾郵件規則庫在線更新功能.
18. 增加日誌記錄等級.
19. 增強日歷功能.
20. 增加 Webmail 登入､取回密碼和修改密碼要求短信驗證功能.
21. Webmail 忘記密碼功能可直接設定新的密碼.
22. 增加發送內部郵件的閱讀情況統計功能.
23. Webmail 行事歷增加搜索功能.
24. 增強 Webmail 寫郵件編輯器﹐支援表格編輯､郵件模板.
25. Webmail 登入後﹐如果密碼強度不符合網域名稱預設密碼策略會出現提醒資訊.
26. 修正繁體系統中 IP 來源地文字顯示亂碼問題.
27. 修正 Windows 2012 以上查看日誌初始不卷動到最新記錄行問題.
28. 修正 Windows 10 以上系統資訊中作業系統版本顯示不正確問題.
29. 修正隔離區取回﹐郵件監控規則不生效問題.
30. 修正間隔時間設定 24 小時時﹐隔離區不發通知郵件問題.
31. 升級 Apache 到 2.4.43.
32. 升級 PHP 到 7.2.31.
33. 升級 ClamAV 到 0.102.3.
34. 升級 SpamAssassin 到 3.4.2.

Version 6.5(Build 0305)(2019/03/05)

1. 全新設計 Webmail Simple 介面風格.
2. 郵件存儲可設定單副本儲存﹐提高磁碟利用率和內部投遞效率.
3. Webmail 支援使用 Winmail APP 掃碼登入.
4. 可以設定 Webmail 發送大附件時自動使用網路磁碟中轉.
5. 改進歸檔存儲﹐防止目錄下檔案過多﹐改進 Web 歸檔管理.
6. 移動介面增加郵件搜索功能﹐改進位址簿搜索.
7. 修正網路磁碟 Web 上傳檔案時容量無法限制問題.
8. 修正郵件通訊閘下載 263 企業郵局特殊郵件發生格式錯誤問題.
9. 增強用戶郵件過濾規則﹐動作可設定為標記為已讀.
10. 可以設定隔離區通知郵件發送間隔時間﹐並修正隔離郵件超期不解除問題.
11. 管理工具多個列示方塊可以使用 Ctrl, Shift 多選.
12. 系統日誌中 Admin 日誌將不能解除與清空.
13. 猜密碼偵測可設定 IP 和用戶白名單﹐屏蔽 IP 位址可導出.
14. 認證發信預設限制發件人必須是本系統域﹐拒絕非法中繼.
15. 給群組位址發信時﹐可設定收件人顯示群組成員的位址﹐也可以設定以群組位址發信.
16. 增強自動回復﹐可設定同一發件人每天只回復一次.
17. 升級 Apache 到 2.4.37.
18. 升級 PHP 到 7.1.23.
19. 升級 OpenSSL 到 1.0.2p.
20. 升級 ClamAV 到 0.100.1.

Version 6.3(Build 0408)(2018/04/08)

1. [白金版]提供64位裝設包﹐提高系統執行效率.
2. 提供全新的適配移動設備的 Webmail.
3. 系統後臺經過組態後﹐Webmail 可以在線預視 Office 附件.
4. 改進記憶體分配﹐防止記憶體分配異常重啟.
5. 改進資料庫讀取﹐改善郵件讀取速度.
6. 增加異地登入提醒功能.
7. 中文日誌和用戶存取記錄增加 IP 地理位置資訊.
8. 增強 SSL/TLS 證書管理﹐可以針對不同的存取主機名組態各自證書.
9. 修正發信到系統通訊群組可能會重複發信問題.
10. 修正 Webmail 閱讀郵件時﹐特殊郵件內容不顯示問題.
11. 歸檔功能可以支援單副本存儲﹐也可以按照用戶分目錄儲存.
12. 防病毒和附件過濾支援 7z 附件解壓.
13. 修正病毒掃描時部分 .zip 附件誤報感染病毒.
14. 管理工具的用戶清單記憶調整後的列寬度和次序
15. 增強反垃圾模組﹐增加查詢網域名稱過濾清單 DBL 功能.
16. 修復多項 Webmail 安全漏洞.
17. 修正部分格式郵件 DKIM 編碼錯誤.
18. 升級 Apache､PHP 版本.

Version 6.2(Build 0620)(2017/06/20)

1. 微信綁定增加支援企業微信.
2. 用戶屬性欄位增加了部門﹐公司和部門欄位分開.
3. 導入用戶時﹐增加郵箱容量､網路磁碟容量欄位.
4. Webmail 公用位址簿顯示更多常用欄位.
5. 修正 Pushmail 不能建立子目錄問題.
6. 修正 Outlook Pushmail 子目錄裏郵件不能閱讀問題.
7. 修正 Webmail 中下載中文名附件有時出現檔案名稱亂碼問題.
8. 修正 Webmail 寫郵件無法正確選擇多個位址問題.
9. 修正 Webmail 網路磁碟上傳､下載中文檔案丟失檔案名稱問題.
10. 修正 Webmail 幾項安全漏洞.

Version 6.2(Build 0330)(2017/03/30)

1. [白金版]新增歸檔郵件查詢模組﹐用戶和管理員可在 Web 上查詢和恢復系統歸檔郵件.
2. IMAP 自動訂閱系統郵件夾﹐Outlook 2013 以上自動識別已發送､已解除等系統郵件夾.
3. 公用位址簿 OpenLDAP 後臺資料庫引擎升級﹐增加自動修復和清空功能.
4. 系統通訊群組增加導入和導出功能.
5. 管理端公用位址簿增加搜索功能.
6. 改進用戶管理易用性﹐可方便的按部門管理用戶.
7. 用戶屬性中增加系統歸檔查詢和 Pushmail 存取權限設定.
8. AD 帳號同步時﹐AD 用戶資訊修改的會同步修改郵箱用戶資訊﹐AD 用戶禁用的郵箱用戶自動禁用.
9. 改進退信內容﹐增加中文解釋和處理建議.
10. 改進郵件簽核的通知郵件.
11. 管理員可以在管理工具裏查看隔離區郵件的摘要資訊﹐進行重發被隔離郵件､加白名單等操作.
12. 用戶隔離通知郵件中增加取回和加白名單鏈接﹐用戶可以直接點擊鏈接取回被隔離郵件.
13. SMTP 過濾中增加 SpamAssassin 過濾選項﹐可疑郵件可以設定放入隔離區.
14. 郵件過濾動作增加放入隔離區選項.
15. 預設 admin 管理員可以解除.
16. SMTP 可以禁止明文認證.
17. 系統安全性提昇﹐加密儲存用戶密碼等多項敏感數據﹐升級後無法回到老版本.
18. 增強了 Webmail 安全性檢查﹐修復多項安全漏洞.
19. 修正"已發送"中郵件遞送狀態不正確問題.
20. 修正 Webmail 某些情況下 Word 表格格式被過濾掉問題.
21. 修正 OpenAPI 接口修改用戶時沒有傳入的欄位數據丟失的問題.
22. 升級 Apache､PHP 版本.
23. 編譯器更新﹐新版本不再支援 Windows 2000﹐XP系統必須裝設 sp3.

Version 6.1(Build 0720)(2016/07/20)

1. 新增郵件密級功能﹐支援用戶密級與郵件密級控制[白金版支援].
2. LDAP 服務升級到 2.4.44﹐支援 Outlook 直接存取伺服器上的公用位址簿.
3. 支援阿裏釘釘綁定﹐可以實現新郵件釘釘通知和在釘釘中登入收發郵件.
4. 微信綁定增加支援微信企業號.
5. 短信通訊閘功能增加支援阿裏大於和網易易信服務﹐支援 RTX 提醒.
6. 支援同時啟用短信､微信､釘釘新郵件提醒和綁定.
7. 增強網路磁碟､行事歷共享安全性.
8. 系統郵件模板支援 HTML 格式.
9. 改善 IMAP､POP3 認證速度.
10. 可以設定是否發送系統郵箱使用情況報表.
11. 郵件簽核增加簽核成功是否通知收件人選項.
12. Webmail 支援在 PHP7 環境執行.
13. 修正 IMAP 收件匣下子檔案夾訂閱狀態丟失問題.
14. 修正 iOS 郵件用戶端 IMAP 命令異常問題.
15. 修正分散式系統數據同步問題.
16. OpenSSL 升級到 1.0.2h 版本, 支援 TLS 1.1､TLS 1.2.
17. 升級 Apache､PHP 版本.

Version 6.0(Build 0330)(2016/03/30)

1. 支援與已認證微信服務號綁定﹐可以實現新郵件微信通知和在微信中登入收發郵件.
2. 支援 Outlook 2013 Pushmail 連接方式﹐支援郵件､日歷､聯繫人､任務同步[白金版支援].
3. 行事歷功能標準化﹐相容 outlook﹐支援共享.
4. 可以設定唯讀郵箱﹐該郵箱用戶無論使用何種用戶端都不能解除郵件.
5. 反垃圾郵件支援隔離區功能﹐郵箱用戶可以自行取回被隔離的疑是垃圾郵件.
6. 反垃圾郵件支援 DKIM 過濾和簽名﹐設定 DKIM 也可以提高外發郵件的到達率.
7. 被反垃圾郵件模組臨時屏蔽的IP﹐管理員可以清除釋放.
8. 歸檔功能增強﹐可設定歸檔郵件保留時間.
9. 備份功能增強﹐可設定備份數據保留時間.
10. 多IP伺服器﹐可以設定外發郵件連出ip.
11. 郵箱密碼輸錯多次被系統暫停後﹐管理員可以解鎖被暫停的賬號.
12. 網域名稱管理裏可以定制 Webmail 裏的 Logo 圖片和公司標簽.
13. 待簽核郵件簽核成功後﹐會給發通知郵件給發件人.
14. 來自郵件監控､郵件歸檔的郵件主題插入"監控郵件""歸檔郵件"標記﹐可取消.
15. 可以禁止一個郵箱的 SMTP 功能.
16. 所有用戶端發出的郵件﹐如果在伺服器上"已發送"郵件夾中保留的﹐可以在 Webmail 上撤回.
17. Webmail 裏可以查看本郵箱的存取記錄､發信記錄､刪信記錄､隔離郵件.
18. Webmail 增加定時發信功能.
19. Webmail 增加交談方式顯示郵件功能.
20. Webmail 可發送加密碼郵件﹐相容 Foxmail 和騰訊郵箱系統相關功能.
21. Webmail 寫郵件功能在新版瀏覽器中支援插入剪下來板裏的圖片﹐支援qq截圖.
22. Webmail 寫郵件功能在新版瀏覽器中支援拖放方式上傳附件.
23. 可以設定 POP3 收取後是否保留伺服器上的郵件﹐不管用戶端軟體是否設定保留備份.
24. 增加多種郵箱使用情況報表﹐讓管理員及時了解系統執行狀況.
25. 提供 OpenAPI 二次開發接口﹐HTTP 通訊協定請求使用 GET/POST 方式﹐返回數據採用 JSON 格式.

Version 5.5.2(Build 0504)(2015/05/04)

1. 修正 IMAP 部份郵件下載不全.
2. 中繼伺服器增加指定域和用戶限制.
3. 附件名過濾增加指定域和用戶限制.
4. 修正垃圾郵件遞送指定郵箱錯誤.
5. 修正佔用記憶體大問題.
6. 修正 IE9,IE10 下HTML 編輯器回車間隔大問題.
7. 修正 Webmail 佔用資源多的問題.
8. 發郵件時 XSS 過濾﹐導致 style 標籤過濾問題.
9. 郵件自動索引時﹐解除無用的緩存記錄.
10. PHP 升級到 5.4.35.
11. Sqlite 升級到 3.8.7.2.
12. 修正伺服器端程式異常終止問題.

Version 5.5(Build 1009)(2014/10/09)

1. 增加分散式部署功能﹐支援單網域名稱多主機﹐滿足多分支機構系統架設需求[白金版支援].
2. 增加支援第三方 LDAP 認證 ､Radius 認證 [白金版支援].
3. 增加自動遷移第三方郵件系統數據的郵箱搬家功能﹐自動遷移原系統賬戶､密碼和郵件.
4. 增加用戶郵件自動歸檔﹐自動清理功能[標準版､白金版支援].
5. 優化 Webmail 郵件清單功能﹐提高大郵件量顯示速度.
6. Webmail 增加標籤管理､置頂､備註､星標､顯示內容摘要等功能.
7. Webmail 郵件清單按時間分類﹐按照今天､昨天､本週､本月顯示郵件.
8. 在 Webmail 已發送郵件夾可以查看發出郵件的遞送情況.
9. 多項系統和用戶數據儲存到 SQLite 資料庫﹐提高系統效率.
10. 系統通訊群組增加標簽欄位﹐方便設定中文名.
11. 用戶 POP3 下載﹐增加發送郵件設定.
12. 修正使用 Pushmail 通訊協定時﹐無法顯示Outlook 日歷提醒郵件內容問題.
13. 修正使用 IE11 下載檔案名稱亂碼､HTML 編輯器部份功能不正常使用問題.
14. Apache 升級到 Apache 2.4.10.
15. PHP 升級到 5.4.31.
16. SpamAssassin 升級到 3.4.0.
17. ClamAV 升級到 0.98.4.
18. OpenSSL 升級到 0.9.8zb.

Version 5.1.2(Build 0522)(2014/05/22)

1. 修正 IE11 存取 Webmail 部分功能無法使用問題.
2. 系統通信群組發信權限設定調整.
3. Apache 升級到 Apache 2.4.6﹐修正 webmail 無響應問題.
4. 修正 webmail 安全漏洞.

Version 5.1(Build 0718)(2013/07/18)

1. 反垃圾模組新增灰名單(Greylisting)和連接延遲響應功能.
2. 部分系統數據改用資料庫儲存﹐提高系統效率.
3. 增加各系統服務流量統計圖﹐保留30天統計記錄.
4. 增加查看活動連接功能.
5. 郵件即時備份改名為歸檔﹐可設定排除用戶.
6. 查看系統日誌介面增加找到功能(Ctrl+F).
7. 網域名稱密碼策略設定﹐增加無策略選擇﹐可設定不做密碼複雜性檢查.
8. 用戶和域屬性﹐增加最多收件人限制[標準版和白金版支援].
9. 用資料庫保留郵件緩存﹐提高網頁大郵件量顯示速度.
10. 管理端可以設定選擇以 FastCGI 執行 php, 提高網頁速度.
11. iPhone,iPad使用網頁寫郵件時支援上傳照片作為附件.
12. 電腦存取登陸頁時可產生二維碼﹐方便手機掃描登陸.
13. 位址簿裏的聯繫人資訊可產生二維碼﹐方便掃描加入手機通訊錄.
14. 增加用戶收發流量記錄[白金版支援].
15. 增加用戶接收郵件記錄[白金版支援].
16. 增強計劃任務指定物件﹐可以設定排除特定用戶.
17. 修正 Outlook 2013 使用 IMAP 佔用資源過大的問題.
18. Apache 升級到 Apache 2.4.4.
19. PHP 升級到 5.4.16.
20. SpamAssassin 升級到 3.3.2.
21. ClamAV 升級到 0.97.7.
22. OpenSSL 升級到 0.9.8x.

Version 5.0(Build 0620)(2012/06/20)

1. 增加郵箱密碼被猜解和郵箱被盜用轉發垃圾郵件行為偵測功能.
2. 外發郵件時﹐一次連接遞給同域下的多個收件人﹐提高外發效率.
3. 優化 DNS 緩存﹐記錄 TTL 時間﹐提高查詢效率.
4. Webmail 預設介面風格支援多標籤視窗﹐使用更方便.
5. Webmail增加一種 pad 專用介面風格﹐支援 iPad､Android 等觸摸平板電腦.
6. 新的Webmail 風格支援 iPhone､Android 等大尺寸觸屏手機.
7. 郵箱用戶可以設定發件人黑白名單.
8. 個人位址簿中的聯繫人做為白名單用戶﹐不進行過濾.
9. Webmail 支援 IE 10.
10. 基礎版和標準版也支援Wap 存取.
11. 個人位址簿可以增加多種電話號碼.
12. 個人位址簿支援按分群組導入導出.
13. 網路磁碟 FTP 數據連接埠允許設定一段範圍.
14. 增強短信通訊閘功能.
15. 支援 Windows 8.
16. 修正郵箱監控和郵件簽核誤判問題.
17. 修正 COM 群組件新增用戶方法無法增加到全局位址簿的問題.
18. SSL 安全服務可以設定關閉 SSLv2 和 Weak Ciphers.

Version 4.9(Build 0715)(2011/07/15)

1. [白金版] 提供Push Mail模組﹐可以用常用的智能手機同步郵件和聯繫人.
2. 增加郵件撤回功能, 支援 Webmail 和 Office Outlook.
3. 系統日誌可以設定記錄語言﹐支援簡體､繁體､英文.
4. 系統退信可以設定語言模板﹐支援簡體､繁體､英文.
5. 郵件監控功能支援條件設定.
6. 郵件簽核功能支援條件設定.
7. 增加收件簽核功能.
8. 增強密碼安全策略﹐支援密碼強度設定﹐支援定期修改密碼.
9. 用用戶端通過 SMTP 發的郵件可以設定自動儲存到伺服器上的發件箱.
10. 增加一個附加的非25的 SMTP 連接埠﹐可以用於用戶端發信.
11. Webmail增加一種簡潔版 simple 介面風格﹐類似 Hotmail.
12. Webmail增加一種 3G mini 介面風格﹐適合用手機和移動設備登入.
13. Webmail閱讀郵件時﹐增加[郵件往來]鏈接﹐可以列出與這個發件人通訊過的郵件.
14. 可以用郵箱別名或域別名登入Webmail.
15. Webmail 支援 IE 9､Firefox 4､Chrome 10.
16. Webmail 上發網路磁碟下檔案鏈接﹐無需先設定共享﹐下載鏈接有截止日期.
17. 新版 Winmail 不再支援在 Windows NT 系統上裝設.
18. 修正同時給內部和外部位址發郵件時﹐內部監控規則會失效問題.
19. 修正新增加用戶時﹐新用戶丟失域的收發控制參數問題.
20. OpenSSL 升級 0.9.8r .
21. Apache 升級到 2.2.19 .

Version 4.8(Build 0811)(2010/08/11)

1. 系統通信群組可以支援多層級﹐實現樹形企業通訊錄.
2. 系統通信群組外部群組成員增加名字欄位.
3. Webmail 新增介面風格.
4. 改進 Webmail 郵件清單和讀郵件代碼.
5. Webmail 更好的支援IE7和IE8.
6. 增強 HTML Editor 支援 Firefox, Safari, Chrome.
7. 管理端可以設定常用的 Webmail 參數.
8. 改進 Webmail 位址簿﹐增加查詢功能.
9. SpamAssassin 改成服務方式執行﹐提高垃圾郵件評分效率.
10. 修正清空網路磁碟時子目錄不會解除問題.
11. 修正存取時間不更新 bug.
12. 修正外發大郵件時﹐超時重複發信問題.
13. PHP 升級到 php 5.3.2.
14. Apache 升級到 Apache 2.2.15 ﹐以服務方式執行﹐提高 Webmail 效率.
15. OpenSSL 升級到 0.9.8n.
16. [白金版]整合 ClamAV 查毒引擎﹐自動更新病毒庫.
17. [白金版]系統通信群組可以排序.
18. [白金版]系統通信群組成員可以排序.
19. [白金版]增加用戶郵箱存取記錄.
20. [白金版]增加發信流量控制﹐系統､域､單個郵箱可以設定每小時和每日發信量.
21. [白金版]增加用戶郵箱發信記錄.
22. [白金版]自動同步 AD 賬戶

Version 4.7(Build 0217)(2009/02/17)

1. 增強 Webmail 郵件清單﹐搜索功能﹐增加標籤設定.
2. 增加域的郵箱的存儲目錄和網路磁碟存儲目錄設定.
3. 增加域的簽名檔設定.
4. 增加單個用戶郵箱的存儲目錄和網路磁碟存儲目錄設定.
5. 增加多條中繼伺服器.
6. 增加系統廣播郵件﹐可以直接發郵件給系統內所有用戶或指定網域名稱下的用戶.
7. 增加 FTP 數據傳輸(PASV 模式)外網 IP 位址和連接埠設定.
8. 增加自動備份的時間設定.
9. 增強郵件監控功能﹐可以設定內部/外部郵件監控.
10. Webmail 位址簿﹐過濾規則等清單分頁顯示.
11. Webmail 增加發件人位址設定.
12. Webmail 發郵件時可以選擇發通知短信.
13. 增強 MS-TNEF(winmail.dat附件) 格式郵件轉碼.
14. 修正位址簿排序出錯﹐可以按照拼音排序.
15. Webmail 增加圖形識別碼檢查﹐用戶登入出錯時﹐註冊新郵箱時.
16. Webmail 用戶登入出錯次數限制
17. 修正 SSL 出錯不超時錯誤.
18. 修正管理工具登入時“伺服器無響應” 的 Bug .
19. 修正行事歷提醒郵件的 mail from 問題.
20. 升級 Apache 到 1.3.41 版.
21. 升級 PHP 到 4.4.9 版.
22. 升級 OpenSSL 到 0.9.8i 版.

Version 4.6(Build 0618)(2008/06/18)

1. Webmail 採用 AJAX 技術, 提高頁面速度.
2. 增加磁碟可用空間容量警告功能.
3. 增加 Webmail 寫郵件時郵件字元集選擇.
4. 增強域管理和用戶管理中增加拒絕或允許與某些域收發.
5. 增加存取用戶郵箱時各服務的 IP 限制.
6. 增加 SMTP 設定中 發件人過濾﹐收件人過濾﹐ehlo主機過濾等設定的導入和導出.
7. SMTP/POP3/IMAP 等各服務過濾 IP 的導入和導出.
8. 系統過濾規則和 POP3 下載記錄的導入和導出.
9. 計劃任務的“清除用戶郵件”的動作物件可以指定特定的用戶.
10. 增強反垃圾郵件功能﹐增加連接發件人的郵件伺服器校驗發件人位址是否存在功能.
11. 系統級過濾處理動作可以設定為終止､放到指定公用郵箱､放到改用戶的垃圾郵箱裏並且主題加[SPAM]標記.
12. 用戶級 SpamAssassin 垃圾郵件過濾動作可以設定為"主題增加前綴[SPAM], 遞送到收件匣".
13. 單個郵箱空間設定允許超過 2G.
14. 增加更多的短信服務商.
15. 域管理員增加 郵件監控﹐郵件簽核 權限.
16. Web 管理增加郵件監控﹐郵件簽核設定.
17. 在Webmail裏查看已發送的郵件時﹐可以選擇重發.
18. Webmail 郵件簽核時可直接點擊“允許”/“拒絕”來進行審核
19. 改進 Webmail 寫郵件時位址簿加載﹐加快顯示速度
20. 修正已經簽核的郵件﹐再次簽核報告用戶不存的錯誤.
21. 新建聯繫人的時可以選擇加入位址群組.
22. 修正 COM 接口解除用戶出錯.
23. 用戶管理和域管理增加 http 接口.
24. 系統 POP3 下載時記錄丟棄郵件的資訊.
25. 修正 Secure FTP 檔案上傳和下載的錯誤.
26. 修正郵件內容有多個字元集時不能正確顯示的問題.

Version 4.5(Build 0912)(2007/09/12)

1. 增強國際化支援﹐字元集轉換成 UTF-8 .
2. 增加日誌檔案存放目錄設定.
3. 各個網域名稱可以設定獨立的系統信發件人.
4. 非主域用戶登入 SMTP/POP3/IMAP/FTP 服務時﹐可以通過存取的主機名和IP區分來用戶.
5. 系統 POP3 下載﹐可以設定保留副本的天數和郵件頭自定義要分析欄位.
6. 用戶管理中增加導入 Windows AD 的用戶功能.
7. 短信通知增加發送短信時間段設定.
8. Webmail 的位址簿/通信群組/過濾規則/簽名檔/外部POP3 郵箱增加批量解除功能.
9. Webmail 行事歷中的任務/事件清單增加排序功能.
10. Webmail 增加預設簽名檔設定.
11. Webmail 增加登入次數及最後一次登入時間顯示.
12. [白金版]增加 WAP 功能.
13. 行事歷中共享事件/任務增加時間控制和存取密碼.
14. 網路磁碟共享檔案增加時間控制和存取密碼.
15. 修正網域名稱 MX 指向 IP 時﹐查詢結果不正確.
16. 修正多條郵件監控時﹐只有第一條監控生效的錯誤.
17. 修正電信 DNS 伺服器不正確時﹐RBL/RWL 檢查結果錯誤.
18. 修正 Webmail 在 PHP5 環境下郵件清單出現警告提示
19. 修正備份郵件時﹐舊的同名備份檔案沒有解除的錯誤.
20. 增加 Winmail 中的白名單加入到 SpamAssassin 組態檔案中.
21. 升級 Apache 到 1.3.37 版.
22. 升級 PHP 到 4.4.6 版.
23. 升級 OpenSSL 到 0.9.8e 版.
24. 升級 SpamAssassin 到 3.17 版.
25. 不再支援在 Windows 9x,ME 上裝設 Winmail 程式.

Version 4.4(Build 1124)(2006/11/24)

1. 增加 SPF(Sender Policy Framework) 檢查.
2. 增加陷阱郵箱功能.
3. 增強 HELO/EHLO 主機名檢查.
4. 增強用戶權限設定.
5. 修正多層郵件監控時﹐管理員收到重複信問題.
6. Webmail 增加了一種新風格﹐該風格可以選擇多種配色.
7. 修正系統 POP3 下載時﹐郵件日期修改問題.
8. 修正佇列臨時檔案解除失敗的問題.
9. SMTP 過濾調整﹐可以通過 http://www.abuse.net/relay.html 測試.
10. 增加Webmail 註冊時用戶名和密碼強度檢查.
11. 修正行事歷不能設定在某一日執行問題.
12. 修正 Webmail 郵件清單排序錯誤.
13. 修正 Webmail 顯示附件圖片太大問題
14. 修正系統 Pop3 下載無限別名郵箱時重複問題.
15. 修正用戶 Pop3 下載錯誤提醒信重複問題.
16. 增強 COM 接口﹐增加通訊群組操作方法.
17. 新郵件短信通知可以顯示發送者姓名.
18. 升級 SpamAssassin 到 3.13 版.

Version 4.3(Build 0302)(2006/03/02)

1. Web 管理中增加“管理員管理”功能.
2. FTP 服務數據連接埠使用固定連接埠6020.
3. 域管理增加了重算所有域的已經分配空間.
4. 郵件通訊閘的 POP3 下載﹐信頭分析可以選擇需要分析的信頭欄位.
5. 修正了不能發送給 aol.com 等多行回應資訊的伺服器時的出錯.
6. 修正了 postmaster 不能收信問題.
7. Web 管理中的網域名稱管理增加網域名稱查詢功能.
8. Webmail 寫郵件時﹐可以分隔收件人.
9. Webmail 寫郵件時﹐可以直接插入內嵌圖片﹐表情.
10. Webmail 預視 HTML 附件時過濾附件中的 JavaScript.
11. Webmail 寫郵件時﹐可以直接從網路磁碟中選擇檔案.
12. Webmail 行事歷增加共享行事歷功能.
13. Webmail 草稿中的郵件發送後可選擇不解除.
14. Webmail 優化﹐加快存取速度.
15. 升級 Apache 到 1.3.34 版.
16. 升級 PHP 到 4.4.1 版.
17. 升級 OpenSSL 到 0.9.8a 版.
18. 升級 SpamAssassin 到 3.10 版.
19. 修正了 IMAP 服務與 JavaMail 的相容錯誤.
20. 修正了 IMAP 服務下載郵件時多“\r\n.\r\n”字串的錯誤.
21. 修正 Webmail 中閱讀了“找到”結果的郵件後出錯.
22. 修正 Web 管理域管理員在普通域下郵箱容量設定不正確的錯誤.

Version 4.2(Build 0824)(2005/08/24)

1. 增強了 SMTP 過濾功能﹐增加發信者白名單伺服器清單 RWL 檢查.
2. 增強了用戶收發限制﹐可以設定用戶能與特定域進行收發.
3. 增強了密碼存儲方式﹐支援 md5, sha1, plain, crypt(DES).
4. 增強了新郵件短信通知功能﹐支援 GSM 短信貓﹐可以設定短信通知內容.
5. 升級資料庫引擎﹐提高資料庫分析速度.
6. 升級 SpamAssassin 到 3.02 版.
7. 中繼遞送﹐支援 SSL 連接的伺服器做中繼伺服器(如 gmail).
8. Webmail 增加數字證書管理﹐可以收發和閱讀 S/MIME 格式的郵件.
9. NT 網域名稱認證用戶可以使用 Webmail 和 foxmail 來收發郵件.
10. Webmail 增加個人聯繫人分群組.
11. 調整了 Webmail 寫郵件時的位址選擇方式（樹形顯示）.
12. Webmail 增加了最近聯繫人清單功能.
13. Webmail 寫信時收件人位址自動提示功能.
14. Webmail 可以閱讀和下載 eml 格式附件中的附件.
15. Webmail 可以標識郵件為已讀/未讀郵件.
16. Webmail 支援 Punycode 格式的網域名稱（中文網域名稱）.
17. Webmail 附件下載時﹐減少多次分析﹐提高速度.
18. Webmail 下載檔案時﹐提示檔案大小﹐修正下載檔案不完整錯誤.
19. Webmail 發信時﹐可以選擇發件人位址.
20. 修正了 SMTP SSL 通訊相容問題.
21. 修正了 Mozilla Thunderbird IMAP 瀏覽圖片慢以及發件箱郵件狀態出錯問題.
22. 移除了 Secure LDAP.
23. IMAP 服務支援 IDLE 擴展命令.
24. 分離防病毒的通知郵件和附件過濾通知郵件.
25. COM 群組件增加了修改用戶和域發信限制的方法.
26. 修改了 POP3 下載後遞送會自動回復到管理員的錯誤.

Version 4.1(Build 0428)(2005/04/28)

1. 增加了 SMTP 服務增加允許 Mail From 為空位址選項（MAIL FROM:<>）.
2. 增加了 SMTP 發送和接收郵件的大小限制分開來.
3. 增強了 POP3 下載﹐支援 SSL 連接.
4. 增強了個人垃圾過濾﹐整合 SpamAssassin.
5. POP3 服務支援 LAST 命令.
6. 增強了郵件監控和簽核功能﹐可以授權給域管理員.
7. 增強了計劃任務﹐可以禁止長期未登入用戶和清空用戶的指定郵箱.
8. 增強了郵箱用戶的權限設定.
9. Webmail 可以導入導出個人位址簿.
10. Webmail 新增加兩種介面風格.
11. Webmail 選單顯示新郵件數.
12. 自動回復增加時間限制.
13. 調整了 Webmail 目錄結構﹐以增加安全性.
14. 修正了導出用戶郵箱帳號出錯.
15. 修正了計劃任務時間段設定問題.
16. 修正了 Webmail 文本格式下郵件回復出錯.
17. 修正了 Mozilla Thunderbird POP3 認證問題.
18. 中繼遞送﹐直接遞送可設定 MAIL FROM﹐支援 163.com, sohu.com 中繼遞送.
19. 修正了加密的 RAR 壓縮包釋放誤判為病毒郵件.
20. 修正了更新密碼時﹐共享檔案不能存取.
22. 更新了 Outlook Express 插件.
23. 修正了遞送給群組的郵件﹐郵件大小記錄不正確的問題.
24. 修正了 IMAP 服務和 Opera, Mozilla Thunderbird 相容性的問題.
25. Webmail 新增加 English 的拼寫檢查功能.
26. webmail 增加了日語和法語支援.
27. 增加了不進行 SMTP 過濾的主機位址清單.
28. 增加了郵件群組可見度設定.

Version 4.0(Build 1318)(2005/01/18)

1. 修正了 Webmail 中網路磁盤檔日期顯示的問題.
2. 修正了 Webmail 暴露裝設路徑的問題.
3. 修正了 Webmail 檔案上傳下載有效性校驗的問題.
4. 修正了 Webmail 對 JavaScript 過濾不全的問題.
5. 修正了 IMAP 服務檔案夾有效性校驗的問題.
6. 修正了網路磁碟服務 Port 命令有效性校驗的問題.
7. 更新了unzipdll.dll.

Version 4.0(Build 1112)(2004/11/12)

1. 增加了網路磁碟（FTP 伺服器）﹐支援檔案共享.
2. 增加了網路行事歷和網路記事本.
4. Webmail 增加公告板功能.
5. 增強了 IMAP 服務.
6. 網域名稱直接遞送支援用戶認證.
7. 郵件查毒時釋放 unzip, unrar 格式的附件.
8. 郵箱用戶權限細分﹐可設定有效時間等.
9. 增加了公用位址簿數據的備份.
10. 增強了 COM 群組件功能﹐增加用戶容量﹐域容量限制﹐個人資訊修改等.
11. 用戶清單顯示郵箱容量﹐已用容量等.
12. Webmail 增加了通過問題和答案產生臨時密碼.
13. Webmail 可以設定頁面寬度.
14. Webmail 可以設定結束到指定制的頁面.
15. Webmail 支援儲存密碼自動登入.
16. Webmail 讀郵件時增加過濾郵件.
17. Webmail 發郵件支援直接發到公共郵件夾.
18. 增加了用戶過濾郵件直接遞送到公共郵件夾
19. 修正了 WinXP 清單中圖示不顯示問題.
20. 修正了 Webmail 彈出視窗時出現登入頁面.
21. 修正了 RBL 查詢時死回圈問題.
22. 修正了 HTTP 服務啟動狀態報告不正確的情況.
23. 修正了 Webmail 轉發 TNEF 格式的郵件不正確的問題.
24. 修正了 Webmail 發送大附件時系統資源佔用過大的問題.
25. 修正了用戶不存在時﹐發送到 Internet 檢發送者是否允許外發.
26. 修正了自動轉發檢查發件人是否有發信限制.
27. 修正了 Mac OS 上 POP3 收到普通域下的郵箱.
28. 修正了 POP3 download 多線程死回圈的問題.
29. 在 SMTP 中增加 VRFY﹐EXPN 命令﹐可以選擇是否開啟.
30. 群組管理員與指定發信人可以是非群組員和外部郵箱.

Version 3.8(Build 0820)(2004/08/20)

1. 增加了SMTP通訊中識別虛假信頭的功能.
2. 增加了發件人白名單和收件人白名單.
3. 增加了群組合過濾功能.
4. 增加了附件個數過濾的功能.
5. 重寫 IMAP 服務.
6. 修正了 Webmail Session Timeout 問題.
7. 修正了 Webmail 顯示亂碼問題.
8. 修正了 Pop3 下載多線程問題.
9. 修正了 RBL 檢查出錯問題.
10. 修正了公用位址簿導入含中文檔案亂碼問題.
11. 修正了在 Windows 2003 上裝設 Webmail 出錯問題.

Version 3.8(Build 0509)(2004/05/10)

1. 增加支援 SSL 的 HTTP 服務.
2. 增加了過濾郵件正文的功能.
3. 增加了在管理程式裏直接清空某一用戶郵箱的功能.
4. 增加了管理工具儲存登陸密碼的功能.
5. 增強了 SMTP 對 SSL 通信的支援.
6. 增加了 SMTP/POP3/IMAP4 用戶 IP 存取頻率限制的功能.
7. 增加了 SMTP/POP3/IMAP4 同一 IP 同時連接次數限制的功能.
8. 管理工具中查看公用位址薄的時候顯示全名.
9. 增加了郵件群組可設定管理員的功能.
10. 增加了郵件群組群組成員導入和導出的功能.
11. 郵件備份按發送者接收者分目錄存放.
12. SMTP 中增加了EHLO/HELO 主機名檢查.
13. Webmail 中增加了用戶郵箱級過濾設定的功能.
14. Webmail 中增加了帳號保留的功能.
15. Webmail 中增加了下載郵件全文的功能.
16. Webmail 可以屏蔽外部pop3, 短信, 修改密碼.
17. Webmail 支援 Greek 語言.
18. 修正了過濾檔案附檔名處理錯誤.
19. 修正了更換裝設目錄後備份數據無法用程式恢復的錯誤.
20. 修正了查看郵件佇列有時管理工具異常中止的錯誤.
21. 修正了一些 IMAP 命令處理錯誤﹐提高 IMAP 郵件處理效率, 支援 Outlook 2003.
22. 修正了網域名稱 MX 記錄找到不到的問題.
23. 修正了用 Web 介面中無法修改網域名稱“直接登入URL”屬性的錯誤.
24. 修正了 Webmail 中寫郵件時列公用位址簿慢的錯誤.
25. 修正了 LDAP 有時停止響應的錯誤.
26. 修正了 Webmail 顯示郵件有時出現 one_filtered 的錯誤.
27. 修正了 Webmail 顯示郵件有時暴露物理路徑的錯誤.

Version 3.6(Build 0202)(2004/02/02)

1. 修正了無限別名失效的問題.
2. 修正了過濾空主題失效的問題.
3. 修正了多郵箱監控失效的問題.

Version 3.6(Build 0116)(2004/01/16)

1. 增強了過濾規則功能, 過濾規則順序可調整.
2. IMAP 支援子檔案夾和包含空格的檔案夾.
3. 增強了快速設定工具的功能.
4. 增加了解除臨時檔案的功能.
5. 增加了設定單個用戶最大的允許發郵件位元組數.
6. 增加了郵件群組可以增加外部郵箱位址的功能.
7. 防病毒設定裏增加支援 Norman 殺毒引擎.
8. 公用位址簿增加導入,導出功能.
9. Webmail 增加了寫郵件時每隔一段時間自動存盤的功能.
10. Webmail 增加了直接收取用戶外部 POP3 帳號中郵件功能.
11. Webmail 寫郵件可以直接從公用位址簿和郵件群組中選取收件人.
12. Webmail 增加拷貝郵件功能.
13. Webmail 增強了對UTF7, UTF8, UUCODE 格式郵件的支援.
14. Webmail 增加了允許用戶選擇是否加入公用位址簿.
15. Webmail 增加MS-TNEF(winmail.dat)型式附件自動剝離功能.
16. Web 管理程式增加找到用戶功能.
17. 輔助說明檔案增加了讓 Webmail 執行在 Apache 環境中的方案
18. 修正了有時用戶最後存取時間丟失問題.
19. 修正了修改主域時公用位址簿出錯問題.
20. 修正了 SMTP 設定 DNS 反查﹐發郵件給本域時的問題.
21. 修正了 SMTP 設定找到用戶是否存在﹐發郵件給域別用戶的問題.
22. 修正了域屬性的預設郵箱被清空的錯誤.
23. 修正了 IE5 瀏覽 Webmail 出錯問題.
24. 修正了 Webmail 閱讀新浪發來帶附件郵件的問題.

Version 3.5(Build 1106)(2003/10/07)

1. 增加 Webmail 瀏覽 IMAP 公共檔案夾中的郵件功能.
2. 增強了公用位址簿的解除用戶名單功能.
3. 增加個人位址簿個數限制功能.
4. 增加了新建的用戶可以自動增加到 everyone 群組中的功能.
5. 增強了郵件過濾功能﹐方便用戶利用此功能來分發郵件.
6. Webmail 可以建立中文檔案夾.
7. 支援自定義系統的各服務顯示標簽.
8. 解決了Web 管理功能中加郵箱頁面出錯的問題.
9. 解決了 Webmail 中簽名檔格式和儲存問題.
10. Web 管理程式的語言包新增瑞典語.
11. 解決了 Webmail 中文檔案名稱有時無法查看的問題.

Version 3.4b(Build 1022)(2003/10/24)

1. 支援短信提醒﹐有新郵件到達時﹐可在手機上獲得通知.
2. 對 SMTP, POP3, IMAP, LDAP 可以支援 SSL 加密傳輸, 防止網路偵聽.
3. SMTP 設定裏增加HELO主機名設定功能, 解決了發信到 sina 郵箱的問題.
4. 公用位址簿可以增加非本系統的位址.
5. 增加 IMAP 公共郵件夾功能, 可以設定讀寫權限.
6. 支援使用外部 Socks4,Socks5 伺服器代理發信和 POP3 下載.
7. 郵件過濾增加信頭任意內容過濾功能.
8. 防病毒設定裏增加附件檔案名稱和型式過濾功能.
9. 防病毒設定裏增加支援 Panda, RAV, F-Secure 殺毒引擎.
10. 增加接受郵件時對發信位址做網域名稱 DNS 反向檢查功能.
11. 增加接受郵件時立刻對本地郵箱是否存在做檢查功能.
12. 增加 COM 接口群組件, 可以程式設計操作用戶賬號,網域名稱,管理員, 提供 asp, php 實例.
13. 郵件通訊閘的 POP3 下載中增加公用外部位址用戶名取代功能, 可以實現多人共享一個郵件帳號而互不干擾.
14. SMTP 設定中增加公用外部位址取代功能.
15. 增加 Web 管理功能, 可以進行在網頁上在線管理系統的郵箱和網域名稱.
16. Webmail 增加請求閱讀收條的功能.
17. Webmail 增加儲存到草稿箱的功能.
18. Webmail 增加 customer 目錄, 使修改頁面更方便, 並可以針對不同的域定制不同的.
19. Webmail 中公用位址簿將顯示用戶全名.
20. Webmail 支援 Norwegian, Danish 語言.
21. Webmail 登陸支援直接輸入網域名稱.
22. Webmail 寫HTML格式郵件支援選擇多種信紙.
23. 解決了webmail 拷貝URL能登入的問題.
24. 解決了修改POP3連接埠後 Webmail 無法登陸的問題.
25. 解決了 Webmail 中簽名檔格式問題.
26. 解決了 Webmail 登陸名加空格無法正常看信的問題.
27. 解決了用 Ximain Evolution 存取時, IMAP, POP3 格式相容的問題.
28. 解決了有時出現錯誤的郵箱滿的問題.
29. 解決了POP3下載有時出現重複收信的問題.

Version 3.0(Build 0808)(2003/08/08)

1. 增加公用位址簿(LDAP), Outlook等可查看, 增加更多的用戶資訊欄位.
2. 增加IMAP功能.
3. 增加郵件簽核功能, 可以在郵件發出前進行簽核.
4. 增加系統備份, 可以增強郵件備份功能.
5. 增加外域直接發送主機.
6. 管理工具語言包新增繁體中文, WebMail 的語言包新增德語和瑞典語.
7. 增強過濾規則的功能.
8. 修正在大量發送郵件時﹐找到用戶找不到的BUG.
9. 增加計劃任務的執行時間段.
10. 可以設定儲存歷史日誌的天數.
11. Webmail與IIS整合後﹐可以上傳較大的附件.
12. 修改有時出現用戶的郵件大小和郵件數為負數的問題.
13. SMTP設定功能增加檢查SMTP互動命令中的郵件位址是否合法的功能.
14. SMTP設定功能增加郵件收件人過濾.
15. 對找到MX的結果按優先權進行排序.
16. 修正某些情況下﹐SMTP發送過程中發生的通信異常.
17. 修正在CheckPoint防火牆下﹐找到MX出錯.
18. 增加用戶清單﹐網域名稱清單等排序功能.
19. 增加用戶導入與導出功能.
20. 改善管理工具超時提示功能.
21. 修正Netscape Messenger認證發送出錯.
22. Webmail增加永久解除功能.
23. 增加單獨的管理程式裝設包.
24. 病毒警告信可以設定發給收件人.
25. 修改了其它一些小問題, 改變了一些提示寫法.

Version 2.4(Build 0530)(2003/05/30)

1. 更新輔助說明檔案, 解決了 Webmail 設定到IIS中無法修改密碼和設定參數的問題.
2. 解決了使用快速設定向導工具後SMTP認證功能不立刻生效的問題.
3. 解決了一個系統記憶體溢出的問題.
4. 解決了Webmail發信信頭標籤不全的問題.

Version 2.4(Build 0516)(2003/05/20)

1. 允許多個管理員, 支援單獨的域管理員功能.
2. 支援更多的域屬性.
3. 用戶郵箱轉發功能可支援多個位址.
4. 增加將 MS-TNEF (winmail.dat) 型式附件自動剝離功能.
5. 可以將 WebMail 設定為 IIS 的虛擬目錄或虛擬站點.
6. WebMail 的語言包新增繁體中文.
7. 優化了 WebMail 登陸速度.
8. 支援 Windows 2003 Server.
9. POP3下載中的用戶名支援包含 %.
10. 解決了smtp改連接埠後 Webmail 無法發信的問題.
11. 解決了使用DNS紀錄緩存後無法發信到某些域的問題.
12. 解決了升級裝設時WebMail 腳本出錯的問題.

Version 2.3(2003/04/02)

1. 新增快速設定向導工具, 讓您一分鐘內設定好郵件系統.
2. 新增直接用郵件用戶端打開郵件佇列裏郵件的功能.
3. WebMail 新增在線註冊新郵箱的功能.
4. WebMail 的 HTML 編輯器新增插入表格,Image鏈接和Flash鏈接的功能.
5. 優化了 WebMail 性能, 執行速度更快.
6. 解決了在特殊設定時 WebMail 無法使用的問題.
7. 解決了 WebMail 日期格式顯示錯位的問題.
8. 解決了 WebMail 多域時無法正常使用的問題.
9. 未註冊版本可加入的郵箱數增加到20個.
10. 解決了多附件郵件格式處理有誤的問題.
11. 解決了外發權限控制不嚴格的問題.
12. 解決了開機自動執行無法關閉的問題.
13. 修改了其它一些小問題; 改變了一些提示寫法.

Version 2.02(2003/03/04)

1. 全功能多語言Webmail, 可以在網頁上收發郵件.
2. 增強郵件殺毒功能, 可支援內嵌API在內三種模式, 支援幾乎所有的殺毒引擎.
3. 增強郵件監控功能, 被監控郵箱和監控人郵箱可以任意群組合.
4. 增加郵件備份功能, 可以將所有發送的郵件本域內或外域外的郵件備份到指定郵箱.
5. 用戶郵箱自動轉發可設定保留備份.
6. 增加用戶郵箱不成功的提示資訊更加清楚明確.
7. 可以設定smtp外發超時時間和郵件通訊閘中POP3接收外部郵件的超時時間.
8. 定時任務可以設定有效或禁用.
9. 增加對防垃圾郵件功能 RBL(Real-time Blackhole Lists) 支援.
10. 增加DNS 緩衝功能, 讓外發郵件更迅速.
11. 解決了SMTP發信快結束時變慢的問題.
12. 解決了有些系統上CPU佔用超過90%的問題.
13. 解決了老的系統日誌無法清除的問題.

Version 1.22(2003/01/16)

1. SMTP 認證可以設定檢查認證用戶和發件人欄位一致.
2. 外發伺服器的驗證用戶名可以包含 "@" 符號.
3. 改正POP3下載和域屬性裏的"本域中不存在的郵箱發送到Internet"可以出現的回圈問題.
4. 改正了發送回退信提示不明確的問題.
5. 在防毒功能中增加超時控制.
6. 優化裝設包,使其更小.

Version 1.20(2003/01/08)

1. 新增郵件佇列病毒掃描功能,用戶可以選擇多種掃毒引擎
2. 可以手工設定兩個DNS伺服器
3. 獲取MX記錄時超時處理
4. 檢查最新版本時顯示版本變動資訊
5. 將啟動失敗資訊寫到系統事件中
6. 控制單個用戶發外部郵件和收外部郵件的權限
7. 修正發信到Hotmail.com出現異常BUG
8. 修正郵件通訊閘/POP3下載按信頭分揀BUG
9. 修正郵箱監控部分特殊信無法監控的BUG

Version 1.04(2002/11/29)

1. 可以監控被監控郵箱的所有收到和發出郵件
2. 管理程式通過SSL加密通訊協定和伺服器通信﹐所以 1.04 不能和 1.02通訊
3. 修正了一些BUG﹕發信到郵件群組､修改郵件群組等等
4. 增加了檢查最新版本功能
5. 修改用戶功能顯示用戶已用空間､用戶自設POP3
6. 管理工具的介面和程式圖示美化調整
7. 支援Windows 95 和 97
8. 增加簡體中文裝設程式

Version 1.02 (2002/11/01)

1. SMTP/ESMTP
2. POP3
3. NT域認證
4. 用戶和用戶別名
5. 郵件群組
6. 域和域別名
7. 郵件通訊閘: POP3､ETRN
8. 遠端控制: 設定用戶POP3､設定自動轉發､設定自動回復
9. 過濾和監控
10. 計劃任務
11. 日誌


註冊購買與升級

Winmail Server是一款共享軟體﹐任何人都可以免費下載使用﹐註冊前可以使用90天﹐ 支援 20 用戶 5 域名。
如果想獲得更多用戶數和及時的技術支援﹐請註冊本軟體。 註冊可以讓我們更好地改進我們的產品。

有關註冊購買的詳細資訊請到 http://www.winmail.cn/register.php
有關本軟體的最新版本升級資訊請到 http://www.winmail.cn


聯繫我們

關於我們

華美科技（蘇州）有限公司於2000年4月在蘇州工業園區投資成立，註冊資本 116 萬美元。蘇州公司是華美科技有限公司在中國的總部，公司在中國大陸的研發中心。 華美科技（蘇州）有限公司是江蘇省第一批認證的軟體企業， 擁有多個自主智慧財產權的網路軟體產品，例如電子郵件系統、傳真伺服器軟體、列印管理監控、資訊發佈系統和遠端教育系統等。 公司擁有一支強大的專業開發團隊，從事 Windows 和 Unix 平臺上的產品開發，公司願以積極的態度、專業的技術、以人為本的服務精神，為使用者提供最高性價比的產品和服務 。

聯繫我們

日常聯繫: webmaster@winmail.cn (負責處理日常事務、建議、意見、網站友情聯接)
技術支援: support@winmail.cn (負責處理有關安裝、 使用、BUG等技術的問題)
註冊服務: register@winmail.cn (負責處理所有和註冊有關事項)
更詳細的聯繫方式請訪問 Winmail 簡體中文主站: http://www.winmail.cn


常見問題

請訪問 http://www.winmail.cn/faq.php 查看網站上更全的常見問題

安裝相關問題
安裝完畢一定要重新啟電腦嗎？
版本升級會影響原有資料嗎？怎樣升級？
安裝後，為什麼總是不能啟動SMTP/POP3/ADMIN/HTTP/IMAP/LDAP服務？
安裝後，為什麼郵件系統啟動不成功？
安裝後，除了ADMIN 服務啟動，其他服務都停止？
我的作業系統需要重新安裝，如何保留 Winmail 的設置和資料？
我的郵件系統要遷移到新的伺服器上，如何移植 Winmail 的設置和資料？

註冊相關問題
註冊版有什麼不同？
我給您們匯款後，多久可以收到註冊碼？

使用與設置相關問題
1) 發郵件問題
Winmail 中 SMTP 服務啟動了，但無法發送郵送呢？
我的郵件系統能收不能發，請問可能是什麼原因呢？
為什麼我向外部（英特網）郵箱發信總是失敗？
我用Outlook 和 發信總是提示 550 5.7.1 Unable to relay for xyz@abc.com，怎樣解決？
我用Outlook 和 發信到其它域總是提示 '553 sorry, your don't authenticate or the domain isn't in my list of allowed rcpthosts(#5.7.1)，怎樣解決？
在 Outlook 已設定了"我的伺服器需要驗證", 但發信時, 仍出現 550 5.7.1 Unable to relay for <company.com>
郵件伺服器設置了SMTP發信認證，為什麼非法用戶一樣可用本郵件伺服器的SMTP發信？
為何總是運行不穩定，有時向外發信有好幾小時的延遲？
我的郵件系統，被其他人用來轉發！怎麼解決？
在沒有功能變數名稱及沒有固定IP的情況下，本軟體可不可以外發郵件？有沒有什麼好的解決辦法？
我用SMTP協議通過 Winmail 郵件伺服器發信，如果位址中使用了不存在的功能變數名稱或者帳號，有什麼提示？
為什麼我在用郵件用戶端收、發信時，總是出現“無法連接到伺服器。 通訊端錯誤: 10061"的錯誤？
為什麼伺服器上安裝了瑞星防毒程式後不能正常收發郵件？
我已經開啟了發信認證，為什麼有時候發郵件不需要認證？

2) 收郵件問題
我可以向外部發送郵件，使用非SMTP標準埠（25），但無法收取外部郵件？
本地能正常收發，能發給外域，但外域發過來不能收到，問題出現在哪裡？
郵件系統裝在內部網中（如：IP是192.168.x.x），有外IP是202.x.x.x（固定），現在可以發郵件，但不能收郵件，怎樣設置才能收到郵件？
為什麼收不到外部信箱（如：yahoo.com 或 hotmail.com）發給我的郵件？
為什麼我的 Winmail 裝上以後，在遠端郵件用戶端使用 POP3 收信總是說密碼錯誤，而無法收信？
用 Outlook 2002 收信會出現停止回應的現象，怎樣解決？
接收郵件的附件是 winmail.dat，無法打開，請問如何解決？
為什麼我在用郵件用戶端收、發信時，總是出現“無法連接到伺服器。 通訊端錯誤: 10061"的錯誤？
為什麼伺服器上安裝了瑞星防毒程式後不能正常收發郵件？

3) 功能變數名稱和DNS問題
能不能告訴我幾個能用的DNS伺服器地址？
在Windows 98 和撥號上網的伺服器出現系統DNS找不到的問題，怎樣解決？
我有多個功能變數名稱 aaa.com, bbb.com, ccc.com，能夠實現一個用戶 user 可以對應於所有功能變數名稱？
怎樣申請動態DNS服務（可以方便架設ADSL互聯網郵件伺服器）？
是否一定要申請功能變數名稱並解析才能通過INTERNET收發郵件？
如何查找功能變數名稱的 MX 記錄是否正確？
如果判斷我的郵件服務是否已經開啟發信認證？

4) 管理工具相關
網路是通的，輸入的密碼也是對的，我的管理端為什麼連不上伺服器？
郵件伺服器管理員密碼丟失後怎麼辦？

5) 郵件系統架設問題
申請了企業郵局之後，是否還有必要設置郵件伺服器嗎？
我們公司現在有自己的功能變數名稱和企業郵箱，但現在自己建一個郵件系統。我想問的是能不能添加兩條MX記錄，使同一封信可以轉到兩個不同的郵件系統？
由於公司是通過FTTP＋Lan方式上網的，具體怎樣來設置呢？
Mail伺服器是否可以和用於撥號上網的伺服器分開？

6) 日常維護問題
 如何手工對郵件系統的資料進行備份？
郵件伺服器是否支援帳號許可權控制？例如，只能收不能發；收發的email能否自動在伺服器上保存並備份？
 我的郵件系統被人作為垃圾郵件伺服器，現在已設SMTP認證，但佇列中有上萬封垃圾郵件，請問怎麼刪除？
別人發給我的信是存放到哪裡的？能不能長期存放？
如何設置才能將服務某個特定網段的用戶使用？
可否禁止使用TELNET 25 或 TELNET 110？ 如可以TELNET 25，可否禁止支援EXPN及VRFY？

7) 其它問題
為什麼伺服器上安裝了諾頓 Norton 防毒程式後 Winmail 有時會自動關閉？
在伺服器上安裝該軟體，伺服器配置正常。伺服器有一塊網卡，兩個位址，如何讓兩個位址都能正常使用？
Winmail 是否支持自由申請，以及申請確認。
RBL 是什麼？
服務程式的註冊和登出命令是什麼？
Winmail 和防火牆配合

8) 錯誤回彈信分析
如何根據錯誤回彈信發現出錯原因？
常見的錯誤回彈信
發到 sina.com 的郵件會被退回
發到 tom.com 的郵件會被退回
發到 aol.com 的郵件會被退回
收到退信錯誤提示為"554 5.7.1 Rejected xxx.xxx.xxx.xxx found in dnsbl.sorbs.net"，怎麼辦？

Webmail 相關問題
 我想在我們主頁上加入 Webmail 的登陸欄，如何實現？
如何更改 Webmail 發出郵件的底部簽名？
我想更換 Webmail 的 LOGO 圖片、 廣告圖片和提示資訊，如何實現？
我可以使用 http://mymailserver:6080 登陸 Webmail。如何換成 http://mymailserver登陸？
多功能變數名稱時，WebMail 登陸頁面使用者要選擇自己的域很不方便，怎樣解決？
怎樣在 WebMail 登陸頁面加自由申請功能？
Webmail 設置到 IIS 中無法修改口令和設置自動轉發等參數, 怎樣解決？
Webmail 設置到 IIS 中無法上傳附件, 怎樣解決？
Webmail 設置到 IIS 中, 頁面出錯, 怎樣解決？
為什麼當我在 Webmail 登陸時會出現“create com instance error”的提示？
Webmail 使用中, 顯示" Can't contact LDAP server" 出錯, 怎樣解決？
使用 WebMail 發信時，提示"SMTP Error:could not connect to SMTP host server(s)" 錯誤怎麼辦？
使用 WebMail 發信時，提示"SMTP Error: Data not accepted，552 sorry， the message size exceeds databytes limit (#5.3.4)"錯誤怎麼辦？
我想讓 Webmail 退出和錯誤返回到指定的網頁，如何實現？
如何開啟與關閉 Webmail 自動登錄功能？
如何開啟與關閉 Webmail 取回密碼功能？
設置用自己安裝的 PHP 程式後，Webmail 不能正常使用，怎麼解決？
如何在我的系統中能取得使用者新郵件數？
如何在我的系統中嵌入Webmail，以實現列郵件夾列表，讀郵件，寫郵件等工作？
怎麼禁止修改介面風格和設定預設介面風格？


常見問題

安裝相關問題
安裝完畢一定要重新啟電腦嗎？
版本升級會影響原有資料嗎？怎樣升級？
安裝後，為什麼總是不能啟動 SMTP/POP3/ADMIN/HTTP/IMAP/LDAP 服務？
安裝後，為什麼郵件系統啟動不成功？
安裝後，除了ADMIN 服務啟動，其他服務都停止？
我的作業系統需要重新安裝，如何保留 Winmail 的設置和資料？
我的郵件系統要遷移到新的伺服器上，如何移植 Winmail 的設置和資料？
請訪問 http://www.winmail.cn/faq.php 查看網站上更全的常見問題

註冊相關問題
註冊版有什麼不同？
我給您們匯款後，多久可以收到註冊碼？

安裝完畢一定要重新啟電腦嗎？ ↑
如果安裝結束後不提示則不需要重啟即可使用。在老版本上升級建議重啟。

版本升級會影響原有資料嗎？怎樣升級？ ↑
在安裝新版本時選擇保留資料(leave)，則可以繼續使用原有資料和系統設置參數。當然為保險起見， 可以在升級前備份一下 Winmail Server 的全部檔。詳細安裝說明請參考軟體?明檔。 升級步驟: 1. 退出winmail; 2. 運行新的安裝包; 3. 選擇保留資料; 4. 重新啟動伺服器.

安裝後,為什麼總是不能啟動 SMTP/POP3/ADMIN/HTTP/IMAP/LDAP 服務？ ↑
出現上述情況可能會是以下幾個問題：
    一、SMTP/POP3/ADMIN/HTTP/IMAP/LDAP 啟動不成功（“系統設置”/“系統服務”所顯示的清單中，SMTP/POP3/ADMIN/HTTP/IMAP/LDAP 行首是圖示是紅色的，用telnet連接25/110/6000/6080/143/389 看沒有回應，如：POP3 則telnet xxx.xxx.xxx.xxx 110）
     1.首先您要確定您的 SMTP/POP3/ADMIN/HTTP/IMAP/LDAP 埠沒有被佔用（用aports　http://www.winmail.cn/download_other.php 查看正在使用此埠的程式）。如果已經佔用請停用佔用埠的程式，或者更換埠。
     2.“系統設置”/“系統服務”中，選中 SMTP/POP3/HTTP/IMAP/LDAP 行點擊“啟動”按鈕。
     3.看一下“系統日誌”/“SYSTEM”的啟動LOG中有關 SMTP/POP3/ADMIN/HTTP/IMAP/LDAP 的啟動資訊。
     4.如果SMTP/POP3/ADMIN/HTTP啟動正常，但本系統啟動時，SMTP/POP3/HTTP/IMAP/LDAP 不能自動啟動。請在“系統設置”/“系統服務”中，選中POP3行點擊“設置”按鈕，將“本系統啟動時自動運行”選中。
    如果以上操作還不能正常啟動，請更改POP3設置中的埠，再重新啟動。看是否能正常運行。
    二、SMTP/POP3/ADMIN/HTTP/IMAP/LDAP 啟動成功，而正常工作（“系統設置”/“系統服務”所顯示的清單中，SMTP/POP3/ADMIN/HTTP/IMAP/LDAP 行首是圖示是綠色的）
     1.“系統設置”/“系統服務”中，選中SMTP/POP3/ADMIN/HTTP/IMAP/LDAP 行點擊“設置”按鈕。
     2.查看本服務綁定的IP（不要用127.0.0.1，而應用您的網卡IP，或是0.0.0.0）和埠、超時時間以及存取控制。
     3.“系統設置”/“系統服務”中，選中 SMTP/POP3/HTTP/IMAP/LDAP 行點擊“停止”按鈕，然後點擊“啟動”按鈕。

安裝後，為什麼郵件系統啟動不成功？ ↑
出現這種情況，可能是以下情況：
1. ADMIN 服務埠(埠號為6000)被佔用，請按“安裝後,為什麼總是不能啟動 SMTP/POP3/ADMIN/HTTP/IMAP/LDAP 服務？”查看 ADMIN 服務埠是否佔用。
2. 註冊碼無效，試用過期或機器時間不對。
3. 資料庫或系統設定檔出錯。

安裝後，除了ADMIN 服務啟動，其他服務都停止？ ↑
出現這種情況，可能是以下情況：
1. 註冊碼無效，試用過期或機器時間不對。
2. 各服務埠被佔用。
3. 安裝了多次，每次安裝方式不一致，需要先卸載後，重新安裝。

我的作業系統需要重新安裝，如何保留 Winmail 的設置和資料？ ↑
1. 備份Winmail Server安裝目錄( 預設是在C:\Program Files\Magic Winmail，可自訂 )，郵件存放目錄( 預設是在C:\Program Files\Magic Winmail\server\store，可自訂 );
2. 重新安裝作業系統;
3. 將備份的2個資料夾複製回原來的存放路徑: Winmail Server 安裝目錄( 預設是在C:\Program Files\Magic Winmail，可自訂 )，郵件存儲目錄( 預設是在C:\Program Files\Magic Winmail\server\store，可自訂 );
4. 重新安裝 Winmail Server，安裝路經選擇之前 Winmail Server 安裝目錄( 預設是在C:\Program Files\Magic Winmail，可自訂 );安裝過程中提及"當設定檔已存在時"選擇"保留原有配置";安裝完成後進入Winmail Server管理工具，在 高級設置->系統參數->郵件存儲 目錄設置為之前的郵件存儲目錄路徑。

我的郵件系統要遷移到新的伺服器上，如何移植 Winmail 的設置和資料？ ↑
1. 備份Winmail Server安裝目錄( 預設是在C:\Program Files\Magic Winmail，可自訂 )，郵件存放目錄( 預設是在C:\Program Files\Magic Winmail\server\store，可自訂 );
2. 將備份的2個資料夾複製到新的郵件伺服器上，( 例如存放在預設的安裝目錄C:\Program Files\Magic Winmail下 );
3. 在新的郵件伺服器上運行Winmail Server安裝包，安裝路經選擇之前Winmail Server安裝目錄;安裝過程中提及"當設定檔已存在時"選擇"保留原有配置";安裝完成後進入Winmail Server管理工具，在 高級設置->系統參數->郵件存儲 目錄設置為之前的郵件存儲目錄路徑。

註冊版有什麼不同？ ↑
軟體使用沒有時間限制
服務期內免費升級
支持更多用戶
服務期內獲得免費、及時的Email技術支援
新版本發佈通知

註冊版有什麼不同？ ↑
我們收到憑證傳真或確認到帳（網上匯款）後，會在半小時內將註冊碼通過郵件先發給您。如果下午4：30之前完成的，發票、註冊授權碼、還有光碟當天通過快遞寄出，否則第二個工作日寄出。


常見問題

請訪問 http://www.winmail.cn/faq.php 查看網站上更全的常見問題

使用與設置相關問題
1) 發郵件問題
Winmail 中 SMTP 服務啟動了，但無法發送郵送呢？
我的郵件系統能收不能發，請問可能是什麼原因呢？
為什麼我向外部（英特網）郵箱發信總是失敗？
我用Outlook 和 發信總是提示 550 5.7.1 Unable to relay for xyz@abc.com，怎樣解決？
我用Outlook 和 發信到其它域總是提示 '553 sorry, your don't authenticate or the domain isn't in my list of allowed rcpthosts(#5.7.1)，怎樣解決？
在 Outlook 已設定了"我的伺服器需要驗證", 但發信時, 仍出現 550 5.7.1 Unable to relay for <company.com>
郵件伺服器設置了SMTP發信認證，為什麼非法用戶一樣可用本郵件伺服器的SMTP發信？
為何總是運行不穩定，有時向外發信有好幾小時的延遲？
我的郵件系統，被其他人用來轉發！怎麼解決？
我用SMTP協議通過 Winmail 郵件伺服器發信，如果位址中使用了不存在的功能變數名稱或者帳號，有什麼提示？
為什麼我在用郵件用戶端收、發信時，總是出現“無法連接到伺服器。 通訊端錯誤: 10061"的錯誤？
為什麼伺服器上安裝了瑞星防毒程式後不能正常收發郵件？
我已經開啟了發信認證，為什麼有時候發郵件不需要認證？

2) 收郵件問題
我可以向外部發送郵件，使用非SMTP標準埠（25），但無法收取外部郵件？
本地能正常收發，能發給外域，但外域發過來不能收到，問題出現在哪裡？
郵件系統裝在內部網中（如：IP是192.168.x.x），有外IP是202.x.x.x（固定），現在可以發郵件，但不能收郵件，怎樣設置才能收到郵件？
為什麼收不到外部信箱（如：yahoo.com 或 hotmail.com）發給我的郵件？
為什麼我的 Winmail 裝上以後，在遠端郵件用戶端使用 POP3 收信總是說密碼錯誤，而無法收信？
用 Outlook 2002 收信會出現停止回應的現象，怎樣解決？
接收郵件的附件是 winmail.dat，無法打開，請問如何解決？
為什麼我在用郵件用戶端收、發信時，總是出現“無法連接到伺服器。 通訊端錯誤: 10061"的錯誤？
為什麼伺服器上安裝了瑞星防毒程式後不能正常收發郵件？

3) 功能變數名稱和DNS問題
能不能告訴我幾個能用的DNS伺服器地址？
我有多個功能變數名稱 aaa.com, bbb.com, ccc.com，能夠實現一個用戶 user 可以對應於所有功能變數名稱？
怎樣申請動態DNS服務（可以方便架設ADSL互聯網郵件伺服器）？
是否一定要申請功能變數名稱並解析才能通過INTERNET收發郵件？
如何查找功能變數名稱的 MX 記錄是否正確？
如果判斷我的郵件服務是否已經開啟發信認證？

4) 管理工具相關
網路是通的，輸入的密碼也是對的，我的管理端為什麼連不上伺服器？
郵件伺服器管理員密碼丟失後怎麼辦？

5) 郵件系統架設問題
申請了企業郵局之後，是否還有必要設置郵件伺服器嗎？
我們公司現在有自己的功能變數名稱和企業郵箱，但現在自己建一個郵件系統。我想問的是能不能添加兩條MX記錄，使同一封信可以轉到兩個不同的郵件系統？
由於公司是通過FTTP＋Lan方式上網的，具體怎樣來設置呢？
Mail伺服器是否可以和用於撥號上網的伺服器分開？

6) 日常維護問題
 如何手工對郵件系統的資料進行備份？
郵件伺服器是否支援帳號許可權控制？例如，只能收不能發；收發的email能否自動在伺服器上保存並備份？
 我的郵件系統被人作為垃圾郵件伺服器，現在已設SMTP認證，但佇列中有上萬封垃圾郵件，請問怎麼刪除？
別人發給我的信是存放到哪裡的？能不能長期存放？
如何設置才能將服務某個特定網段的用戶使用？
可否禁止使用TELNET 25 或 TELNET 110？ 如可以TELNET 25，可否禁止支援EXPN及VRFY？

7) 其它問題
為什麼伺服器上安裝了諾頓 Norton 防毒程式後 Winmail 有時會自動關閉？
在伺服器上安裝該軟體，伺服器配置正常。伺服器有一塊網卡，兩個位址，如何讓兩個位址都能正常使用？
Winmail 是否支持自由申請，以及申請確認。
RBL 是什麼？
服務程式的註冊和登出命令是什麼？

8) 錯誤回彈信分析
如何根據錯誤回彈信發現出錯原因？
常見的錯誤回彈信
發到 sina.com 的郵件會被退回
發到 tom.com 的郵件會被退回
發到 aol.com 的郵件會被退回
收到退信錯誤提示為"554 5.7.1 Rejected xxx.xxx.xxx.xxx found in dnsbl.sorbs.net"，怎麼辦？

9) Winmail 和殺毒引擎軟體
Winmail 和殺毒引擎
Winmail 和諾頓防毒
Winmail 和瑞星防毒
Winmail 和金山毒霸
Winmail 和江民 KV 防毒
Winmail 和McAfee防毒
Winmail 和趨勢防毒
Winmail 和AVG防毒
Winmail Server和朝華安博士防毒
Winmail 和卡巴斯基(Kaspersky/AVP)防毒
Winmail 和熊貓衛士防毒(Panda)

Winmail 中 SMTP 服務啟動了，但無法發送郵送呢？ ↑
出現上述情況是主要是SMTP參數設置不正確。一般是SMTP伺服器設置要求發信認證，而用戶端發信工具沒有設置發信認證。這種情況Outlook 的錯誤提示包含: 伺服器回應: '553 sorry, your don't authenticate and the domain isn't in my list of allowed rcpthosts(#5.7.1)' . 還有一種情況是伺服器上安裝了瑞星防毒程式, 郵件伺服器上不要打開瑞星的郵件監控功能，這樣會帶來無法發送郵件問題, 具體說明請看下面的FAQ。

我的郵件系統能收不能發，請問可能是什麼原因呢？ ↑
1. 首先要確定您的機器能不能正確的連接到外面的主機。在命令列方式下執行如下命令：
C：> telnet mx.mail.163.com 25
220 Welcome to coremail System(With Anti-Spam) 2.1 for 163.com
C：> telnet sinamx.sina.com.cn 25
220 sina.com ESMTP
如果能見到上述住處就表示能正常連接，否則表示不能正常連接。
2. 您的機器上沒有安裝一些郵件防火牆軟體。如果用了請停止。因為郵件防火牆軟體，會接管SMTP、POP3埠，請郵件系統不能正常工作。 如果用了瑞星，請見：郵件伺服器與瑞星防火牆整合
3. 可能是DNS Server不正確，請用管理工具登錄郵件系統後，在“系統設置”-》“高級設置”-》“系統參數”，在“DNS設置”屬性頁中，選擇“使用下面的DNS伺服器位址”，並在“首先DNS伺服器”和“備用DNS伺服器”中，增加當地的dns伺服器地址，然後“應用”。 如果您不能確定當地的DNS位址，也可以用 Google 的DNS: 8.8.8.8 和 8.8.4.4。

為什麼我向外部（英特網）郵箱發信總是失敗？ ↑
一、在絕大部分情況下對外部（英特網）郵箱發信失敗都是因為DNS設置不當引起的。您可以在伺服器上點擊右下角圖示，然後在彈出功能表中選取“服務”項後查看所設置的DNS伺服器地址。您需確認：
1) 是否設置有DNS伺服器位址。
2) 所設置的DNS伺服器位址是否是有效的。
3) 此DNS伺服器是否正常工作。
4) 如果使用預設的DNS服務，要確定可以進行正常DNS解析
二、系統安全設置或防火牆的設置造成無法對外進行UDP通訊引起的
解決辦法：允許UDP包通過。

我用Outlook 和 發信總是提示 550 5.7.1 Unable to relay for xyz@abc.com，怎樣解決？ ↑
這兒提示資訊不是 Winmail 的, 可能是IIS自帶smtp伺服器的資訊, 請進入IIS管理程式停止它的smtp伺服器, 然後重新啟動 Winmail 的smtp服務。徹底停止請到系統服務設置裡將 "Simple Mail Transport Protocol (SMTP)"的啟動類型設為"手動"或"已禁用"。

我用Outlook 和 發信到其它域總是提示 '553 sorry, your don't authenticate or the domain isn't in my list of allowed rcpthosts(#5.7.1)，怎樣解決？ ↑
您的SMTP伺服器設置要求發信認證，而用戶端發信工具沒有設置發信認證, 請設置。

在 Outlook 已設定了"我的伺服器需要驗證", 但發信時, 仍出現 550 5.7.1 Unable to relay for (New) ↑
1) Telnet yourserverip 25 , 出現 220 ******************************************
2) 輸入 EHLO 命令, 出現 502 unimplemented (#5.5.1)
3) 前端使用Cisco PIX 防火牆

此為Cisco PIX 內建的 MailGuard 或 MailHost 阻擋了 ESMTP 的指令 (如EHLO)
請關掉 Mail Guard 功能或與防火牆供應商聯繫。
請查考 Winmail 和防火牆配合

郵件伺服器設置了SMTP發信認證，為什麼非法用戶一樣可用本郵件伺服器的SMTP發信？ ↑
發信時不需要認證的情況：
1) 發郵件主機的位址在“信任主機”清單中；
2) 收件人的位址所屬域在本系統的功能變數名稱，域別名或“直接遞送域”列表中。

為何總是運行不穩定，有時向外發信有好幾小時的延遲？ ↑
建議您檢查以下幾個方面：
1. 網路狀況。
2. DNS解析的情況。
3. 保證沒有尺寸很大的郵件，導致處理速度慢。
4. 保證郵件伺服器沒有被別人用來轉發郵件。

我的郵件系統，被其他人用來轉發！怎麼解決？ ↑
請開始伺服器的SMTP認證功能。用管理工具登錄郵件系統，“系統設置”-》“SMTP設置”, 在“基本參數”屬性頁，選中“啟用發信認證”選項。然後點擊“應用”。

在沒有功能變數名稱及沒有固定IP的情況下，本軟體可不可以外發郵件？有沒有什麼好的解決辦法？ ↑
即使在沒有註冊功能變數名稱及沒有固定IP的情況下，只要能連接到INTERNET就，本系統一樣可以往外發郵件，但是可能會收不到從外域發過來的郵件。
如果是ADSL上網使用者，可以有申請動態功能變數名稱，來實架構郵件伺服器。具體請見我們的資料：http://www.winmail.cn/technic_dnip.php

我用SMTP協議通過 Winmail郵件伺服器發信，如果位址中使用了不存在的功能變數名稱或者帳號，有什麼提示？ ↑
該郵件在指定時間裡如果沒有被發送出去的話，會被退回給發信人（並在退信中提示是向哪個位址發送郵件時失敗的），而在當時是沒有提示的。

為什麼我在用郵件用戶端收、發信時，總是出現“無法連接到伺服器。 通訊端錯誤: 10061”的錯誤？ ↑
1) IP位址設置錯誤：在郵件用戶端軟體中設定的POP3以及SMTP伺服器的ip地址，不是當前正在運行的Winmail伺服器的IP地址；
2) 埠號設置錯誤：在郵件用戶端軟體中設定的POP3以及SMTP服務的埠號錯誤；
3) Winmail的服務程式沒有被運行（您可以查看系統進程中是否有mailserver.exe）。

為什麼伺服器上安裝了瑞星防毒程式後不能正常收發郵件？ ↑
郵件伺服器上不要打開瑞星的郵件監控功能，這樣會帶來無法收發郵件問題, 具體設置是: 打開瑞星的管理程式, 選擇功能表"選項"/"設置", 在"電腦監控"設置頁面, 不要選擇"開機時啟動郵件監控", 注意必須重新啟動電腦才能生效。
再關閉瑞星的郵件監控後, Winmail 可以和瑞星配合使用, 不過還有進行以下設置: 打開瑞星的管理程式, 選擇功能表"選項"/"設置", 在"電腦監控"設置頁面, 選擇"開機時開機檔案監控", 再選擇"高級設置", 打開"殺毒設置"視窗, 在"發現病毒後處理方式"選擇"刪除檔", 在"發現清除失敗後處理方式"選擇"忽略"; 注意必須重新啟動電腦才能生效。 然後在 Winmail 的"防病毒設置"選擇"病毒防火牆"模式。 不過需要注意的是在打開瑞星的管理程式時, 瑞星的防護功能無效, 而且正常使用時瑞星的防護功能也可以失效。
詳細設置請看 Winmail 和瑞星防毒

我可以向外部發送郵件，使用非標準的SMTP埠（25），但無法收取外部郵件？ ↑
如果SMTP用非標準的25埠肯定是收不到外面發來的郵件的。其它郵件伺服器發郵件給您的郵件伺服器時，不知道您SMTP伺服器現在採用什麼埠，默認還是連接的郵件伺服器的SMTP服務預設埠25，所以連接就不可能成功，也就自然收不到外域發來的郵件。如果您的郵件伺服器要與其它郵件伺服器進行交換郵件，就不能更改SMTP伺服器的埠。

本地能正常收發，能發給外域，但外域發過來不能收到，問題出現在哪裡？ ↑
如果您收發本地的郵件正常，信發往外部郵件系統也可以，可能是以下情況引起：
1. 您沒有公網的位址，外部郵件系統連不到您的伺服器或伺服器的SMTP (25) 埠拒絕外部訪問；
2. 您所用的功能變數名稱是否是已經註冊過的功能變數名稱, 功能變數名稱及此功能變數名稱的郵件交換記錄（MX）記錄有沒有DNS解析名, MX是否已經指向到您現在的郵件伺服器的主機位址。如果不是請與您的功能變數名稱服務商聯繫, 請他們?明設好DNS和將MX記錄指向您的郵件伺服器。有關功能變數名稱和MX記錄的技術資料，可以參考相關的書籍，或是通過搜尋引擎尋找相關網頁，我們的網站上也有一些資料。
3. 您的機器上有沒有安裝一些郵件防火牆軟體。如果安裝了請停止。因為郵件防火牆軟體，會接管SMTP、POP3埠，讓郵件系統不能正常工作。
4. 還有請確定您的功能變數名稱是否到期。

郵件系統裝在內部網中（如：IP是192.168.x.x），有外IP是202.x.x.x（固定），現在可以發郵件，但不能收郵件，怎樣設置才能收到郵件？ ↑
1、要申請一個功能變數名稱。要能收信一般需要一個頂層網域名（可在www.net.cn等網站上申請）；如果覺得成本較高可以也採用動態功能變數名稱。功能變數名稱相關知識、動態功能變數名稱的相關知識
2、如果是代理伺服器上網的話，可在代理伺服器上做NAT映射，也即將202.x.x.x（固定）位址的25，110，6080的埠映射到裝郵件伺服器的IP是192.168.x.x上。具體請見“Magic Winmail 郵件伺服器與代理伺服器軟體配合方案”；如果是路由器上網，也可必須設置埠（NAT）映射的，您可以找一下您所用路由器的型號相關的配置的說明書或文章。
3、如果採用的是頂層網域名，還需要設置功能變數名稱的MX（Mail eXchange，郵件交換記錄）使用指向到您安裝郵件伺服器的INTERNET上的地址。這步操作可以與您的功能變數名稱服務商聯繫。

為什麼收不到外部信箱（如：yahoo.com 或 hotmail.com）發給我的郵件？ ↑
成功接收來自Internet的郵件必須要做到以下條件：
1.要擁有Internet上的有效功能變數名稱。（如：www.domain.com）
2.可成功將此功能變數名稱解析到安裝 Winmail 伺服器的IP地址。
3.在 Winmail 中增加一個郵件功能變數名稱：domain.com，相對應的用戶郵寄地址為：username@domain.com
如果以上工作你都做了而仍然收不到郵件時，最大的可能性就是您的功能變數名稱解析出現了問題，請做以下測試。假設你的郵寄地址是: username@domain.com，請：
確認domain.com的MX記錄被指向了正確的位址；（可使用nslookup命令進行查詢）
nslookup命令的使用方式，mail exchanger = mail.nsmc.edu.cn內容就是nsmc.edu.cn功能變數名稱的MX記錄指向的真真實位址

C:\> nslookup

Server: dns.nsmc.edu.cn
Address: 211.83.0.66
>set type=mx
>nsmc.edu.cn (輸入您想解析的郵寄地址中“@”符號後的功能變數名稱)
Server: dns.nsmc.edu.cn
Address: 211.83.0.66
nsmc.edu.cn　　　　preference = 10, mail exchanger = mail.nsmc.edu.cn
smc.edu.cn　　　　nameserver = dns.nsmc.edu.cn
mail.nsmc.edu.cn　　　　internet address = 211.83.0.67
dns.nsmc.edu.cn internet address = 211.83.0.66

>exit

C:\>

您在得到了 mail exchanger = mail.nsmc.edu.cn 資訊後，請使用：
C:\> telnet mail.nsmc.edu.cn 25
命令以確認安裝在此機器上的 Winmail 服務程式可以正常工作。

為什麼我的 Winmail裝上以後，在遠端郵件用戶端使用pop3收信總是說密碼錯誤，而無法收信？ ↑
1) 沒有在Winmail中添加該用戶或添加了該使用者但密碼和郵件用戶端的設定不相同；
2) 埠衝突：因為Winmail使用了標準的smtp埠（埠：25）和pop3埠（埠：110），所以如果您運行Winmail的機器上已經佔用了這兩個主要埠時（如：已經架設有其他的郵件伺服器，MS Exchange 或 Windows 內置的smtp服務等），將會造成 Winmail 無法正常運行
3) 如果您將Winmail裝在撥號伺服器上時，有可能會因為同時啟動了WinGate程式而佔用了Winmail需要的110和25兩個埠，從而導至Winmail無法正常提供服務。
解決辦法：停止其他的郵件伺服器的服務或關閉其他佔用smtp及pop3埠的應用程式，或者開放WinGate的25和110兩個埠。
4) 非主域的用戶在Outlook或Foxmail設置中用戶名時要用寫全位址，如在一個非主域 abc.com 中的用戶 test 的用戶名要寫成 test@abc.com。

用 Outlook 2002 收信會出現停止回應的現象，怎樣解決？ ↑
這是Microsoft的bug, 請看 http://support.microsoft.com/default.aspx?scid=kb;EN-US;Q329349? , http://support.microsoft.com/?kbid=331866

接收郵件的附件是 winmail.dat， 無法打開，請問如何解決？ ↑
winmail.dat 是 Microsoft Outlook 發的 RTF 格式檔, 只能由Outlook打開。 解決的辦法一是 在Outlook設置不用 RTF 格式發郵件。 二是將winmail.dat另存, 用其它工具打開, 我們網站上有一個名為 wmopener 的工具可以展開這種附件(下載); 有關 winmail.dat 資料可以參見： http://www.ust.hk/itsc/email/tips/tnef/ 。從2.4版開始增加將 MS-TNEF (winmail.dat) 類型附件自動剝離功能, 您可以到“SMTP設置”功能裡設置啟用該功能。 從3.6版開始Webmail 增加將MS-TNEF (winmail.dat) 類型附件自動剝離功能。

能不能告訴我幾個能用的DNS伺服器地址？ ↑
直接詢問本地ISP服務提供者，也可以用 Google 的DNS: 8.8.8.8 和 8.8.4.4。

我有多個功能變數名稱 aaa.com, bbb.com, ccc.com，能夠實現一個用戶 user 可以對應於所有功能變數名稱？ ↑
可以配置域的別名。

怎樣申請動態DNS服務（可以方便架設ADSL互聯網郵件伺服器）？ ↑
國內用戶可以到 http://www.88ip.com 網站申請這些功能變數名稱解析服務。需要在伺服器上安裝一個88ip的用戶端軟體，就可以了。

是否一定要申請功能變數名稱並解析才能通過INTERNET收發郵件？ ↑
郵件系統一般都要和其他郵箱進行收發郵件，所以要有一個確定的功能變數名稱。如果僅是內部使用，則可以不要申請功能變數名稱。

網路是通的，輸入的密碼也是對的，我的管理端為什麼連不上伺服器？ ↑
出現上述情況可能是:
1. 管理端的版本要和伺服器端的版本不一致。
2. 可能是您通過防火牆聯接，但是防火牆沒有開放 Winmail 管理埠，管理埠缺省是6000，當然您可以改成其它。

郵件伺服器管理員密碼丟失後怎麼辦？ ↑
將server安裝目錄下的 adminuser.cfg 文件用記事本打開(對於 Winmail 4.3 以前的版本，修改 userauth.cfg 文件; 4.9 以後版本修改 data/adminuser.cfg)，將如下內容
<adminuser>
<item>
<username>admin</username>
<password>{md5}21232f297a57a5a743894a0e4a801fc3</password>
</item>
</adminuser>
修改為
<adminuser>
<item>
<username>admin</username>
<password>newpassword</password>
</item>
</adminuser>
然後就可以使用新密碼（newpassword)等錄，登錄進管理端後要及時更改管理員密碼。

申請了企業郵局之後，是否還有必要設置郵件伺服器嗎？ ↑
申請了企業郵局，可以不設置郵件伺服器，也可以架設自己的郵件伺服器。
架設自己的郵件伺服器的情況，有以下幾種：
1. 不是所有人都開設企業郵局的帳號。如：主管級以上人員開設外部帳號，大多員工使用內部郵件帳號。
2. 上網條件比較差，不能永久連接INTERNET。

我們公司現在有自己的功能變數名稱和企業郵箱，但現在自己建一個郵件系統。我想問的是能不能添加兩條MX記錄，使同一封信可以轉到兩個不同的郵件系統？ ↑
您可以架設好新的郵件系統，同時創建好所有的新郵箱，在非工作日的晚上，將MX指向到新的郵件伺服器。所有發過來的信都會自動發到新的郵箱中去。 這時候老的企業郵箱的信還是可以繼續用OUTLOOK，Foxmail來接收。只是不能收到外域郵件系統遞送來的信，所有外域發來信都發到了新的郵箱去了。

由於公司是通過FTTP＋Lan方式上網的，具體怎樣來設置呢？ ↑
請參見“系統應用方案”

Mail伺服器是否可以和用於撥號上網的伺服器分開？ ↑
不一定要裝在撥號上網伺服器上，可以裝在局域網內其它能訪問INTERNET的機器上。具體請見“Magic Winmail 郵件伺服器與代理伺服器軟體配合方案”。

如何手工對郵件系統的資料進行備份？ ↑
目前本系統本身沒有提供備份功能，計畫在以後的版本中增加此功能。目前您可以根據實際情況，用作業系統的計畫任務進行備任。具體方法如下：
1.備份郵箱帳號：可以將~/server目錄下所有尾碼後為.cfg的檔（4.9以後版本備份 ~/server/data/ 目錄），定時（設置作業系統的計畫任務）拷貝到其它目錄中。
2.備份用戶郵件：可以將~/server/store目錄打包後，定時（設置作業系統的計畫任務）拷貝到其它目錄中。
3.全備份：可以將~/server目錄打包後，定時（設置作業系統的計畫任務）拷貝到其它目錄中。
上述~指的是安裝時選擇的系統安裝到的目錄。默認為：C:\Program Files\Magic Winmail

郵件伺服器是否支援帳號許可權控制？例如，只能收不能發；收發的email能否自動在伺服器上保存並備份？ ↑
本郵件系統的可以對帳號設置許可權，如不能發郵件到外域，不能接收外域發來的郵件等。同時所有郵件也能自動備份到某一帳號或被某一管理員監控。

我的郵件系統被人作為垃圾郵件伺服器，現在已設SMTP認證，但佇列中有上萬封垃圾郵件，請問怎麼刪除？ ↑
先停止郵件系統，然後刪除郵件佇列目錄 (在“高級設置”/“系統參數”設置的“郵件佇列目錄”，預設是在 ~\server\queue)下的所有子目錄和檔， 系統會自動重新所有子目錄，重新開機郵件系統。~是本系統安裝時選擇的路徑，預設安裝在“C:\Program Files\Magic Winmail”。

別人發給我的信是存放到哪裡的？能不能長期存放？ ↑
別人發給系統中的郵箱使用者的信是存放在在“高級設置”/“系統參數”設置的“郵件存儲目錄”下(預設是在 ~\server\store)。當然可以長期存放。 ~是本系統安裝時選擇的路徑，預設安裝在“C:\Program Files\Magic Winmail”。

如何設置才能將服務某個特定網段的用戶使用？ ↑
在管理端的“系統服務”中，對於每一個服務都可以進行存儲設置，禁止或者許可指定主機位址或者網路位址的機器存取權限。

可否禁止使用TELNET 25 或 TELNET 110？ 如可以TELNET 25，可否禁止支持EXPN及VRFY？ ↑
TELNET 25 或 TELNET 110是不能禁止的。
本郵件伺服器沒有實現EXPN和VRFY命令，因為這兩個命令會引起伺服器安全性問題。現在郵件系統大多已經不實現了。

為什麼伺服器上安裝了諾頓 Norton 防毒程式後 Winmail 有時會自動關閉？ ↑
這種情況出現在Norton企業版, Norton網路版, Norton單機版。 由於諾頓可以直接殺信體檔的病毒, 和 Winmail 的佇列處理常式產生衝突, 導致系統資源佔用很大, Winmail 自動關閉。
解決辦法: 在諾頓中排除以下目錄:（如果在“高級設置”->“系統參數”中更改了“佇列存儲目錄”、“郵件存儲目錄”、“網路磁片存儲目錄”，請排除更改後的目錄。）
~\server\queue\bounce
~\server\queue\header
~\server\queue\msg
~\server\queue\status
~\server\queue\todo
~\server\store
~\server\webmail
~\server\netstore
~ 表示郵件系統安裝的目錄，預設為：C:\Programe Files\Magic Winmail
另外還要在諾頓中設置發現病毒自動刪除受感染的檔, 並且關閉警告提示, 刪除不成功則忽略。
然後在 Winmail 的"防病毒設置"選擇"病毒防火牆"模式。
詳細設置請看 Winmail 和諾頓防毒

在伺服器上安裝該軟體，伺服器配置正常。伺服器有一塊網卡，兩個位址，如何讓兩個位址都能正常使用？ ↑
對於上述出現的情況，SMTP，POP3屬性的“綁定位址”不應該設為固定位址（內部位址或為外部位址），應該設為0.0.0.0（伺服器上的所有IP地址）。

Winmail 是否支持自由申請，以及申請確認。 ↑
Winmail支持自由申請和申請確認。
管理員可以設置各個域是否允許Webmail申請，管理員可以選中左邊的“功能變數名稱設置”->“功能變數名稱管理”，然後修改一個域的擴展屬性中有關Webmail申請設置即可。

RBL 是什麼？ ↑
RBL 全稱是 Real-time Blackhole Lists, 是國外的反垃圾郵件組織提供的檢查垃圾郵件發送者位址的服務。
以下網址有幾乎所有國外RBL的列表. http://www.declude.com/junkmail/support/ip4r.htm, http://rbls.org/
常用的RBL伺服器地址有: dnsbl.njabl.org;bl.spamcop.net;sbl.spamhaus.org;dun.dnsrbl.net;dnsbl.sorbs.net
國內有CBL反垃圾郵件組織, 請看 http://www.anti-spam.org.cn, CBL伺服器地址有: cblless.anti-spam.org.cn;cbl.anti-spam.org.cn;cdl.anti-spam.org.cn;cblplus.anti-spam.org.cn

服務程式的註冊和登出命令是什麼？ ↑
Install service ---- MailServer /install
UnInstall service ---- MailServer /uninstall
Run as service ---- MailServer /service
Startup service ---- MailServer /startup
Stop service ---- MailServer /stop
Run as alone ---- MailServer /alone

如何查找功能變數名稱的 MX 記錄是否正確？ ↑
C:\> nslookup

Server: dns.nsmc.edu.cn
Address: 211.83.0.66
>set type=mx
>nsmc.edu.cn (輸入您想解析的郵寄地址中“@”符號後的功能變數名稱)
Server: dns.nsmc.edu.cn
Address: 211.83.0.66
nsmc.edu.cn　　　　preference = 10, mail exchanger = mail.nsmc.edu.cn
smc.edu.cn　　　　nameserver = dns.nsmc.edu.cn
mail.nsmc.edu.cn　　　　internet address = 211.83.0.67
dns.nsmc.edu.cn internet address = 211.83.0.66

>exit

C:\>

如果判斷我的郵件服務是否已經開啟發信認證？ ↑
為了防止郵件伺服器變成垃圾郵件轉發伺服器，現在架設在 Interent 上的絕大多數郵件伺服器都開設了發信認證功能。檢測方法如下：
C:\>telnet 119.119.119.212 25
Trying 119.119.119.212...
Connected to 119.119.119.212.
Escape character is '^]'.
220 steven.chinanusa.local Winmail Mail Server ESMTP ready
ehlo
250-steven.chinanusa.local Winmail Mail Server
250-PIPELINING
250-AUTH=NTLM LOGIN PLAIN
250-AUTH NTLM LOGIN PLAIN
250-STARTTLS
250-SIZE 5242880
250 8BITMIME
mail from: steven@abcdefg123.com (輸入一個非本系統中使用者的郵寄地址)
250 ok
rcpt to: steven@abcdefg123.com (輸入一個非本系統中使用者的郵寄地址)
553 sorry, you don't authenticate or the domain isn't in my list of allowed rcpthosts(#5.7.1)
quit
221 steven.chinanusa.local Winmail Mail Server
Connection closed by foreign host.

C:\>

如果上述輸入 rcpt to 命令後，出現 553 sorry, you don't authenticate or the domain isn't in my list of allowed rcpthosts(#5.7.1) 錯誤資訊就表示系統是需要認證的。

我已經開啟了發信認證，為什麼有時候發郵件不需要認證？ ↑
為了防止郵件伺服器變成垃圾郵件轉發伺服器，現在架設在 Interent 上的絕大多數郵件伺服器都開設了發信認證功能。有兩種情況下通過郵件系統發郵件是不需要認證：
1. 發信主機是信任主機；
2. 收信人所在的域是本系統中的域或信任域。

如何根據錯誤回彈信發現出錯原因？
錯誤回彈信格式通常如下:

Hi. This is the smtp delivery program.
I'm afraid I wasn't able to deliver your message to the following addresses.
This is a permanent error; I've given up. Sorry it didn't work out.
=====================================================
您好！
您的郵件不能成功的遞送到指定位址。這是一個永久的錯誤，因此不得不放棄繼續遞送。
<aaa@bbb.com>， sorry， no mailbox here by that name

注：以上反彈信中紅色部分內容才是錯誤的原因。

常見的錯誤回彈信
no mailbox here by that name: 系統中沒有該郵箱位址，請檢查收件人位址填寫是否正確。
don't find mail exchanger and domain's ip address: 郵件伺服器使用的DNS伺服器無法解析到收件人位址的功能變數名稱，請檢查功能變數名稱填寫是否正確；或更換郵件伺服器使用的DNS伺服器位址後重試。
connect remote host error (xxx.xxx.xxx.xxx : 25): 無法連接到收件人的郵件伺服器的25埠，原因可能為網路阻塞，對方郵件伺服器忙，或對方郵件伺服器IP地址已更換等。
mail size/count over quota (count : xxxx): 收件人郵件數量達到最大限制數。可以刪除一些郵件，或要求管理員增加該用戶能存放的最大郵件數。
mail size/count over quota (size : xxxx): 收件人郵箱容量達到最大限制數。可以刪除一些郵件釋放空間，或要求管理員增加該使用者郵箱的容量。
delivery failure: the message matches up to the filter rule(level: system， name: 1). 郵件符合過濾規則1的過濾條件，因此被過濾。
delivery failure: the message has been infected virus: 郵件中發現病毒。
anti-virus killed the attachment(s) with infected virus, file:test.rar: 防毒軟體清除了郵件中帶病毒的附件test.rar。
delivery failure: the message's attachment file (Filename: xxx.exe) matches the pattern string (Pattern: *.exe)： 郵件系統過濾尾碼為.exe的附件。附件過濾可以在管理工具->防病毒設置中設置。
delivery failure: the message's attachment number exceeds the limited: 郵件所帶的附件數量超過限制，請減少附件數或要求管理員增加郵件允許的最大附件數。
connect DNS server failure. 連接DNS伺服器失敗，可能你郵件伺服器上設置的DNS伺服器不是很穩定。可以換一個試試。
Relay server said: 554 too many hops, this message is looping (#5.4.6) 中繼遞送設置了不對，形成了遞送迴圈，不要設置中繼，直遞送試試。
也可以參考 Winmail 退信分析

發到 sina.com 的郵件會被退回
我發到 sina 的郵件會被退回，並提示"remote server said: 553 Spam Mail http://mail.sina.com.cn/FAQ.html"錯誤，怎麼辦？
1. 確認您郵件系統使用的功能變數名稱是合法的，而不是隨意填寫的。
2. 確認您的郵件伺服器使用的IP位址是固定的，而不是動態的IP位址。
3. 正確設置Winmail Server管理工具->系統設置->SMTP設置->基本參數->HELO/EHLO 主機名稱。可用nslookup命令查找，YourDomain MX preference = 10， mail exchanger =後面的內容即為正確的HELO/EHLO 主機名稱。
4. 如滿足以上三點，發到 sina 還是被退回相同的信件，請和 sina 聯繫。聯繫方式如下
郵箱地址：antispam@staff.sina.com.cn 或 lanjiang@staff.sina.com.cn
聯繫電話：010-82624488 轉 5602
也可以申請個 sina 的郵箱，在Winmail Server管理工具->系統設置->SMTP設置->外發遞送 中設置遞送失敗後啟用中繼遞送，中繼伺服器: smtp.sina.com.cn， 再輸入您在 sina 註冊的用戶名和密碼。

發到 tom.com 的郵件會被退回
我發到 TOM.COM 的郵件會被退回，並提示"550 CoremailSys:IP blocked by RBL，Please see http://whitelist.mail.tom.com"錯誤，怎麼辦？
1. 確認您郵件系統使用的功能變數名稱是合法的，而不是隨意填寫的。
2. 確認您的郵件伺服器使用的IP位址是固定的，而不是動態的IP位址。
3. 正確設置Winmail Server管理工具->系統設置->SMTP設置->基本參數->HELO/EHLO 主機名稱。可用nslookup命令查找，YourDomain MX preference = 10， mail exchanger =後面的內容即為正確的HELO/EHLO 主機名稱。
4. 如滿足以上三點，發送到 TOM.COM 還是被退回相同的信件，請到http://whitelist.mail.tom.com申請加入到TOM.COM的白名單。

發到 aol.com 的郵件會被退回
我發到AOL.COM的郵件會被退回，並提示"554- (RTR:DU) http://postmaster.info.aol.com/errors/554rtrdu.html"錯誤，怎麼辦？
AOL.COM除了要求您的郵件伺服器使用合法的功能變數名稱，固定公網IP位址，還需要該IP位址能夠作反向解析。但國內要申請作反向解析比較困難，所以我們可以使用中繼伺服器轉發，例如：
可以申請個 sina 的郵箱，在Winmail Server管理工具->系統設置->SMTP設置->外發遞送 中設置遞送失敗後啟用中繼遞送，中繼伺服器: smtp.sina.com.cn， 再輸入您在 sina 註冊的用戶名和密碼。

收到退信錯誤提示為"554 5.7.1 Rejected xxx.xxx.xxx.xxx found in dnsbl.sorbs.net"，怎麼辦？
這是因為收件人所在的郵件伺服器使用RBL過濾垃圾郵件，而您的郵件伺服器IP位址在RBL列表中，因此被拒絕了。一般此類的退信會包含一個連接，可以按網站上面的要求來申請把您的郵件伺服器IP地址從列表中移除。 也可以嘗試使用中繼伺服器轉發，例如：
可以申請個 sina 的郵箱，在Winmail Server管理工具->系統設置->SMTP設置->外發遞送 中設置遞送失敗後啟用中繼遞送，中繼伺服器: smtp.sina.com.cn， 再輸入您在 sina 註冊的用戶名和密碼。


常見問題

請訪問 http://www.winmail.cn/faq.php 查看網站上更全的常見問題

Webmail 相關問題
 我想在我們主頁上加入 Webmail 的登陸欄或自動登錄郵箱，如何實現？
如何更改 Webmail 發出郵件的底部簽名？
我想更換 Webmail 的 LOGO 圖片、 廣告圖片和提示資訊，如何實現？可以針對域定制圖片嗎？
我可以使用 http://mymailserver:6080 登陸 Webmail。如何換成 http://mymailserver登陸？
多功能變數名稱時，WebMail 登陸頁面使用者要選擇自己的域很不方便，怎樣解決？
怎樣在 WebMail 登陸頁面加自由申請功能？
Webmail 設置到 IIS 中無法修改口令和設置自動轉發等參數, 怎樣解決？
Webmail 設置到 IIS 中無法上傳附件, 怎樣解決？
Webmail 設置到 IIS 中, 頁面出錯, 怎樣解決？
為什麼當我在 Webmail 登陸時會出現“create com instance error”的提示？
Webmail 使用中, 顯示" Can't contact LDAP server" 出錯, 怎樣解決？
使用 WebMail 發信時，提示"SMTP Error:could not connect to SMTP host server(s)" 錯誤怎麼辦？
使用 WebMail 發信時，提示"SMTP Error: Data not accepted，552 sorry， the message size exceeds databytes limit (#5.3.4)"錯誤怎麼辦？
使用 WebMail 發信時，提示"SMTP Error: Invalid username/password 535 5.7.3 Authentication unsuccessful" 錯誤怎麼辦？
我想讓 Webmail 退出和錯誤返回到指定的網頁，如何實現？
如何開啟與關閉 Webmail 自動登錄功能？
如何開啟與關閉 Webmail 取回密碼功能？
設置用自己安裝的 PHP 程式後，Webmail 不能正常使用，怎麼解決？
如何在我的系統中能取得使用者新郵件數？
如何在我的系統中嵌入Webmail，以實現列郵件夾列表，讀郵件，寫郵件等工作？
怎麼更改預設的介面風格？

我想在我們主頁上加入 Webmail 的登陸欄或自動登錄郵箱，如何實現？ ↑
可以在您的頁面中增加如下代碼，注意要根據您的實際情況做修改。

<!--
action的值改為您的實現登錄URL
-->
<form name="form1" action="http://yourserverip:6080/login.php" method=post>
用戶名:&nbsp;<input type="text" name="f_user" value="" size="12" maxlength="32">
<!--
將yourdomain替換成您所要使用的功能變數名稱。
-->
<input type="hidden" name="f_domain" value="yourdomain">
密碼:&nbsp;<input type="password" name="f_pass" value="" size="12" maxlength="32">
<!--
選擇語言包，登錄後的語言
f_lang=en --- 英語
f_lang=ch_gb --- 簡體中文
f_lang=ch_big5 --- 繁體中文
-->
<input type="hidden" name="f_lang" value="ch_gb">
<input type="submit" name="submit" value="登錄">
<input type="reset" name="reset" value="重置">
</form>

如需要自動登錄，可以將上面上type="text" 改為 type="hidden"，然後在 value 中預先設置好用戶名與密碼，自動提交登錄

<script language="JavaScript">
document.form1.submit();
</script>

如何更改 Webmail 發出郵件的底部簽名？ ↑
可以在 Winmail 管理工具的“高級設置”->“系統參數”下的“系統簽名”中做修改。

我想更換Webmail的LOGO圖片、廣告圖片和提示資訊，如何實現？可以針對域定制圖片嗎？ ↑
有關LOGO的更改：
首頁、登錄後的頁面、使用者註冊頁面的 LOGO 檔都放在 ~\server\webmail\customer 下，可以直接替換，要保持檔案名一致， 圖片的長和寬儘量和原來的保持一致。

有關網頁 Title 和連結的更改：
請更改~\server\webmail\customer 下的所有語言檔 (*.txt) 的相關內容
common_page_title = WebMail | Power by Winmail Server
homepage = Power by Winmail Server
homepage_url = http://www.winmail.cn
contact_us = 聯繫我們
webmaster_mail = support@winmail.cn
banner_url = images/cn-banner.gif
請更改等於號右邊的內容，左邊的內容勿改動。

添加語言檔：
1. 請拷貝一份已有的語言的語言檔，並更名（副檔名為仍要為.txt），然後更改檔中各行的等於號右邊的內容，左邊的內容勿改動。
2. 在 ~\server\webmail\inc\config.languages.php 檔後，增加如下行：
$languages[] = Array(
"name" => "Simplified Chinese",
"path" => "ch_gb" //引號內更改為您的語言檔案名（不含副檔名）
);

禁止更改語言、設定預設語言、禁止修改介面風格、設定預設介面風格：
在管理端程式"系統設置"/"高級設置"/"Webmail設置"/"首頁設置"裡設置。

針對域定制圖片：
~\server\webmail\www\customer 目錄下的圖片
可以增加相同尺寸的圖片，將圖片的名稱前名加上相應的功能變數名稱和底線開頭
如登錄 look.com 域要顯示與其它域不同的圖片，則增加以下名稱的圖片:
look.com_banner.gif
look.com_index_logo.gif
look.com_index_winmail.gif
look.com_main_logo.gif

針對域定制說明文字：
~\server\webmail\www\customer 目錄下的語言檔（副檔名為 txt 的檔）
可以拷貝指定的語文件，將檔案名稱前名加上相應的功能變數名稱和底線開頭，然後打開修改中間的內容（等號右邊的）
如登錄 look.com 域要顯示與其它域不同的文本，則增加以下名稱的語言檔:
look.com_ch_gb.txt
look.com_en.txt
look.com_ch_big5.txt
look.com_it.txt
....

我可以使用http://mail.mymailserver.com:6080 登陸Webmail。如何換成http://mail.mymailserver.com登陸？ ↑
將HTTP服務的改為80埠即可，但要確保您的機器上沒有安裝其它 web server。
更改HTTP服務埠：請用管理工具登錄系統，選擇左邊的“系統設置”/“系統服務”，在右邊的頁面中選中“HTTP”然後點擊“編輯”，修改埠。
如果你的伺服器上已經安裝了IIS, 也可以將Webmail設置到IIS中, 請參考 如何能讓Webmail運行在IIS環境中。

多功能變數名稱時，WebMail登陸頁面使用者要選擇自己的域很不方便，怎樣解決？ ↑
2.4版後, 在域屬性裡增加了一個"直接訪問主機名稱"的參數, 添入該域的登陸URL即可實現登陸頁面只顯示該域, 例如有一個abc.com的域, 在DNS里加一個mail.abc.com指向郵件伺服器IP地址, 在"直接訪問主機名稱"輸入: mail.abc.com , 注意不要包括6080埠。

怎樣在WebMail登陸頁面加自由申請功能？ ↑
Winmail支持自由申請和申請確認。管理員可以設置各個域是否允許Webmail申請，管理員可以選中左邊的“功能變數名稱設置”->“功能變數名稱管理”，然後修改一個域的擴展屬性中有關Webmail申請設置即可。

Webmail 設置到IIS中無法修改口令和設置自動轉發等參數, 怎樣解決？ ↑
將Webmail\temp目錄，郵件存儲目錄和使用者資料庫檔的許可權中增加Everyone允許訪問，並將許可權設置為“完全控制”。
Webmail\temp目錄，其具體位置是在~\server\webmail\temp
郵件存儲目錄，其具體位置是在~\server\store
網路磁片存儲目錄，其具體位置是在~\server\netstore
使用者資料庫檔，其具體位置是在~\server\data\userauth.cfg
功能變數名稱資料庫檔，其具體位置是在~\server\data\domain.cfg

注意：
1. ~ 表示Magic Winmail安裝時選擇的目錄，?認是安裝在 C:\Program Files\Magic Winmail。
2. 目錄的許可權要選擇“將父系可繼承物件傳播給該物件”
3. 如果更改了“郵件存儲目錄”，請直接設置更改後的目錄許可權。

同時為了發郵件能上傳附件，還需要設置Windows 的 TEMP 目錄 C:\Winnt\temp(假設Windows 安裝在C:\Winnt 或 Windows 的 TEMP 目錄路徑沒有更改)目錄的許可權，增加Everyone訪問許可，並將許可權設置為“完全控制”。

Webmail 設置到 IIS 中無法上傳附件, 怎樣解決？ ↑
設置Windows 的 TEMP 目錄 C:\Winnt\temp(假設Windows 安裝在C:\Winnt 或 Windows 的 TEMP 目錄路徑沒有更改)目錄的許可權，增加Everyone訪問許可，並將許可權設置為“完全控制”。

Webmail 設置到IIS中, 頁面出錯, 怎樣解決？ ↑
如果是提示"Warning .... Permission denied in..."，是檔和目錄許可權沒有設置正確, 請按照幫助文檔重新設置目錄許可權。

為什麼當我在 Webmail 登陸時會出現“create com instance error”的提示？ ↑
這個問題可能是安裝時註冊COM元件出錯引起的。您可以重新手動註冊COM元件。“開始”功能表-》“運行”中行輸入cmd

先登出這個COM元件
C:>regsvr32 /u "~\server\XmlDataBase.dll"

重新註冊COM組件
C:>regsvr32 "~\server\XmlDataBase.dll"

在上述命令中，~表示安裝時選擇的系統安裝到的目錄。默認為：C:\Program Files\Magic Winmail
還有不要將 Winmail 安裝到在中文目錄中。

Webmail 使用中, 顯示" Can't contact LDAP server" 出錯, 怎樣解決？ ↑
這個問題可能是 LDAP 服務不能正常啟動引起的。
您用的 win2003 以上版本，系統中活動目錄服務。這樣就會和 LDAP 使用同一埠，
LDAP 就不能正常啟動。解決辦法，將 LDAP 服務的埠改為 489. 然後重啟一下即可。
如果還不能正常連接，請停止 Secure LDAP 服務，並將此服務屬性中不要選擇“本系統啟動時自動運行此服務”，然後重啟一下郵件系統即可。

使用 WebMail 發信時，提示"SMTP Error:could not connect to SMTP host server(s)" 錯誤怎麼辦？ ↑
1. 郵件伺服器上是否安裝瑞星防毒軟體？如安裝請參考 Winmail Server和瑞星郵件監控結合防毒;
2. 打開 Winmail 管理工具，檢查系統服務中的SMTP服務是否正常啟動。

使用 WebMail 發信時，提示"SMTP Error: Data not accepted，552 sorry， the message size exceeds databytes limit (#5.3.4)"錯誤怎麼辦？ ↑
該錯誤是因為發送的郵件大小超過了系統允許的最大位元組數而產生的，需要減小發送郵件的大小或增加系統允許發送郵件的最大位元組數(在 "SMTP 設置"功能裡設置)。

使用 WebMail 發信時，提示"SMTP Error: Invalid username/password 535 5.7.3 Authentication unsuccessful"錯誤怎麼辦？ ↑
該錯誤是因為Windows IIS的 smtp 服務沒有停止，請進入IIS管理程式停止它的smtp伺服器, 然後重新開機 Winmail 的smtp服務。徹底停止請到系統服務設置裡將"Simple Mail Transport Protocol (SMTP)"的啟動類型設為"手動"或"已禁用"。

我想讓 Webmail 退出和錯誤返回到指定的網頁，如何實現？ ↑
打開 ~\server\webmail\inc\config.php
查找以下內容，並將等號右邊內容修改為指定的 URL。
$logout_location = '';
如需要返回到 oa.winmail.cn 這個網站，請在等號右邊填寫 http://oa.winmail.cn

如果要針對每個功能變數名稱，設置返回到不同頁面，可以在修改 ~\server\webmail\www\customer 目錄下的語言檔（副檔名為 txt 的檔）
可以拷貝指定的語文件，將檔案名稱前名加上相應的功能變數名稱和底線開頭，然後打開在中檔的最後增加下面內容：
logout_location = http://oa.winmail.cn

如登錄 look.com，則增加以下名稱的語言檔:
look.com_ch_gb.txt
look.com_en.txt
look.com_ch_big5.txt
look.com_it.txt
....

如何開啟與關閉 Webmail 自動登錄功能？ ↑
只需要選中或取消“高級設置”->“Webmail 設置”中的“Webmail 允許自動登錄”即可。

如何開啟與關閉 Webmail 取回密碼功能？ ↑
只需要選中或取消“高級設置”->“Webmail 設置”中的“Webmail 登錄頁顯示'忘記密碼'”連接即可。

設置用自己安裝的 PHP 程式後，Webmail 不能正常使用，怎麼解決？ ↑
請參考 http://www.winmail.cn/setupiis/phpsetup.html 第二步, 修改 php 的設定檔php.ini

如何在我的系統中能取得使用者新郵件數？ ↑
可以使用 Winmail 中所提供的介面控制項中 GetFolderMsgCount 方法來取得。有關文檔請見：COM 組件功能
如果你的系統與郵件系統不在同一台機器，也可以通過 http 方式訪問指現的介面頁面來取得相關郵箱的郵件數。相關文檔可以參考 ~\server\webmail\doc 下的 get_newmsg_num 目錄文檔

http://yourmailserver:6080/getmsgnum.php?user=username&pass=CryptEncode(password)&folder=foldername&onlynew=1
user: 郵箱名
pass: 登錄密碼, 需要加碼
folder: 指定的郵件夾，沒有此參數，返回所有系統郵件夾
onlynew: 僅顯示新郵件，沒有此參數，返回新郵件和郵件總數。1 - 僅新郵件，0 - 新郵件和郵件總數
html: 返回結果輸出格式，沒有此參數，返回文本格式。1 - html 格式；0 - 文本格式
lng: 返回結果顯示的語言索引號，沒有此參數，為系統預設語言

如何在我的系統中嵌入Webmail，以實現列郵件夾列表，讀郵件，寫郵件等工作？ ↑
可以使用 Webmail 中所提供的專門嵌入式介面（僅有核心部份，去掉不必要的頁眉和頁腳資訊），相關文檔可以參考 ~\server\webmail\doc 下的 embed_interface 目錄中文檔

怎麼禁止修改介面風格和設定預設介面風格？ ↑
在管理端程式"系統設置"/"高級設置"/"Webmail設置"/"首頁設置"裡設置。


'Import namespace
'1. Startup VS
'2. Open project
'3. Right-click the project name in "Solution Explorer"
'4. Property pages
'5. Select "References"
'6. Click "Add Reference"
'7. Click "Com" lable
'8. Search "MailServerCtrl 1.0 Type Library"
'9. OK
'10. OK
'
'Import MailServerCtrl successfully
'

Imports MAILSERVERCTRLLib

Partial Class _Default
    Inherits System.Web.UI.Page
    Dim retCode As Short

    Protected Sub add_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles add.Click
        Dim maildb As MAILSERVERCTRLLib.MailDBInterface

        maildb = New MAILSERVERCTRLLib.MailDBInterface
        maildb.InitControl("C:\Program Files\Magic WinMail\server")

        retCode = maildb.AddUser(name.Text, domain.Text, pass.Text)
        If retCode = 0 Then
            Response.Write("Add user successfully<br>")
        Else
            Response.Write("Add user failed<br>")
        End If

    End Sub

    Protected Sub Delete_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles Delete.Click
        Dim maildb As MAILSERVERCTRLLib.MailDBInterface

        maildb = New MAILSERVERCTRLLib.MailDBInterface
        maildb.InitControl("C:\Program Files\Magic WinMail\server")

        retCode = maildb.DeleteUser(name.Text, domain.Text)

        If retCode = 0 Then
            Response.Write("Delete user successfully<br>")
        Else
            Response.Write("Delete user failed<br>")
        End If
    End Sub

    Protected Sub changepwd_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles changepwd.Click
        Dim maildb As MAILSERVERCTRLLib.MailDBInterface
        maildb = New MAILSERVERCTRLLib.MailDBInterface
        maildb.InitControl("C:\Program Files\Magic WinMail\server")

        retCode = maildb.ChangePassword(name.Text, domain.Text, pass.Text, newpass.text)

        If retCode = 0 Then
            Response.Write("Change user password successfully<br>")
        Else
            Response.Write("Change user password failed<br>")
        End If
    End Sub

    Protected Sub checkuser_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles checkuser.Click
        Dim maildb As MAILSERVERCTRLLib.MailDBInterface
        maildb = New MAILSERVERCTRLLib.MailDBInterface
        maildb.InitControl("C:\Program Files\Magic WinMail\server")
        retCode = maildb.Authenticate(name.Text, domain.Text, pass.Text)

        If retCode = 0 Then
            Response.Write("Check user successfully<br>")
        Else
            Response.Write("Check user failed<br>")
        End If
    End Sub

    Protected Sub domain_Add_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles domain_Add.Click
        Dim maildb As MAILSERVERCTRLLib.MailDBInterface
        maildb = New MAILSERVERCTRLLib.MailDBInterface
        maildb.InitControl("C:\Program Files\Magic WinMail\server")
        retCode = maildb.AddDomain(domain_name.Text)

        If retCode = 0 Then
            Response.Write("Add domain successfully<br>")
        Else
            Response.Write("Add domain failed<br>")
        End If
    End Sub

    Protected Sub domain_Del_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles domain_Del.Click
        Dim maildb As MAILSERVERCTRLLib.MailDBInterface
        maildb = New MAILSERVERCTRLLib.MailDBInterface
        maildb.InitControl("C:\Program Files\Magic WinMail\server")
        retCode = maildb.DeleteDomain(domain_name.Text)

        If retCode = 0 Then
            Response.Write("Delete domain successfully<br>")
        Else
            Response.Write("Delete domain failed<br>")
        End If
    End Sub

    Protected Sub Admin_Add_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles Admin_Add.Click
        Dim maildb As MAILSERVERCTRLLib.MailDBInterface
        maildb = New MAILSERVERCTRLLib.MailDBInterface
        maildb.InitControl("C:\Program Files\Magic WinMail\server")
        retCode = maildb.AddAdminUser(admin_name.Text, admin_pass.Text, admin_usertype.Text, admin_adminrange.Text)

        If retCode = 0 Then
            Response.Write("Delete admin successfully<br>")
        Else
            Response.Write("Delete admin failed<br>")
        End If
    End Sub

    Protected Sub Admin_Del_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles Admin_Del.Click
        Dim maildb As MAILSERVERCTRLLib.MailDBInterface
        maildb = New MAILSERVERCTRLLib.MailDBInterface
        maildb.InitControl("C:\Program Files\Magic WinMail\server")
        retCode = maildb.DeleteAdminUser(admin_name.Text)

        If retCode = 0 Then
            Response.Write("Delete admin successfully<br>")
        Else
            Response.Write("Delete admin failed<br>")
        End If
    End Sub
End Class


Winmail Control PHP Test

<% option explicit if request("dest")="submit" then Dim name,domain,pass,newpass,usertype,adminrange Dim maildb Dim retCode,sub_action,mode name = request("name") domain = request("domain") pass = request("pass") newpass = request("newpass") usertype = request("usertype") adminrange = request("adminrange") sub_action = request("sub_action") mode = request("mode") Set maildb = Server.CreateObject("MailServerCtrl.MailDBInterface") ' Winmail Server DB Path maildb.InitControl("C:\Program Files\Magic WinMail\server") Select Case sub_action Case "user" Select Case mode Case "add" retCode = maildb.AddUser(name, domain, pass) if retCode=0 then Response.write mode+" success
" else Response.write mode+" fail
" end if Case "delete" retCode = maildb.DeleteUser(name, domain) if retCode=0 then Response.write mode+" success
" else Response.write mode+" fail
" end if Case "changpwd" retCode = maildb.ChangePassword(name, domain, pass, newpass) if retCode=0 then Response.write mode+" success
" else Response.write mode+" fail
" end if Case "checkuser" retCode = maildb.Authenticate(name, domain, pass) if retCode=0 then Response.write mode+" success
" else Response.write mode+" fail
" end if End Select Case "domain" Select Case mode Case "add" retCode = maildb.AddDomain(domain) if retCode=0 then Response.write mode+" success
" else Response.write mode+" fail
" end if Case "delete" retCode = maildb.DeleteDomain(domain) if retCode=0 then Response.write mode+" success
" else Response.write mode+" fail
" end if End Select Case "admin" Select Case mode Case "add" Response.write pass Response.write domain retCode = maildb.AddAdminUser(name,pass, usertype, adminrange) if retCode=0 then Response.write mode+" success
" else Response.write mode+" fail
" end if Case "delete" retCode = maildb.DeleteAdminUser(name) if retCode=0 then Response.write mode+" success
" else Response.write mode+" fail
" end if End Select End Select set maildb=nothing end if %> Winmail Control PHP Test User
name: @
pass:
new pass:

Domain
domain

Admin
user
pass:
usertype:
adminrange:


#include "stdafx.h"
#include "atlbase.h"

#import "C:\\Program Files\\Magic WinMail\\server\\MailServerCtrl.dll" no_namespace

int main(int argc, char* argv[])
{
    CoInitialize(NULL);

    CLSID clsid;
    CLSIDFromProgID(OLESTR("MailServerCtrl.MailDBInterface"), &clsid);

    CComPtr <IMailDBInterface> pGetRes;

    pGetRes.CoCreateInstance(clsid);

    //Set winmail database path
    pGetRes->InitControl(L"C:\\Program Files\\Magic WinMail\\server");

    //Add new mail user
    int iRet = pGetRes->AddUser(L"winmail", L"test.com", L"mail123");

    if (iRet == 0)
        printf("Added user successfully");
    else
        printf("Added user failed");

    pGetRes.Release();

    CoUninitialize();

    return 0;
}


//Simple1: use JACOB call COM object

import com.jacob.com.Dispatch;

public class TestSimple {
    public static void main(String[] args) throws Exception {
        String result = "";
        try {
            Dispatch ids = new Dispatch("MailServerCtrl.MailDBInterface");

            //Set Winmail database path
            Object[] param1 = new Object[]{"C:\\Program Files\\Magic WinMail\\server"};

            Dispatch.call(ids, "InitControl", param1);

            //Add new mail user
            Object[] param2 = new Object[]{"winmail", "test.com", "Mail123"};
            result = String.valueOf(Dispatch.call(ids, "AddUser", param2));

            System.out.println("result: "+result);
            ids.safeRelease();
        }
        catch(Exception e)
        {
            e.printStackTrace();
        }
    }
}

//Simple2: use JCOM call COM object

public class TestSimple {
    public static void main(String[] args) throws Exception {
        ReleaseManager rm = new ReleaseManager();
        String result = "";
        try {
            IDispatch ids = new IDispatch(rm,"MailServerCtrl.MailDBInterface");

            //Set Winmail database path
            Object[] param1 = new Object[]{"C:\\Program Files\\Magic WinMail\\server"};
            ids.method("InitControl", param1));

            //Add new mail user
            Object[] param2 = new Object[]{"winmail", "test.com", "Mail123"};
            result = String.valueOf(ids.method("AddUser", param2));

            System.out.println("result: "+result);
        }
        catch(Exception e)
        {
            e.printStackTrace();
        }
        finally {
            rm.release();
        }
    }
}


Winmail Control Test

InitControl("C:\Program Files\Magic WinMail\server"); switch($sub_action){ case 'user': switch($mode) { case 'add': $retCode = $ctrl->AddUser($name, $domain, $pass); switch($retCode){ case 0: echo '0 - Add success
'; break; case 1: echo '1 - The paramenter is error
'; break; case 2: echo '2 - Existed the same mail user
'; break; case 3: echo '3 - Existed the same mail group
'; break; case 4: echo '4 - Existed the same mail alias
'; break; case 5: echo '5 - In the domain, The user number has attache the limition
'; break; case 6: echo '6 - In the domain, The user available space has attache the limition
'; break; case 7: echo '7 - The domain isn\'t exist.
'; break; default: echo $retCode.' - Invaild return
'; break; } break; case 'delete': $retCode = $ctrl->DeleteUser($name, $domain); switch($retCode){ case 0: echo '0 - Delete success
'; break; case 1: echo '1 - Delete failure
'; break; default: echo $retCode.' - Invaild return
'; break; } break; case 'changpwd': $retCode = $ctrl->ChangePassword($name, $domain, $pass, $newpass); switch($retCode){ case 0: echo '0 - Change password success
'; break; case 1: echo '1 - The paramenter is error
'; break; case 2: echo '2 - The old password is error or user not exists
'; break; case 3: echo '3 - Modify user failure
'; break; default: echo $retCode.' - Invaild return
'; break; } break; case 'checkuser': $retCode = $ctrl->Authenticate($name, $domain, $pass); switch($retCode){ case 0: echo '0 - Check user success
'; break; case 1: echo '1 - The paramenter is error
'; break; case 2: echo '2 - Check user failure or user not exists
'; break; default: echo $retCode.' - Invaild return
'; break; } break; case 'modify': $retCode = $ctrl->ModifyUser($name, $domain, "test", "test", "test", "test"); switch($retCode){ case 0: echo '0 - Check user success
'; break; case 1: echo '1 - The paramenter is error
'; break; case 2: echo '2 - Check user failure or user not exists
'; break; case 3: echo '3 - Modify user failure
'; break; default: echo $retCode.' - Invaild return
'; break; } break; case 'chguserinfo': break; case 'chgquota': $retCode = $ctrl->ModifyUserQuota($name, $domain, 20*1024*1024, 0, 0, 50*1024*1024, 0); echo $retCode.'
'; break; case 'chgright': $retCode = $ctrl->ModifyUserRight($name, $domain, 0, 0, 0, 0, 0, 0, 0, 0); echo $retCode.'
'; break; case 'chgstatus': $retCode = $ctrl->ModifyUserStatus($name, $domain, 0); echo $retCode.'
'; break; default: echo 'mode error
'; break; } break; case 'domain': switch($mode) { case 'add': $retCode = $ctrl->AddDomain($domain); switch($retCode){ case 0: echo '0 - Add domain success
'; break; case 1: echo '1 - The paramenter is error
'; break; case 2: echo '2 - Existed the same domain
'; break; default: echo $retCode.' - Invaild return
'; break; } break; case 'delete': $retCode = $ctrl->DeleteDomain($domain); switch($retCode){ case 0: echo '0 - Delete success
'; break; case 1: echo '1 - Delete failure
'; break; default: echo $retCode.' - Invaild return
'; break; } break; default: echo 'mode error'; break; } break; case 'admin': switch($mode) { case 'add': $retCode = $ctrl->AddAdminUser($name, $pass, intval($usertype), $adminrange); switch($retCode){ case 0: echo '0 - Add administrator success
'; break; case 1: echo '1 - The paramenter is error
'; break; case 2: echo '2 - Existed the same administrator
'; break; default: echo $retCode.' - Invaild return
'; break; } break; case 'delete': $retCode = $ctrl->DeleteAdminUser($name); switch($retCode){ case 0: echo '0 - Delete success
'; break; case 1: echo '1 - Delete failure
'; break; default: echo $retCode.' - Invaild return
'; break; } break; default: echo 'mode error
'; break; } break; case 'group': switch($mode) { case 'add': $retCode = $ctrl->AddGroup($name, $domain, $description, $memberlist, $right, $senderlist); switch($retCode){ case 0: echo '0 - Add group success
'; break; case 1: echo '1 - The paramenter is error
'; break; case 2: echo '2 - Existed the same mail user
'; break; case 3: echo '3 - Existed the same mail group
'; break; case 4: echo '4 - Existed the same mail alias
'; break; case 5: echo '5 - The domain isn\'t exist.
'; break; default: echo $retCode.' - Invaild return
'; break; } break; case 'modify': $retCode = $ctrl->ModifyGroup($name, $domain, $description, $memberlist, $right, $senderlist); switch($retCode){ case 0: echo '0 - Modify success
'; break; case 1: echo '1 - Modify failure
'; break; default: echo $retCode.' - Invaild return
'; break; } break; case 'delete': $retCode = $ctrl->DeleteGroup($name, $domain); switch($retCode){ case 0: echo '0 - Delete success
'; break; case 1: echo '1 - Delete failure
'; break; default: echo $retCode.' - Invaild return
'; break; } break; default: echo 'mode error
'; break; } break; default: echo 'sub_action error
'; break; } echo '
'; } ?> Winmail Control Test User
mailbox: @
pass:
new pass:

Domain
domain:

Admin
user:
pass:
usertype:
adminrange:

Group
group: @
description:
memberlist:
right:
senderlist:


與代理伺服器軟體配合 - 普通模式

普通模式

代理軟體﹕CProxy, CCProxy, Sygate, WinGate, WinRoute, WinProxy, ISA Server2000。
網路環境﹕Winmail和代理伺服器軟體裝在同一臺機器﹐內部IP為192.168.0.1, 外部IP為61.177.18.66。

1.CProxy

正常裝設CProxy和 Winmail後﹐即可使用﹐兩者並無衝突。

2.CCProxy

要將CCProxy的郵件代理功能關閉。

3.Sygate

要將"啟用增強的安全機制"選項關閉。

4.Wingate

Wingate啟動後﹐會把smpt, pop3服務綁定到ip位址127.0.0.1上。所以﹐需停止wingate的smtp,pop3服務。
1)按一下"Control", 進入"System"。
2)連續按兩下"SMTP Server", 在彈出的視窗選擇"Bindings"頁﹐在"Bound"欄連續按兩下所有的ip, 取消smtp綁定﹐按Apply → OK。如下圖﹕

或者也可以修改Winmail的SMTP, POP3服務連接埠號。 有關操作請見系統服務

5.WinRoute Pro

WinRoute Pro和 Winmail裝同一機器﹐需停止WinRoute的NAT功能。
1)Settings → Interface Table → 選中網卡﹐點擊“屬性”→ 在彈出的對話方塊中取消NAT功能。如下圖所示﹕

6.WinRoute Lite

需允許winRoute Lite打開所有連接埠。
1)Settings → Settings → Security → 打開所有連接埠。如下圖﹕

7.WinProxy

WinProxy啟動後﹐會把SMTP, POP3服務綁定到ip位址0.0.0.0上。所以﹐需停止WinProxy的smtp,pop3服務。同時讓WinProxy工作在Classic Proxy模式。
1）File->Advanced Settings->設定用戶端存取模式。如下圖﹕

2）File → Settings → Protocols﹐勾掉Mail服務 → 確定。如下圖﹕

或者也可以修改Winmail的SMTP, POP3服務連接埠號。有關操作請見系統服務

8.ISA Server 2000

ISA啟動後﹐並不跟 Winmail衝突﹐但由於ISA的預設方式是內部網內﹐及內部網和外網並不能互相通訊﹐所以要加入相應的過濾規則﹐以便 Winmail可正常收發Mail。
1）Access Policy → IP Packet Filters → 開新文件Filter, 填入external_smtp（可任意）→ 選擇 "Allow packet transmission" → 選擇"Custom" → 設定protocol, 連接埠等﹐如下圖 → 選擇 "Default IP addresses for each external on the ISA Server computer" → 選擇"All remote computes" → 點擊"完成"。如下圖所示

2）Access Policy → IP Packet Filters → 開新文件Filter, 填入internal_smtp（可任意）→ 選擇"Allow packet transmission" → 選擇"Custom" → 設定protocol, 連接埠等﹐如上圖所示 → 選擇"This compute（on the perimeter network）", 填入IP 192.168.0.1﹐如下圖所示 → 選擇"All remote computers" → 點擊"完成"。如下圖


與代理伺服器軟體配合 - 映射模式

映射模式

代理軟體﹕CProxy, CCProxy, Sygate, WinGate, WinRoute, WinProxy, ISA Server2000。
測試環境﹕代理伺服器（機器名為proxy）綁定2個IP,其中內部IP為192.168.0.1, 外部IP為61.177.18.66。裝有Winmail的機器（機器名為mail）IP為192.168.0.2。mail在內部網中﹐通過代理伺服器proxy收發郵件。Proxy負責把郵件伺服器映射到mail機器。如圖所示﹕

1.CProxy設定

映射SMTP Server
1）按一下"設定" → "連接埠映射" →"E" 。
2）在彈出視窗填入映射連接埠號和IP位址﹐如圖所示。

映射POP3 Server步驟同上﹐只是把連接埠25改為110。

2.CCProxy設定

映射SMTP Server
1）按一下Protocols → SMTP Options。
2）在彈出視窗填入映射連接埠號和IP位址﹐如圖所示。重起服務。

映射POP3 Server步驟同上﹐只是把連接埠25改為110。

3.Sygate設定

映射SMTP Server
1)按一下Access Rules, 在彈出對話方塊選擇"Add"。
2)選中"Import a rule from system", 在下拉框選擇"Mail(SMTP)Server"﹐按OK。
3)在彈出的對話方塊中﹐"Direction"欄選擇"IN", "PROTOCOL"欄選擇"TCP", "CLIENT IP"填入192.168.0.2, "DesPort"添入25。如下圖所示﹕

映射POP3 Server步驟同上﹐只是把連接埠25改為110。

4.WinGate設定

映射SMTP Server
1)按一下"Control", 進入"system"。
2)連續按兩下"SMTP Server", 在彈出的視窗選擇"Bindings"頁﹐在"bound"欄連續按兩下所有的ip, 取消smtp綁定﹐按Apply → OK。如下圖﹕

3)進入"Services", 加入"TCP Mapping Service", 選擇"General"頁﹐在"Start Option", 服務模式選為選擇"Service will start automatic", 服務連接埠填入25﹐在"Default Maping"中﹐"Service"填入192.168.0.2, "on"填入連接埠25。如下圖﹕

選擇"Binding"頁﹐選擇IP 61.177.18.66進行綁定Smtp服務。

映射POP3 SERVER步驟同上﹐只是把連接埠25改為110。

5.WinRoute Pro設定

映射SMTP Server
1)選擇選單Settings → advanced → Port Mapping。
2)在彈出視窗按一下"add", Protocl選TCP, 連接埠填入25﹐目標ip填入192.168.0.2, 目標連接埠25。如下圖所示﹕

映射POP3 SERVER步驟同上﹐只是把連接埠25改為110。

6.WinRoute Lite設定

映射SMTP Server
1）Settings → Settings → Port Mapping → 加入連接埠映射規則。如下圖:

映射POP3 SERVER步驟同上﹐只是把連接埠25改為110。

7.WinProxy設定

映射SMTP Server
1)選擇選單 file → advanced settings → Map Ports
2)按一下new, 再彈出的視窗中﹐服務連接埠填入25﹐ 目標ip填入192.168.0.2, 目標連接埠填入25﹐ 個數填入1。 Type / Protocol選擇TCP, DIRECTION 選擇 Incoming。如下圖﹕

映射POP3 Server步驟同上﹐只是把連接埠25改為110。

8.ISA Server 2000的組態

映射SMTP Server
1）加入過濾規則﹐使外網的機器能存取proxy的25連接埠。
Access Policy → IP Packet Filters → 開新文件Filter, 填入external_smtp（可任意）→ 選擇 "Allow packet transmission" → 選擇"Custom" → 設定protocol, 連接埠等﹐如下圖 → 選擇 "Default IP addresses for each external on the ISA Server computer" → 選擇"All remote computes" → 點擊"完成"。

2）加入過濾規則﹐使在內部網中﹐proxy能與mail在25連接埠通訊。
Access Policy → IP Packet Filters → 開新文件Filter, 填入internal_smtp（可任意）→ 選擇"Allow packet transmission" → 選擇"Custom" → 設定protocol, 連接埠等﹐如上圖所示 → 選擇"This compute（on the perimeter network）", 填入IP 192.168.0.2﹐如下圖所示 → 選擇"All remote computes" → 點擊"完成"。

3）映射smtp服務。
Publishing → Server Publishing Rules → 開新文件Rules → 填入IP位址﹐如下圖 → 在下拉框中選擇 "SMTP Server" → 選擇"any request" → 點擊"完成"。

映射POP3 Server步驟同上﹐只是把連接埠25改為110。

4）關於的 ISA SMTP Filter
ISA 缺省是關閉"SMTP Filter", 如果你開啟了"SMTP Filter"會導致 smtp 認證無法使用, 這時你可以按 http://www.isaserver.org/tutorials/smtpauth1.html 設定 ISA 以加入對 smtp auth 的支援。


與代理伺服器軟體配合

Winmail 郵件伺服器可方便地跟常用代理伺服器軟體配合使用。一般 Winmail和代理伺服器軟體裝設有兩種方式

普通模式 | Winmail和代理軟體裝設在同一臺機器﹐該機直接連在Internet上。 代理伺服器設定﹕CProxy 3.4.3, CCProxy 5.30, SyGate 4.5, WinGate 5.0.1, WinRoute Pro 4.2.5, WinRoute Lite 4.2.5, WinProxy 5.0, ISA Server 2000
映射模式 | Winmail裝設在區域網路內部的某臺機器﹐通過代理軟體來映射SMTP,POP3服務。 代理伺服器設定﹕CProxy 3.4.3, CCProxy 5.30, SyGate4.5, WinGate 5.0.1, WinRoute Pro 4.2.5, WinRoute Lite 4.2.5, WinProxy 5.0, ISA Server 2000